Martyn

New Ford Fiesta - How Many Faults Does Yours Have?

Recommended Posts

Have a 59 plate Titanium 1.6 petrol

This would have been a great car from new but for the following faults

1. Creaking from the suspension, top strut mounting fault: rectified

2. Steering fault, new steering rack fitted : rectified

3. Rear door seal came away from door frame : rectified

4. Rear door panel pressing fault: repaired badly

Back at Fords at present due to:

Rough steering AGAIN !

Passenger footwell carpet coming away from body

strange whine coming from Drivers side mirror when folding electrically

Engine "pinking" under acceleration/load

Nobody has mentioned the grotesque vibration from the plastic door pockets caused by the use of the stereo: fixed this myself

I'm sick to death of driving Ford courtesy cars !!!!!!!!!!!!!!!

Share this post


Link to post
Share on other sites
 

Have a 59 plate Titanium 1.6 petrol

This would have been a great car from new but for the following faults

1. Creaking from the suspension, top strut mounting fault: rectified

2. Steering fault, new steering rack fitted : rectified

3. Rear door seal came away from door frame : rectified

4. Rear door panel pressing fault: repaired badly

Back at Fords at present due to:

Rough steering AGAIN !

Passenger footwell carpet coming away from body

strange whine coming from Drivers side mirror when folding electrically

Engine "pinking" under acceleration/load

Nobody has mentioned the grotesque vibration from the plastic door pockets caused by the use of the stereo: fixed this myself

I'm sick to death of driving Ford courtesy cars !!!!!!!!!!!!!!!

how did you fix this?

i too get a anoying vibration from the passenger side when my radio is on

Share this post


Link to post
Share on other sites

....after the heavy rain we've had lately ,im fed up how quickly it gets steamed up, the vents open blowing cold but every window was at it :angry: , but , BUT , my main annoyance is the squeal I keep getting after 15 minutes or so ,and its worse if i'm turning slightly to the right :huh: , tried the sharp braking trick to no avail Ggrrr :(

Share this post


Link to post
Share on other sites

how did you fix this?

i too get a anoying vibration from the passenger side when my radio is on

Not very technical but it worked for me: if you run your hand along the door pocket towards the back of the car you will come to the point where the door pocket meets the main door moulding, I found that the door pocket vibrates against the main moulding here: I cut a felt pad (the type that you stick on the bottom of chair legs to protect a laminate floor)down to size and rammed it between the door pocket and moulding which stopped the vibration. Cant believe that so few have mentioned this irritational fault on here. This lack of attention to design IMO is very poor especially when so much thought has obviously gone into other areas.

Share this post


Link to post
Share on other sites

No faults from the car so far touch lap top (no wood close by).My moan is the placing of the electric window switches.How far back are they.

Share this post


Link to post
Share on other sites

Had my 60 plate 1.6 Titanium since september and Its had to go in as the bonnet was not sitting flush. Also the seal on the drivers door was not stuck on properly. Both fixed now and Ive sent a right stinky letter to Ford, Im not going to hold my breath for any kind of compo though!!

Share this post


Link to post
Share on other sites

Dear All,

I am the "proud" owner of a Fiesta Titaniam on an 09 plate, its spec is:

  • 3dr titanium
  • avalon blue
  • 17" alloys upgrade from standard titanium.
  • keyless/power button
  • usb + bluetooth + voice control

From the begining i have had a few problems with it,

1. Drivers door window seal had to be re adjusted 4 times! solved.

2. Passenger Door Locks had to be replaced 2 times, and still not right.

3. Usb and line in socket was very loose so replaced, solved.

4. Plastic loose bits in the head lining rattling, solved.

5. Inidicator problem mentioned in other threads, still not right.

6. sqeaky peddals, seems to be solved,

7. radio looses bass with adaptive volume enabled, still not right

8. sqeaky wing mirrors when folding in past their point, still not right,

i since found out they have changed the radio and so am currently pressing them to uprade the radio, it is a great car i know it sounds daft after all mentioned above, but it is a dream to drive and with all the features on it, its so easy, very pleased, just annoyed with all the issues im having. I would buy another which i guess is the main thing just want these things sorted :(.

PLEASE REPORT BACK TO ME ABOUT YOURS.

Probably teething problems with the new model, you might have one of the first built, they often sit at the ports for ages in storage before delivery to dealers (months if that spec is not ordered)

Share this post


Link to post
Share on other sites

Had 1.4 TDCi since July 2009 - 16800 miles.

I've had

1.) Cold weather starting - engine would crank for 10 seconds, or longer - and occasionally "miss" (Dunno how else to describe it) how old diesels often do when they're struggling to catch. Semi-fixed by "Software update" - but still occasionally sounds like it's struggling to start when the temperature is low (It's never NOT started first time, it just has that air of struggling a little)

2.) Fuel leaks out - replaced fuel filler neck, didn't fix the problem. Then got told that I'm not filling the car up properly. HAHA! There is an overflow pipe, which, if you hold the fuel nozzle in wrong - fuel comes out of it. Design fault for sure, but Ford are fobbing people off by telling them they don't know how to fuel it properly, which is total BS, they just wont recall it for that.

3.) When it's been raining a lot or is wet - I get a whistly rough noise at low revs. Goes away when driven for 20 minutes or longer (ish) - doesn't sound that great though. Overall there is a little bit of turbo whiney-ness, but only in 1st and 2nd gear. This might be the transmission though I guess (Any comments?)

4.) Rattling interior - I pull over a lot and hit it. A lot. Crap plastics, don't sit flush, etc.

5.) Squeaky/rattling at about 2000 RPM when accelerating hard - doesn't happen outside of this - if you put the windows down you can't hear it - only IN the car (but it's NOT inside the cabin) - anyone got any idea what this could be!? Doesn't do it when you hit your cruising speed and it fades to nothing when you get near 3000 RPM, or decelerating.

6.) Power steering feels nice and light when I set off, then relatively heavy when I get to where I'm going. Like it can only give me proper power for a bit, then runs out of juice. Not that much of a problem really.

7.) Idle - if i flick to neutral and coast, the car sometimes nearly stalls - revs drop quite low, then they pick up and sometimes will shoot over 1k RPMs. With climate control off, or in cold weather - car is stallable and feels a bit weak and pathetic. In warm weather with the climate control on - I get more revs at idle and it's impossible to stall! Again, just irritates me a bit.

8.) under the bonnet there are bits of rubber and plastic and trim which have come loose or do not fit properly. No wonder I get 4.) and 5.) really in that case is it!

Car is ok - I lease it til 2012 - will not be having another Ford though.

Wouldnt mind any comments or ideas relating to 4, 5, 6 or 7? Interested to know if these items have appeared on any of your fiestas - particularly with the same engine (1.4 or 1.6 TDCi)

Cheers!

Share this post


Link to post
Share on other sites

2.) Fuel leaks out - replaced fuel filler neck, didn't fix the problem. Then got told that I'm not filling the car up properly. HAHA! There is an overflow pipe, which, if you hold the fuel nozzle in wrong - fuel comes out of it. Design fault for sure, but Ford are fobbing people off by telling them they don't know how to fuel it properly, which is total BS, they just wont recall it for that.

hi monkeyalan. how much did it cost you to get the easy capless fixed? i hate the easy capless tech together with the always unlock gas lid cover. were you guys able to find a workaround on this?

Share this post


Link to post
Share on other sites

OK, here goes:

1.6 TDCi Titanium, usb, BT, voice control, ESP/EBA, sealing kit, Dark Grey, Lumbar support., March 09 plate, 20,500 miles on the clock, mostly quiet, some spirited driving.

What I love:

  • Learnt to drive through thick snowfall and ice on the first night of snow after Xmas on the M25 from heathrow to Canterbury. The ESP was on about 3/4 of the way, and saved my life. Full points for this Ford.
  • Similarly, lost traction around a roundabout at low speed after fresh rain; ESP put me back into place. Thanks ford :-)
  • Stereo sound is phenomenal. Makes JBL Speakers in peugeot 306 sound like kettle bleepers.
  • fantastic capacity. I put in my entire 8 piece drumkit and the missus with her long legs in the car with spare space for a cup o tea
  • Hands free BT connection is just the bees' knees.

Faults:

  • Blown wiper fuse during the snows last winter; replaced for free.
  • Front left main beam bulb gone; £16 to fix.
  • Tracking gone TWICE so far; had to replace front tyres as the inside of one of the two was below legal depth (put on Michellin SP3's)
  • Reverse gear doesnt go in always, needs clutch release and retry; Ford calls this a 'standard feature of asynchronous gear boxes'. What???
  • Rattling plastics when bass at high volumes; I guess its good to keep you from tinnitus, but I'll try the felt fix anyway
  • "iPhone does not recognise this accessory" - firmware upgrade should be complimentary by Ford as a sign of good customer service and appreciation. From another point of view, this is as much a comfort as a safety feature: if they upgrade the firmware then the driver will be less distracted by ipod/iphone operation during driving ;-)
  • Auto wiper sensitivity is crap; they are either too sensitive (off to full speed wiping), or insensitive (manual flicking needed)
  • Right indicator auto cancels too early around a roundabout.
  • Voice control os dreadful when dialling numbers. I dont have a funny accent, despite my name!
  • MPG is never near where its meant to be. Driving spirited on the motorway means about 45 mpg using Texaco or BP Ultimate Diesel. In town driving it gives me around 50 mpg on a spirited run, 55 MPG on calm driving. I am only 31 though, so I 'll leave it to the old ladies. Rating went down last spring by about 10 mpg, but Ford said this might happen due to ageing?! Seems to have been a fuel quality issue, a colleague noticed the same with his vectra

.

The big problem:

- Loss of power on 1st gear, not always when the engine is cold. This has nearly cost my life, twice. Ford cannot find the fault so wont do anything about it. This is serious and I find their response irresponsible.

Overall, I am really happy with the consumption, handling, resiliance, comfort, audio quality and general feel of the car. I hope they sort out the 1st gear and reverse gear issues though. Should be under warranty anyway...

Share this post


Link to post
Share on other sites

OK, here goes:

1.6 TDCi Titanium, usb, BT, voice control, ESP/EBA, sealing kit, Dark Grey, Lumbar support., March 09 plate, 20,500 miles on the clock, mostly quiet, some spirited driving.

What I love:

  • Learnt to drive through thick snowfall and ice on the first night of snow after Xmas on the M25 from heathrow to Canterbury. The ESP was on about 3/4 of the way, and saved my life. Full points for this Ford.
  • Similarly, lost traction around a roundabout at low speed after fresh rain; ESP put me back into place. Thanks ford :-)
  • Stereo sound is phenomenal. Makes JBL Speakers in peugeot 306 sound like kettle bleepers.
  • fantastic capacity. I put in my entire 8 piece drumkit and the missus with her long legs in the car with spare space for a cup o tea
  • Hands free BT connection is just the bees' knees.

Faults:

  • Blown wiper fuse during the snows last winter; replaced for free.
  • Front left main beam bulb gone; £16 to fix.
  • Tracking gone TWICE so far; had to replace front tyres as the inside of one of the two was below legal depth (put on Michellin SP3's)
  • Reverse gear doesnt go in always, needs clutch release and retry; Ford calls this a 'standard feature of asynchronous gear boxes'. What???
  • Rattling plastics when bass at high volumes; I guess its good to keep you from tinnitus, but I'll try the felt fix anyway
  • "iPhone does not recognise this accessory" - firmware upgrade should be complimentary by Ford as a sign of good customer service and appreciation. From another point of view, this is as much a comfort as a safety feature: if they upgrade the firmware then the driver will be less distracted by ipod/iphone operation during driving ;-)
  • Auto wiper sensitivity is crap; they are either too sensitive (off to full speed wiping), or insensitive (manual flicking needed)
  • Right indicator auto cancels too early around a roundabout.
  • Voice control os dreadful when dialling numbers. I dont have a funny accent, despite my name!
  • MPG is never near where its meant to be. Driving spirited on the motorway means about 45 mpg using Texaco or BP Ultimate Diesel. In town driving it gives me around 50 mpg on a spirited run, 55 MPG on calm driving. I am only 31 though, so I 'll leave it to the old ladies. Rating went down last spring by about 10 mpg, but Ford said this might happen due to ageing?! Seems to have been a fuel quality issue, a colleague noticed the same with his vectra

.

The big problem:

- Loss of power on 1st gear, not always when the engine is cold. This has nearly cost my life, twice. Ford cannot find the fault so wont do anything about it. This is serious and I find their response irresponsible.

Overall, I am really happy with the consumption, handling, resiliance, comfort, audio quality and general feel of the car. I hope they sort out the 1st gear and reverse gear issues though. Should be under warranty anyway...

Share this post


Link to post
Share on other sites
  • "iPhone does not recognise this accessory" - firmware upgrade should be complimentary by Ford as a sign of good customer service and appreciation.

It is! Take it back to your dealer and get them to upgrade it. Will be covered under 3yr warranty.

Share this post


Link to post
Share on other sites

Drove 17k miles in my mk7 zetec and done 9k miles in my ZS and apart from some minor rattle that was fixed on the zetec

not 1 issue

Share this post


Link to post
Share on other sites

Had my "10" reg 1.25 Zetec Fiesta for a month now, bought it when 6 months old and only 2,000 miles on the clock. Pleased with the car and the ride is great, especially around town. Was worried the 1.25 would be screaming on the motorway but it handles it pretty well.

Some niggles...

1. Whining/squealing from clutch after a cold start - only noticed this 3 or 4 times, and always when started from cold (and on an icy morning). When you press the clutch in there's a noticeable high pitched kind of whine, almost a squeal but not that loud. Seems to only last the first time you press it in, and when you release the clutch it stops. Once things start to warm up it doesn't do it again. Have mentioned it to the dealer but they said they'd need to keep the car in overnight and try it - and as it doesn't do it very often I think I'll just keep an eye on it at the moment and see it it continues or gets any more frequent.

2. Exhaust loud after a a motorway journey - noticed that when I come off the motorway, or after any reasonable length of journey, the exhaust sounds really loud, almost like a boy racer's. I was concerned it was blowing, or perhaps one of the joints was expanding when it gets hot. So, asked the dealer to check it, they said it was normal and that it was probably due to the hole that Ford put in the silencer - apparently this is designed to allow water to drain out of the exhaust and stop it rusting! I must admit, I've never heard of anything like this, sounded like a line they were using - anyone know if this is BS, or are they telling the truth?

3. Slight knocking noise from power steering at low speeds or when parking - sounds like a common one this, related to the speed sensitive power steering. Only notice it when parking, changing steering from full lock to striaght. Guess I'll live with this one, as it seems to just be a "characteristic" of the power steering system!

4. Hissing from Speakers when stereo is turned off - not a niggle as such, and not sure if this is what others have mentioned as being a buzzing from the console. If I switch everything off and take the ignition key out, you can still hear a slight hissing from the Speakers if you put your ear to them - especially the top door ones, near the door handles. It sounds like the stereo is still switched on, even though it isn't - not mentioned this to the dealers, as I'm sure they'll think I'm mad, but was just concerned that this might drain the battery over a length of time!

5. Rattling/vibrating from front dash, driver's side - I think from where the dash meets the "A" pillar plastic cover. Great design, shame about the finish and quality of plastics! Will have to experiment with some padding in that area - shouldn't have to on a nearly new car though!

Don't get me wrong, I love driving the car so far, a definite upgrade from my previous Fiesta Mk 5 Zetec - just wish Ford had put as much effort into the engineering and electronics as they've obviously put into the design of the Mk7 Fiesta.

Share this post


Link to post
Share on other sites

18 months old with around 22k on the clock

I've had issues with the stereo since day one, bass problems which i worked my way around with a new sound system. Ford just fobbed me off saying it was fine.

My front passenger wheel has a very high pitch sqeek coming out of it when taking corners at low speed.

And lately I've been having exhaust problems. The exhaust is VERY loud, I'm only getting 33MPG (1.25 Zetec) and loss of power.

I took it to Fords but once again they just said it was fine (due to condensation aparently). So I took it elsewhere to find that the exhaust has problems.

Drivers window makes a clonking noise when going down.

Covers under front whell arches are loose due to the clips pulling out.

Replaced both headlight bulbs TWICE.

Probably more that i will remember later.

Share this post


Link to post
Share on other sites

I have an 09 plate 1.4TDCi Zetec.

HAd the car for a week and am very impressed.

One minor niggle - the storage compartment on the drivers side keeps dropping down whilst driving.

Anyone else had the same problem.

Thinking of sticking on one of those "thin" self adhesive magnets to cure.

Any other solutions out there?

Share this post


Link to post
Share on other sites

2. Exhaust loud after a a motorway journey - noticed that when I come off the motorway, or after any reasonable length of journey, the exhaust sounds really loud, almost like a boy racer's. I was concerned it was blowing, or perhaps one of the joints was expanding when it gets hot. So, asked the dealer to check it, they said it was normal and that it was probably due to the hole that Ford put in the silencer - apparently this is designed to allow water to drain out of the exhaust and stop it rusting! I must admit, I've never heard of anything like this, sounded like a line they were using - anyone know if this is BS, or are they telling the truth?

It isn't BS. See http://www.bosal.co.uk/Portals/9/Local/Docs/AM01_Drain_Hole.pdf

Share this post


Link to post
Share on other sites

This is my list of faults.

Clunking Steering.

The Steering on My fiesta clunks at low speeds when negotiating a parking space or on full lock when parking.

The Steering also clunks if you were to wobble the steering wheel from left to right Engine on or off.

Front Suspension.

The Front Suspension creaks when turning Right or Left at junctions

The front suspension Creaks and knocks when going over speed humps at any speed.

Brakes

The front Brakes make a grinding noise but not all the time it is often louder than the brakes normally sound.

Also we have heard a squeeking noise coming from the brakes it also feels like the brakes are dragging.

Mirrors

The Powerfold mirrors touch the chrome trim running alongside when folding in and also make squeeking noises when folded in.

Gearbox

The 4th Gear crunching problem seems to have subsided a little it was happening when changing from 3rd to 4th when accelerating.

One other problem I have noticed when driving is that 5th gear whines a little at above 60mph when cruising and can sometimes be heard when accelerating above 60mph.

Audio/usb/Bluetooth

The bluetooth Element of the Audio system in my car Loses all stored devices at regular intervals when I say devices I refer to mobile Telephones

The Usb element of the Audio system sometimes will not recodnise an ipod.

When making a Telephone Call The microphone has on one occasion only stopped working completely and relied on my pulling over turning the car off for a few minutes to reset the system as it would not respond to turning the audio system off the conventional way.

Also When Hanging up after a Telephone Call The Audio system Freezes/Crashes and will not respond to any commands and means I have to find somewhere to pull over to reset the system by manually turning the car off for a few minutes to reset.

On once occasion The Audio system remained Frozen/Crashed for over two days it would not respond to any key presses even the on/off button.

Interior Cabin

The Dashboard area of the car rattles.

To be precise the Rattling occurs around the a pillars and occurs at low speeds etc especially on bumpy roads.

There is a Rattle coming from the Area around the Drivers Side Rear quarter panel that occurs most of the time and leads me to believe that the speaker contained in the rear quarter panel is actually loose. It happens more when warm.

There is a rattle coming from the boot (More like a buzzing really) Even if the boot is infact empty.

There is an electrical buzzing coming from around the audio system that stay on even when the car is switched off and also when driving

Driving along etc.

When first starting the car from cold the engine sounds grouchy ie lumpy.

When driving along with a cold engine the car is hesitant at lower speeds and seems almost like it is misfiring.

When driving along sometimes when using cruise control when driving along a flat road or about to go down a very small hill (not too steep) I can feel the car hesitating again as if it is misfiring.

All in all I wish this car was as well built as it looks.

Jamie

Share this post


Link to post
Share on other sites

Hey there everyone, im very new to all this and im know that i made a huge mistake trading in my Ford Fiesta MK6 ST for this MK7 Fiesta

i need help please, im currently driving a 09 plate 1.4tdci, 21k miles, and from new i have had a misfire/hesitation around 2/2.5 revs hot or cold,its been in for 2 regens at my local ford garage , it went back for the third time yesterday and the chap from ford came down to look at it as there are 4 other ford fiestas with the same fault, All they done was recalibrated the engine for the third time, before when this was done the problem reoccured after 3/5 days so i will see what happens i just need feed back please , as my local ford garage said to me yesterday the only thing i can do is buy a focus!!

what a joke !!

thanks guys

Share this post


Link to post
Share on other sites

Had my 60 plate 1.6 Titanium since september and Its had to go in as the bonnet was not sitting flush. Also the seal on the drivers door was not stuck on properly. Both fixed now and Ive sent a right stinky letter to Ford, Im not going to hold my breath for any kind of compo though!!

Compo?

They fixed it didn't they!!

!Removed! world today, owt for nowt.

Share this post


Link to post
Share on other sites

Just done a 700 mile round trip to Newquay and broke through the 5000 mile marker. Still no faults and 46mpg, not bad out of a 1.4 at my motorway speeds. ;)

Share this post


Link to post
Share on other sites

Audio/usb/Bluetooth

The bluetooth Element of the Audio system in my car Loses all stored devices at regular intervals when I say devices I refer to mobile Telephones

The Usb element of the Audio system sometimes will not recodnise an ipod.

When making a Telephone Call The microphone has on one occasion only stopped working completely and relied on my pulling over turning the car off for a few minutes to reset the system as it would not respond to turning the audio system off the conventional way.

Also When Hanging up after a Telephone Call The Audio system Freezes/Crashes and will not respond to any commands and means I have to find somewhere to pull over to reset the system by manually turning the car off for a few minutes to reset.

I have this issue with the mic (but on many more than one occasion!) and the freezing/locking up.

Also lumpy when cold.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now