Jump to content
Do Not Sell My Personal Information


Car Won't Start


JamesChilds123
 Share

Recommended Posts

I have a 1.7 ford puma which one day decided not to start, it turns over and there is also fuel going into the engine just no spark at the plugs, I plugged it into a diagnostic reader and a number of faults came up, 2 for the coil pack, 1 for the camshaft sensor and 1 for the manifold pressure sensor.

I replaced the camshaft sensor, coil pack and spark plugs, still nothing, I plugged it back into the diagnostic reader which cleared the camshaft problem and 1 of the coil pack problems, now I just have one for the manifold pressure sensor and the coil pack (code is p0351), I have bought a new crankshaft sensor but haven't got round to fitting it yet as I can't get the old one off, could the crankshaft sensor be the cause of the p0351 code? Just wondering if there is any common faults with these engines as I really don't know what else to try.

Thanks in advance

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership