• Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save


olisun

Steering Wheel Remote Not Working

Recommended Posts

Hi,

A few yrs back I successfully replaced the stereo on my Ford C-Max 08 reg twice with 2 different Sony
after market units including the steering wheel control and it has been
working fine until today when I tried to replace the unit with a JVC
one.

I got the JVC patch lead hooked up to the stereo and also got the steering wheel controls working for a short time.

Now the steering wheel controls have stopped working and to debug the issue I installed my previous working Sony unit and the steering controls still don't work.

I tried replacing the stalk adaptors and the problem still persists.

I am not sure what else to look for.

Any ideas or pointers?

Share this post


Link to post
Share on other sites

Found out that the JVC unit was "faulty" and it seems to be the case with a few models.



Switched over to a Kenwood unit of similar spec and it is working as expected.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now