Jump to content
Do Not Sell My Personal Information


Upgraded Org. Sat Nav Unit, Now No Bluetooth & Usb Connection


ssd1984
 Share

Recommended Posts

Hi, I hope that someone can help me.

I just upgraded my boring blue monochrome display to a colour display with navigation.

Everything was plug and play, and it works perfect! except no voice guidence in navigation :-/ and I lost my bluetooth, and usb too :-(, I think it might be the bluetooth module for the old radio(with monochrome display) that cause the problem, and I have a new one(came with the navigation unit) for the navigation unit, my problem is, where is this module located??

Link to comment
Share on other sites


Yeh, worked straight away, which xvision sensors you have?are they the flush fit or semi flush fit, part number on xvision module, should be located behind rear side trims which ever side the wires run in to car, also check if the oem multiplug is in same location, if its not there , then the interface module needs wiring diferentely

thenits just needs switching on in central car configuration on ford diagnostics

Here is the module I´m talking about..

Link to comment
Share on other sites

Parts diagram suggests it lives in the middle of the dash - it's not that common for module positions to change with different territories, apart from LHD and RHD as the amount of kit they try and cram in doesn't usually leave many options for where things end up being mounted.

G023520304.jpg

Link to comment
Share on other sites

AHA down there! it was dark, so I couldn't see anything, and I didn't take the heater temp controls apart, maybe therefore I couldn't find it! doh! I will try again tomorrow!..Do you think its the problem that cause the bluetooth, usb & navi voice guidence? or is it something else??? Everything worked before the upgrade..

Link to comment
Share on other sites

That could be why then, your sat nav not compatable with sync module which does voice/usb

Aah, then I have to fit the sync module that came with this navi unit, and it will work right?? If I can find the old one in the car haha ;-) I will try that tomorrow

Link to comment
Share on other sites

I am afraid you have the wrong type of satnav system for your car.

The old Bluetooth/Voicecontrol module which came with your 2011 satnav is the oldest type of module that was ever used on a Focus MK3. This is basically the same system which was also used on the Focus MK2.5. This system is not compatible with your car at all if it has the SYNC 1.0 (SYNC) or SYNC 1.5 (SYNC with APPlink) system. The wiring of the old Bluetooth/Voicecontrol system is completely different from the much newer SYNC system. There are also differences between audio/satnav systems of these different systems.

This basically means that the old 2011 satnav system you have is not suitable for your 2013 Focus. I suppose if should be possible to make it work by changing the complete interior wiring loom for an older (pre-SYNC) version and also change some settings of the car's Central Configuration.

The easiest way to make it work is by installing the correct type of radio for your car.

Link to comment
Share on other sites

The SYNC system uses a completely different module than the old Bluetooth/Voicecontrol system. The SYNC (APIM) module is a bit larger and has different wiring and connections.

Link to comment
Share on other sites

  • 2 months later...

Hi there. I am in exactly the same boat as yourself. I have a 63 plate focus zetec tdci and bought a navigation system from a 2014 titanium ( sony fascia). Plugged it in all works fine except for no voice instructions. Did you ever manage to get to the bottom of it?

Link to comment
Share on other sites

Hi there. I am in exactly the same boat as yourself. I have a 63 plate focus zetec tdci and bought a navigation system from a 2014 titanium ( sony fascia). Plugged it in all works fine except for no voice instructions. Did you ever manage to get to the bottom of it?

Hi there.. No I didnt, I sold it on eBay for £80 :-/ and bought a china unit with big touch display for £300, it works perfect with navigation & bluetooth :-D
Link to comment
Share on other sites

hi. thanks for the reply I might just have one last play with it this weekend and see if I can get something sorted. its probably something stupid that needs activating to make it work. so you would recommend one of the Chinese models then? does it do DAB or just normal FM? and is it plug and play. cheers

Link to comment
Share on other sites

Yeah maybe it just a activation.. I dont know.... Yes I can recommend a chinese model, great display and just plug and play, the steering wheels still working.. Unfortunately No DAB, only FM..

Link to comment
Share on other sites

I recently retrofitted the OEM Sat Nav system to my 2013 Focus MK3 without any problems.

The Sat Nav system is fully controlled by the FCDIM module (display) of the audio system. The radio unit itself is not a part of the SAT NAV system. However there are several different radio units with or without support for the Sat Nav system.

My car did originally have the "High Level" audio system with SYNC and the 3.5 Inch monochrome FCDIM module. The radio unit of this audio system is completely identical to the radio unit of the OEM Sat Nav system. I compared part numbers between my car and a car of the same age with OEM Sat Nav and my radio unit appeared to be identical.

After I installed the 5 Inch color FCDIM module and changed the settings for the FCDIM in the Central Configuration of the car the Sat Nav settings and menu appeared on the radio menu. Afterwards I only had to install a suitable GPS antenna and an SD-card with maps to make the system work. The Sat Nav system does even work without the radio panel with "NAV" button. The Sat Nav functions can also be selected from the radio menu.

After a quick test the Navigation audio was missing. The missing Navigation audio is caused by missing wiring between the FCDIM module and the radio unit. To solve this you have to connect 2 wires as follows:

Radio Unit connector C1 Pin 4 (NAV AUDIO IN +) To FCDIM connector C1 Pin 6 (AUDIO LINE OUT +)

Radio Unit Connector C1 Pin 5 (NAV AUDIO IN -) To FCDIM connector C1 Pin 12 (AUDIO LINEOUT -)

After I installed these wires the Navigation audio was fully functional.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...

Forums


News


Membership