Jonny_T2002

Retrofitting A Sat Nav To A 2014/2015 (Facelift) Focus

Recommended Posts

 

On 20/10/2016 at 8:40 AM, Bannko said:

If anyone else is interested in activating the NAVI through the proper way with licence - you can also contact me.

I am able to generate the licence.

Hi mate please can you message me i want to add the nav to my car cheers

Share this post


Link to post
Share on other sites

@Bannko

Sorry for knocking on your door as well. :tongue:

Just bought a 2016 Focus Estate, and also fell for the assumption that touchscreen meant navigation. Checked, it's running Sync 2 with software version 3.10, and "Information System" in the upper-right corner. Have an original F5 SD-card from my previous car (which did have satnav, but was totalled by a drunk racing through the street).

Can you please enlighten me via PM as to how to move on from here?

Share this post


Link to post
Share on other sites

@Bannko I see you are the man in know and was hoping you could offer some advice.

 

I purchased a Focus T EcoBoost 2016 (Sync 2) from a dealer in the knowledge the Navigation worked - Low and behold the navigation has not been enabled.

Before I spend hours trying to get my head around how to do this, is it still possible to be done ?

Any advice is much appreciated.

 

Share this post


Link to post
Share on other sites

Hi Guys, I have recently bought a 2014 face lift Focus Titanium with Sync 2. I would really love to add the satnav feature to this car. It has the compass and emergency assist, so I'm guessing I can activate and buy the correct SD map card?

I have previously made small mods to Audi's using VCDS, so have a small understanding of coding, but Fords are a new area to me. Would anybody be able to steer me in the right direction of what hardware and software I need to obtain and also the correct procedure?

Thanks very much.

Share this post


Link to post
Share on other sites

I wonder if anyone can please help me.

I'm currently looking for a newer car to replace my oldish Mondeo. It's been a long search including looking at various cars. Today I went to look at a Focus 1.5 Ecoboost Estate and travelled 70 miles only to find out that it doesn't have a sat nav. Silly me presumed that a Titanium with Sync 2 would have that as standard however it doesn't.

I thought I'd get online to see if there are any upgrade options and I stumbled across this and another thread which seems to suggest some hope for adding sat nav.

I'd be very grateful if Bannko or anyone else with instructions could please get in touch to let me know if it is possible and also how. If it is possible then I'll be getting back in touch with the dealer to say I'll have it.

Hope to hear from someone.

Dave

Share this post


Link to post
Share on other sites

Hi brand new to forum, today  just bought a 2017 Mondeo.

could Bannko be so kind to PM me the details too so I can fix my wife’s 2016 Focus? We were told the vehicle had Satnav but it didn’t, they gave us a Tom Tom but I’d still like to upgrade the Sync2.

terrific stuff Bannko.

Share this post


Link to post
Share on other sites

@Bannko would it be possible to send me the instructions for the satnav activation? 

I am picking up my car on wednesday and this would be great to add to it.

thanks for your help in advance

kind regards 

scott

Share this post


Link to post
Share on other sites
1 hour ago, Scott1980 said:

@Bannko would it be possible to send me the instructions for the satnav activation? 

I am picking up my car on wednesday and this would be great to add to it.

thanks for your help in advance

kind regards 

scott

sync 2 no sat nav ?

Share this post


Link to post
Share on other sites

Yes, it is to sync 2. To sync3 it is a little but difficult.

Share this post


Link to post
Share on other sites

On 10/20/2016 at 8:40 AM, Bannko said:

If anyone else is interested in activating the NAVI through the proper way with licence - you can also contact me.

I am able to generate the licence.

@Bannko. Yes please Tomas. From reading this thread it should be possible to enable on my 2015 Mk3 facelift Focus with Sync2 ver 4.32.14073

I have an ELM327 cable and have successfully connected it up to a PC running Forscan. 

If I understand the thread here and some I Googled on other forums there are two ways of achieving the same end but one is potentially not permanent?

I'd be most grateful for any pointers as to how to go about it. Thanks in advance.

David

Share this post


Link to post
Share on other sites

@MangoFury you are correct mate. 😉 you also have prepared the Forscan so that is great will PM you more on detail what you have to do next.

In the meantime you also have to update your sync because sat nav activation will not work on that 4.32

Please check this thread:

https://www.fordownersclub.com/forums/topic/79328-update-sync-2-the-easy-way/?page=6&tab=comments#comment-646367

Share this post


Link to post
Share on other sites

Hi Bannko,

Have been searching how to do this with my Sync 2. Could you please PM details. Would really appreciate your advice and guidance.

Thanks

Share this post


Link to post
Share on other sites
On 9/21/2017 at 9:07 PM, Stoney871 said:

Bannko

Hi bannko, sorry to bother you as I've seen you have been very busy on here but could you also PM me please as I am finding it very difficult to find out how to do it, thank you 😊

Share this post


Link to post
Share on other sites

Many thanks to Bannko for all the help in getting my SatNav successfully enabled. It needed an upgrade of the APIM software from 4.32 to 3.10 and then enabling the SatNav using Forscan and a TunnelRat Electronics ELM327 cable. Also got the cluster display between the tacho and speedo showing the summary SatNav instructions. Did that using Forscan also as the method using the FoCCCus software didn't work. It's running F7 maps on a sub-£10 64GB SD card. All-in-all a reasonably cheap exercise to enable something that really should be a default factory fit in this day and age...

Out on the road the SatNav is a little quirky. Heading north on the A1197 in Cambridgeshire turning left onto the A14 - standard four road interchange - "take the fifth exit". You mean drive past the exit you want, have a look at the other three, then take the first one... 😄. I don't think so...

And at the A45 junction further west (SatNav setup for fastest route), go down the slip road, across the roundabout under the A14 and back up again. Genius. At least it's entertaining...

Don't blindly follow it's instructions is the moral.

All pretty straightforward, great instructions and backup from Bannko. Thanks again!

Share this post


Link to post
Share on other sites
Many thanks to Bannko for all the help in getting my SatNav successfully enabled. It needed an upgrade of the APIM software from 4.32 to 3.10 and then enabling the SatNav using Forscan and a TunnelRat Electronics ELM327 cable. Also got the cluster display between the tacho and speedo showing the summary SatNav instructions. Did that using Forscan also as the method using the FoCCCus software didn't work. It's running F7 maps on a sub-£10 64GB SD card. All-in-all a reasonably cheap exercise to enable something that really should be a default factory fit in this day and age...
Out on the road the SatNav is a little quirky. Heading north on the A1197 in Cambridgeshire turning left onto the A14 - standard four road interchange - "take the fifth exit". You mean drive past the exit you want, have a look at the other three, then take the first one... . I don't think so...
And at the A45 junction further west (SatNav setup for fastest route), go down the slip road, across the roundabout under the A14 and back up again. Genius. At least it's entertaining...
Don't blindly follow it's instructions is the moral.
All pretty straightforward, great instructions and backup from Bannko. Thanks again!
How did you add the nav on the speedo cluster using forscan? I couldn't get focccus to work so skipped it as I'm assuming you need the wired Elm.



Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

@MangoFury Not a problem mate 😉

Btw 

The maps are provided by HERE company. And a lot of time happen that even in the newest maps some roads are missing. The simple solution to this is actually us, the community. If you find such a road you can report it directly to the HERE and they will maybe fix this in future update. Check the link:

https://www.ford.co.uk/owner/resources-and-support/sync-bluetooth/ford-sync-3-navigation-help

 

@Bally12345 Emailed you other instructions how to add the nav into cluster with Forscan. Focccus was primary developed only for MK3 Focus so there are more factors why it just don't work on MK3.5 like wifi ELM has a very slow speed connection and so on. But using WiFi ELM and editing car's settings is very dangerous. In case the connection will be lost just for a second during writing to car, then it is 90% change you will kill your car and it won't start. That means a lot of stress bringing it back to life, lol.

Share this post


Link to post
Share on other sites
[mention=99228]MangoFury[/mention] Not a problem mate
Btw 
The maps are provided by HERE company. And a lot of time happen that even in the newest maps some roads are missing. The simple solution to this is actually us, the community. If you find such a road you can report it directly to the HERE and they will maybe fix this in future update. Check the link:
https://www.ford.co.uk/owner/resources-and-support/sync-bluetooth/ford-sync-3-navigation-help
 
[mention=98389]Bally12345[/mention] Emailed you other instructions how to add the nav into cluster with Forscan. Focccus was primary developed only for MK3 Focus so there are more factors why it just don't work on MK3.5 like wifi ELM has a very slow speed connection and so on. But using WiFi ELM and editing car's settings is very dangerous. In case the connection will be lost just for a second during writing to car, then it is 90% change you will kill your car and it won't start. That means a lot of stress bringing it back to life, lol.
I will probably swap the WiFi version for USB in that case

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.