Jonny_T2002

Retrofitting A Sat Nav To A 2014/2015 (Facelift) Focus

Recommended Posts

Thanks for the information.

I will get the licence soon. Is this hard to install?

Jamie

Share this post


Link to post
Share on other sites
 

If anyone else is interested in activating the NAVI through the proper way with licence - you can also contact me.

I am able to generate the licence.

Share this post


Link to post
Share on other sites

Okay,

Bit of an issue. Ordered an F5 card off eBay and car is still saying insert Nav SD card. Tried a master reset of Sync and still the same.

Speaking with Bannko I've discovered I also need to activate the navi cluster on FoCCCus as well as changing the hex on ForScan. 

As I only activated the Nav on ForScan I assumed the SD card wasn't being read as I hadn't done the FoCCCus step. Tried to do this and discovered the USB cable I ordered is knackered. Two Windows laptops are not detecting the cable at all!

So need to check three things:

1) SD card is legit!

2) USB cable replaced and check ForScan changes have been set and then check FoCCCus. (I thought I could do one or the other)

3) Navi Licence file. Not sure if the unlock has worked and hence I can't open the SD card.

 

Anyone have any thoughts?

Share this post


Link to post
Share on other sites

Should work without cluster change.

Did you put some music on another sd and see if it is seen......just in case  there's a wiring issue  ?

Dodgy or faulty card usually gives a faulty sd card warning on screen.

 

Share this post


Link to post
Share on other sites

Will try that in the morning!

Really been set back with the USB adapter not working.

Starting to think it is the licence now to be honest.

Share this post


Link to post
Share on other sites

Thanks very much to Bannko & Richiemac for their help.

Seems as if getting a licence file done the trick rather than using the free unlock to activate sat nav.

Will use FoCCCus to complete the final part of activating the instrument cluster but just using ForScan and the licence done the trick.

 

IMG_2835.JPG

Share this post


Link to post
Share on other sites

I seem to have similar problem now, I've been able to change the forscan values and I now have the insert nav card and "information" icon. However the nav card i created doesnt seem to be read. I also cannot connect to Focccus for some reason, It seems to get stuck on connecting to ecu. So I dont know if the cards correctly setup or if I need to get into focccus to change the cluster settings. Any help would be appreciated?

Share this post


Link to post
Share on other sites

The thing that really helped me was the licence file.

Bannko supplied this to me, bundled with a Sync update so it was a case of installing/reinstalling Sync from the USB stick, so it was a fresh install and working.

Once I got the Sat Nav working I then activated the cluster with FoCCCus afterwards. 

Share this post


Link to post
Share on other sites

Yep, the Focccus thing is only optional. The navi will stil work also without it. But it is nice to have it also on your cluster

Share this post


Link to post
Share on other sites

Must admit that when I did my nav a few months ago I applied the Foccus part but no additional info pops up on the cluster.

Bannko, can you PM me the process and what I should be seeing on the IC?

Sent from my SM-G930F

Share this post


Link to post
Share on other sites

Can this be done but as a temporary thing? Cheers guys

Share this post


Link to post
Share on other sites
8 hours ago, Stoney871 said:

Must admit that when I did my nav a few months ago I applied the Foccus part but no additional info pops up on the cluster.

Bannko, can you PM me the process and what I should be seeing on the IC?

Sent from my SM-G930F

 

2 hours ago, rm9 said:

Can this be done but as a temporary thing? Cheers guys

 

Have sent you both a private message :) have a good day.

Share this post


Link to post
Share on other sites

Hi

Recently purchased a focus have made sd card enabled options etc.

Can you possibly tell me how to get the nav info on the drivers cluster as well please?

John

Share this post


Link to post
Share on other sites
38 minutes ago, jmacp1808 said:

Hi

Recently purchased a focus have made sd card enabled options etc.

Can you possibly tell me how to get the nav info on the drivers cluster as well please?

John

 

Hey there John,

you have to download the Focccus software: http://ford.xtlt.ru/FoCCCus/FoCCCus_0.8.6.zip

Run it in your car with ELM calbe and change this value #172 to value as seen on the screenshot:

b5c094deb8da3117med.jpg

 

But you have to have the cluster with the bigger color display:

d31f906eff0e2abfmed.jpg

Share this post


Link to post
Share on other sites

Managed to get sat nav activated and unlocked.

Sd Card required the key file to be placed at the root of the card!

However I cannot for the life of me get focccus to connect to the car any advice?

 

John

 

Share this post


Link to post
Share on other sites
On 10/30/2016 at 9:31 PM, jmacp1808 said:

Managed to get sat nav activated and unlocked.

Sd Card required the key file to be placed at the root of the card!

However I cannot for the life of me get focccus to connect to the car any advice?

Hallo John, the only thing that comes to my mind is faulty ELM cable or it does not support something. If you connect the ELM cable to your pc and open the Device Manager - can you see what port is assigned to it? (e.g. COM1,COM2,COM3...)

Share this post


Link to post
Share on other sites

Hi

I am computer literate luckily so I've went through a pile of drivers and get the same message continually "cant connect to ECU" changed date rates etc as well.

Does focccus work with the 2015 Focus?

Thanks John

 

Share this post


Link to post
Share on other sites

Foccus works fine on the mk3.5 Focus.

Sounds like a bad/clone ELM cablw or problems with auto-allocation of the computers port baud rate.

Sent from my SM-G930F

Share this post


Link to post
Share on other sites

Followed all the guides and got the Nav working on the Sync 2 and enabled the cluster option as well.

However I can't get the sd card to work. Display shows the prompt to insert sd card but no matter where I put the sdcard.key file it doesn't pick it up.

I've put the sdcard.key in the root of the sdcard and also tried it in nuance\vca\data.

 

Anyone have any tips on what I can try? Also when using the genfordkey do you keep the first radio button selected?

 

Many thanks

Jon

Share this post


Link to post
Share on other sites

Did you use the sd card keygen software that gives 3 possible keys?

I found that the first one didn't work but the second one did for me.

Sent from my SM-G930F

Share this post


Link to post
Share on other sites
4 minutes ago, Stoney871 said:

Did you use the sd card keygen software that gives 3 possible keys?

I found that the first one didn't work but the second one did for me.

Sent from my SM-G930F

yeah I tried all 3. I put the sdcard.key in at the root e.g. \sdcard.key and also tried it at \nuance\vca\data\sdcard.key

I'll format the card and try again tomorrow. One thing I did notice is that the file is different each time its created, even though I'm not changing the radio button selection. You would think if you generate the file twice with the same serial number both files would be the same but they don't seem to be.

P.S. am I correct in thinking you enter the serial key in hex in to the app e.g. 0x0000305ec  etc

Share this post


Link to post
Share on other sites

1.  Get a 32 gig MicroSDHC card, Class 10 or faster with a full size SD adapter.

2.  Use the android app 'SD Booster' to read the serial number from the MicroSDHC card, Save the serial number for later use.

3.  Format the MicroSDHC card FAT32.  This will get rid of any folders created by Android and ensure the proper format.

4.  Copy maps files to the SD card, This can take 4+ hours to copy NA region.  5+ hours for EU.

5.  Use GenFordKey.exe and enter your serial number without the 0x at the front and all in lower case.

6.  Click the first button to generate SdCard.key file in same folder as GenFordKey.exe

7.  Copy SdCard.key to the MicroSDHC card.  Overwrite if file already exists.  Test in car.

8.  If it doesn't work, try the second button in GenFordKey.exe

Share this post


Link to post
Share on other sites
11 minutes ago, Stoney871 said:

1.  Get a 32 gig MicroSDHC card, Class 10 or faster with a full size SD adapter.

2.  Use the android app 'SD Booster' to read the serial number from the MicroSDHC card, Save the serial number for later use.

3.  Format the MicroSDHC card FAT32.  This will get rid of any folders created by Android and ensure the proper format.

4.  Copy maps files to the SD card, This can take 4+ hours to copy NA region.  5+ hours for EU.

5.  Use GenFordKey.exe and enter your serial number without the 0x at the front and all in lower case.

6.  Click the first button to generate SdCard.key file in same folder as GenFordKey.exe

7.  Copy SdCard.key to the MicroSDHC card.  Overwrite if file already exists.  Test in car.

8.  If it doesn't work, try the second button in GenFordKey.exe

Cheers, I'll give it another go tomorrow, thank you :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.