Jonny_T2002

Retrofitting A Sat Nav To A 2014/2015 (Facelift) Focus

Recommended Posts

6 hours ago, jonathanp said:

Cheers, I'll give it another go tomorrow, thank you :)

Quote

5.  Use GenFordKey.exe and enter your serial number without the 0x at the front and all in lower case.

PLS do not do this step 5 as it is described an you will avoid any problems.

INSTEAD DO THIS:

1. Copy the whole HEXA serial number (also with the 0x). Go to this page and convert it from hexa to decimal form:

http://www.binaryhexconverter.com/hex-to-decimal-converter

2. Copy the new converted decimal serial and put it into GenFordKey.exe - that will generate you a proper file.

Share this post


Link to post
Share on other sites
 

Thanks for the help guys

 

Serial number is 0x05300ec5 decimal is 87035589. I'll try it again later. sdcard.key is to go in the root only?

Share this post


Link to post
Share on other sites

Still no good, bought a new sandisk ultra 32gb today to try but that's not being picked up either

Share this post


Link to post
Share on other sites

9 hours ago, jonathanp said:

Still no good, bought a new sandisk ultra 32gb today to try but that's not being picked up either

Johnathan,

Does your car throw up an error saying something along the lines of navigation SD card is not installed?

Jamie

Share this post


Link to post
Share on other sites
1 hour ago, JamieSMcC said:

Johnathan,

Does your car throw up an error saying something along the lines of navigation SD card is not installed?

Jamie

Nope, display doesn't change in any way (insert nav so card is always in the top right corner) when I insert or remove the sd card. I know the sd card is recognised though as I can browse it for music and wallpaper on the touchscreen. 

Might see if I can reflash the firmware for sync. 

So far I have tried two class 10 micro sd's and all three options on the ford key gen using both hex and decimal values. 

Share this post


Link to post
Share on other sites

Have you got a proper licence or are you just using the licence hack image?

I had the same problem as you, so bought an F5 card off eBay and it still didn't work. 

Once I reinstalled Sync with the bundled licence the sat nav worked straight away, prompted me for the SD card and away it went.

 

Share this post


Link to post
Share on other sites
1 hour ago, JamieSMcC said:

Have you got a proper licence or are you just using the licence hack image?

I had the same problem as you, so bought an F5 card off eBay and it still didn't work. 

Once I reinstalled Sync with the bundled licence the sat nav worked straight away, prompted me for the SD card and away it went.

 

I'm using the navi patch. I'll try another master reset and flash today if not i'll see about getting the licence from Bannko

Share this post


Link to post
Share on other sites

all sorted :)

I was missing a nav update (version 5.67.6). Downloaded the file below and unzipped to usb. Once installed I then got a popup message on the screen regarding the sd card not being installed which was was encouraging as I'd never had that before.

https://www.dropbox.com/s/llahdixb1ctj6hx/NaviUpdate_5.67.6.zip?dl=0

I may have missed something earlier in the thread or on other links but I don't recall any mention of running a nav update.

I'll try and do a more detailed post later with screenshots and links etc, but here is a quick summary of what I think is needed.

1. Download the navipatch.png, copy to usb, insert usb in car, select wallpaper, browse to usb and select navipath.png, navpatch.png will then be saved to SYNC, go to the preview of navipatch.png and press unlock.

2. Use forscan and ELM cable to change the following APIM value, 7D-01-02 00 to 7D-01-02 04. Basically just change the first two numbers after 7D-01-02 to 04, leave the rest of the numbers as they are.

4. Optional. If you have the colour cluster use focccus software to change value #172 to With Display - No Touchscreen, Colour-TFT, DM8 with Navi

5. After all the above is done and you don't have a popup in the middle of the screen regarding the sd card (not just the insert sd nav in the top right) you will need to download the navi update and unzip to usb,

6. Buy a F5 Navi card or make your own and generate the sdcard.key and place in the root of the sdcard. On my focus I used the 2nd radio button and used the hex values in the box including the 0x prefix.

 

 

Share this post


Link to post
Share on other sites

On 8.5.2016 at 10:22 PM, Richiemac said:

PM'd

Would you please send me a PM with details? Thank you in advance!

Share this post


Link to post
Share on other sites
3 hours ago, ccris said:

Would you please send me a PM with details? Thank you in advance!

PM'd

Share this post


Link to post
Share on other sites
  • On 02/05/2016 at 5:15 PM, channisanger said:
    • Just done retrofit of navigation to Ford Focus 2014, can be done. Not to difficult ethier just mainly need the unit screen and that's it 

 

On 18/10/2016 at 9:34 PM, JamieSMcC said:

Think my download is corrupt as I can't get the rar to extract at all :( 

Bit the bullet and bought an F5 card off eBay  

 

Would you please send me a PM with details?

Share this post


Link to post
Share on other sites

Hi all

picking up a new rs on Friday which hasn't got nav

its sync 3 anyone know if its different

Share this post


Link to post
Share on other sites
14 hours ago, gingertom said:

Hi all

picking up a new rs on Friday which hasn't got nav

its sync 3 anyone know if its different

No, unfortunately in SYNC 3 it is not possible as there is a difference on the inside between NAVI and nonNAVI version.

Also a NAVI version has 64GB internal memory and the nonNAVI version has only 32GB internal built-in memory :(

Share this post


Link to post
Share on other sites

Hi all,

I have managed to get it to the "insert SD Card " stage, changed the values with the ELM but when trying to install the navi update via USB it says there are files missing or corrupt.

There are quite a few rar files in the unzip, do I have to so anything else to the folder once I have un zipped it? Is there a certain way or arranging the files etc?

Any info or additional download links to try another file would be great!

 

(I am using the SD card out of my other Focus, which is an original card so I know that works fine)

 

 

Share this post


Link to post
Share on other sites
5 hours ago, Benh33 said:

Hi all,

I have managed to get it to the "insert SD Card " stage, changed the values with the ELM but when trying to install the navi update via USB it says there are files missing or corrupt.

There are quite a few rar files in the unzip, do I have to so anything else to the folder once I have un zipped it? Is there a certain way or arranging the files etc?

Any info or additional download links to try another file would be great!

 

(I am using the SD card out of my other Focus, which is an original card so I know that works fine)

 

 

Hi,

would love to help but just be more specific. what navi udate are you insttaling there? do you have some link or even screenshots would be helpful.another thing is, what version of sync do you have installed there? is it v3.08?

Share this post


Link to post
Share on other sites
20 hours ago, Bannko said:

,

would love to help but just be more specific. what navi udate are you insttaling there? do you have some link or even screenshots would be helpful.another thing is, what version of sync do you have installed there? is it v3.08?

I will check the current version on the car tomorrow as its currently not here however its a 16 plate that has had no updates done to it since it was PDI'd if that helps?, the version I am trying to put on is the one linked on this page above 5.67.6 that was linked along with the navipatch.

It is not picking up the SD card when inserted, based upon whats being said on here that's because it needs this software update. I unzipped the syncmyride folders to a usb stick and it says that there files missing and/or corrupt.

Does anyone have a different update I could try use?

Thanks

Ben

Share this post


Link to post
Share on other sites
15 hours ago, Benh33 said:

 I unzipped the syncmyride folders to a usb stick and it says that there files missing and/or corrupt.

You do not unzip further folders. On the installation USB must be only folder SyncMyRide (all stuff inside must stay untouched, zipped) and the file autoinstall.lst

That is all. 

On the other hand...your tested SD-Card from the other car, is it also used with SYNC 2?

Share this post


Link to post
Share on other sites

Ok so above is what I am getting when I try install the update and I have put the software versions up there too. I have just the syncmyride folder and the auto install in the USB and it throws that bad installation file error up every time i insert the USB drive.  

Share this post


Link to post
Share on other sites

Hallo Ben,

plase firstly try to update your SYNC II to a newer version. Version 4.32.xxxx ist outdated. Folow this post from Alex:

In the download link you will find please rewrite the Rev2 with Rev4.

 

Share this post


Link to post
Share on other sites

Managed to get the Sat Nav working thanks to @Bannko

Activated using ForScan and the ELM cable, then installed the licence using USB.

Cant believe its working!

The only thing that seems to be missing is the traffic, is that a separate module?

Share this post


Link to post
Share on other sites

Hey guys, does anyone know if this still works? If so can some one give me a hand with what's needed as I really want to unlock nav on my 2015 ST.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.