TG12345

Focus 2012 Mk3 rough idle and stall when stationary

Recommended Posts

Hi all,

I wonder if anyone has had this problem and found the cause - I have a Focus Mk3 2011 (61) 1.6 petrol. 30,000 miles. I have owned it for a year and I have a steadily increasing problem of stalling when sitting in traffic. It will idle fine then if I tap the accelerator or move forward slightly then stop, the revs drop up and down between 300-800 revs then it just dies. Starts again no problem, and no issues when its moving - drives lovely.

Anyone else experienced this and if so was there an easy solution? I took it to the garage a while ago and they couldn't find a problem with it - no error codes. Please help!

Thank you :)

Tony

Share this post


Link to post
Share on other sites
 

its common on all years of ford first step have a pcm update ford at ford that usually fixes it

Share this post


Link to post
Share on other sites

Hi,

 

Just by way of an update took it to Ford garage today and software update fixed the problem, thanks artscot79!

Caught the mechanic saying how he was going to rag it on the test drive before he switched off my dashcam, currently waiting to hear from the Service Manager.....what a plum

Share this post


Link to post
Share on other sites

yeah I know how you feel my dash cam was switched off too on a service just after the mechanic was caught saying he couldn't be bothered with a test drive stick it in the corner service manager didn't want to know wouldn't even watch what was records dont go to the service manager go to the main head office upload the video in an email to them you'll get further

Share this post


Link to post
Share on other sites
On 20/04/2016 at 10:43 PM, TG12345 said:

Hi,

 

Just by way of an update took it to Ford garage today and software update fixed the problem, thanks artscot79!

Hi, i am currentley having this same issue, can i just ask if indeed this completley cured the problem? Also how much did the update cost and what exactly did you ask for? Was this problem present when you got the car or did it develop shortly afterwards?

Thanks

Share this post


Link to post
Share on other sites

Got Exactly the same issue with the same 2011 model 1.6 125 focus started at around 50k miles cuts out at low revs im guessing it needs the pcm update , anyone got any idea of cost involved

 

Share this post


Link to post
Share on other sites

Looking at Ford dealer service details. Some dealers list software updates as part of the service so if you are having a dealer service done ask for the update at the same time. I only found out about the update after I had my car serviced so booked it in for a Pcm update and paid £51 for half an hour labour. Happy I did though as it is a different car afterwards. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now