Jump to content
Do Not Sell My Personal Information


Engine malfunction warning 2008 tdci


jack1997
 Share

Recommended Posts

So today whilst driving my car engine malfunction light went off with a scary beep sound and then into limp mode in the middle of a roundabout. I was thrashing the car today and driving with a heavy foot but I do that here and there, I made sure not to exceed red line and change gears appropriately. Anyway I pulled the car over and let it cool. I just put in fresh bp diesel and the oil has also been recently replaced. 

Anyway after I turned the car back on the light is gone but I'm pretty worried. The last time this happened and the car was on limp mode the repair bill cost £900. It wasn't the dpf back then though but an issue with the electricals. So I am slightly worried that I may have a dpf issue now, as I am a city driver  who occasionally road trips. I also do 40 minute commutes to the suburb two evenings a week. The car is on 105400 miles so not surprising that an issue has popped up though. 

 

Any thoughts as to my next course of action?

 

 

thansks guys. 

Link to comment
Share on other sites

4 minutes ago, Stoney871 said:

Get the codes read and go from there.

The should be a DTC stored if the mil light flashed up.

Sent from my SM-G930F

Are you talking about the codes that you need to take the car to a garage to get or the codes you can get from the in-car diagnostics? I've heard the diagnostic feature in the car is no good

Link to comment
Share on other sites

In car codes can be quite restricted but may flag something obvious up.

A proper OBD diagnostic scan will find more info.

A bluetooth module and the Torque app on a phone is a decent option.

Out of interest, when was the fuel filter and filter housing seal last replaced?

Sent from my SM-G930F

Link to comment
Share on other sites

As said without a diagnostics session it could be many things. Torque app is OK but again won't show codes from other modules, so if it isn't a code stored in the PCM they are not always that much use.

Link to comment
Share on other sites


ive started getting this.the other day i went out to the car and it wouldnt start.from experience of when i was fitting heated seats i knew it was the lower plug in the passenger foot well i checked it and the car started.well today went out in car and before i set of the malfunction alarm sounded with pics on dash.keep restarting and it went ok got to tescos and it started up again.any way when i got home i started checking the plug in foot well when i touched it the alarm would sound.i swaped the blus clip over(was going to change the grey plug male bit but the one i have wasnt up to much)i noticed the blue cip bit had wear on the bits thats hold it tight.it seams ok now so will see how it goes.

just thought maybe of help to any one having problams with out finding anything

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership