Jump to content
Do Not Sell My Personal Information


MK1 Battery light


MM92
 Share

Recommended Posts

Hi all,

 

Today the battery light started appearing on the dashboard when I was in natural sat at traffic lights. The light would then go out once I got into first and pulled away.

 

There's been no loss of power etc when the light is on and off. windows, radio, wipers etc all the same speed etc.

 

Plus, the last couple of days the revs have got stuck at the 1,200 mark before making its way down to 8/900 (normal) when I drop into neutral. (Again, no issues on power or gear changes).

 

Would these be linked or well timed separate issues? Any ideas on what could be causing it/them?

 

Thanks!

Link to comment
Share on other sites

could be linked when you start the car do the dials sweep? battery light will either be a battery fault alternator or dash cluster any garage will do a free battery and alternator test its also possible the alternator belt is slipping and old .you can do the dash test check batt voltage at starting 12.5v engine running in neutral 14v minimum any

Link to comment
Share on other sites

1 hour ago, artscot79 said:

could be linked when you start the car do the dials sweep? Battery light will either be a battery fault alternator or dash cluster any garage will do a free battery and alternator test its also possible the alternator belt is slipping and old .you can do the dash test check batt voltage at starting 12.5v engine running in neutral 14v minimum any

Yup, the dials all sweep and run without any issues.

 

I'll take it to the garage tomorrow - I got the battery Jan 2014.

Thanks.

Link to comment
Share on other sites

if the dials sweep on start up that means the battery is low the sweep is a self diagnostic that only happens when the battery is low it shouldn't sweep at all unless you do dash diagnostics make sure The battery is a calcium or silver calcium a lead acid battery wont work

Link to comment
Share on other sites

Just had it checked.

 

The battery was slightly low and the alternator is also slightly low on the power it's giving. So going to swap the alternator.

 

From memory it's a Platinum silver battery.

 

Not sure if this linked to the higher revs in neutral but the battery light is the main concern at the moment.

 

Thanks

Link to comment
Share on other sites


  • 2 weeks later...

UPDATE: Got the alternator changed and we're all good!

 

Since being changed the revs have gone back to idling normally and not sticking. :yahoo:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership