Jump to content
Do Not Sell My Personal Information


Higgsy's Mk3 ST thread


Recommended Posts

Yup 19" style pack alloys painted matt grey. 

I'm not too sure exactly what I'm doing with her yet kind of in awe of the whole thing at the moment. Its my dream car.

Today I fitted a new set of bulbs and led side lights,

Intend to fit custom DRLs in the fog surrounds.

Mostly done cosmetic/protection stuff so far. clay bar and polish the other day. Rubber floor mats, sorted out/replace some rusty screws ( spent the first 3 years by the sea. When the exhaust goes,I will fit a full stainless .

Link to comment
Share on other sites


The last photo was taken before I swapped the wheel nuts for a new set today so all are black now. Needed a new set of lockers anyway as the socket was looking a bit worse for wear and didn't want it breaking on me. Also a couple of nut had been replaced for ugly looking nuts These are ones I bought

http://pages.ebay.com/link/?nav=item.view&id=181901820510&alt=web 

Link to comment
Share on other sites


Another 5min little mod today, boot struts were a bit rust pitted and it was bothering me, so I covered them in black 4d  carbon fibre vinyl. They look really good.

IMG_20160514_121147.jpg

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

Update on the car.

After just under a month I started to smell an oil burning smell, didn't think too much about it at first, however it got worse over a week or so. After further investigation, I found the car was leaking a large amount of oil and evidently had been for a while and it had got worse and had been masked by the engine undertray.

To cut a long story short the car was returned to the dealer 2 weeks ago on the 04/06 and they still have not resolved the issue.  They advised they would looks at the car and fix under warranty, however I have requested to return the car for a refund. They are saying the issue was not present when they took delivery of the car, which of course I dispute.

They have gone from telling me nothing about the issue for 12 days, to providing me with some non logical disgnoses of the problem.  Very reluctant to converse in writing etc.

Basically tt all a bit of a mare and very disappointing :wallbash: !!

 

 

Link to comment
Share on other sites

So this is the funny thing so they said (after 12 days) they thought it was the turbo/intercooler so have been investigating this, there is no problem there. Then they have come back and said they believe it to be a simple issue of the seal on the oil filter. The thing is the turbo is up high at the back of the engine and the oil filer is low down at the front, so why would you start taking apart/investigating the turbo which is obviously more time consuming and expensive to do, rather than starting with an oil after. Also it would be clear (especially with how much oil was leaking) whether it was coming from the turbo at the back, or the oil filter at the front. I don't believe I am getting the full story.

Link to comment
Share on other sites

8 hours ago, higgsy said:

So this is the funny thing so they said (after 12 days) they thought it was the turbo/intercooler so have been investigating this, there is no problem there. Then they have come back and said they believe it to be a simple issue of the seal on the oil filter. The thing is the turbo is up high at the back of the engine and the oil filer is low down at the front, so why would you start taking apart/investigating the turbo which is obviously more time consuming and expensive to do, rather than starting with an oil after. Also it would be clear (especially with how much oil was leaking) whether it was coming from the turbo at the back, or the oil filter at the front. I don't believe I am getting the full story.

Send all the details to ford customer service, they'll soon get to the bottom of it

Link to comment
Share on other sites

23 minutes ago, Maxxxykins said:

Send all the details to ford customer service, they'll soon get to the bottom of it

I hope your joking. Otherwise it must be a different CS to what I "dealt" with.

Only part of Ford I have ever seen anything done is UK HQ.

I'd ask to speak to service manager and demand an explanation. In person is usually better.

Link to comment
Share on other sites

Its a used car from a Toyota dealer. To be fair I am trying to keep a written trail via email, as we all know verbal doesn't really mean much. A lot of not responding when they said they would and the dealer principle is always "away from the centre", if this is the case they need to learn to use an out of office assistant on their emails! They have given me a loan car, and seem to think this takes all the inconvenience out of it for me. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership