Willy

Satnav retrofit help

Recommended Posts

I'm retrofitting a satnav to my 2015 Titanium X and slowly working it out but need a bit of help with a few things.

The KM issue has been mentioned on Facebook a fair bit and wondered if that's easy to sort?

I have a reversing camera at the moment. The SatNav unit won't show a picture when in reverse. I just thought it was a case of activating it but I've read the green connection on the back is the camera connection which I don't have.

20160908_084121.jpg

 

Share this post


Link to post
Share on other sites
 

Hi 

I have the same spec fiesta as you and the Rev camera connections are in the large black plug that has a latch so if they are run into that 4 pin green plug you'll need to get some screened cable and connect on to them and run them into that green connector.

 

i did have the pin outs for the Rev camera written down as I had to work them out when I fitted my Alpine unit.

I done this by stripping the boot and following the cable run to a plug on the NS / C post and then jus buzzed them out from there. If it will help I can dig them out tomorrow night.

 

Regards karl 

Share this post


Link to post
Share on other sites

That would be great 😆

Strange how the original setup uses the large black plug connection for the camera but the satnav doesn't.

I came across a connector on the net that would possibly fit

Camera-Connection-Cable-for-Ford-Cars-with-Sync-1-Monitors.jpg

How did you overcome the KM to miles issue? I've gone into the setting but found it was already set to english and won't select miles on the menu.

Share this post


Link to post
Share on other sites

Camera connector now sourced so just need to work out where the camera cables are on the loom.

2016-09-10 12.59.55.jpg

Share this post


Link to post
Share on other sites

Hi

has anything happened regarding this mod

on the screen photo above what are all the other connectors for

is there one for the gps antenna

Share this post


Link to post
Share on other sites

GPS is the blue fakra cable unless you have this in your car already you can buy the GPS receiver on eBay for around £6 and that works fine 

the issue with the reverse camera is the camera itself has to be ntsc format not pal otherwise it will not respond to the satnav display and you can use the lead in the pic above to connect it unless you have the loom already in car. The black fakra socket on the back of satnav uses the black connector of the back of your stereo unit then you run another fakra lead from the pink connector of your satnav to the black socket on the stereo unit so you can receive dab and radio 

then you attach 2 wires from pin 6 and 12 of your display plug to pin 4 and 5 on your head unit for nav voice hope it helps 

Share this post


Link to post
Share on other sites

Hi

have just come over from the dark (vauxhall) side. I have a Fiesta 2014 Titanium X and have read the sat nav thread with interest and wondered how you over come the Km to miles issue ?

any help would be great                                                                                                                                                         

Share this post


Link to post
Share on other sites
1 hour ago, Coldhands said:

Hi

have just come over from the dark (vauxhall) side. I have a Fiesta 2014 Titanium X and have read the sat nav thread with interest and wondered how you over come the Km to miles issue ?

any help would be great                                                                                                                                                         

you need to use forscan to change the screen size to 5 MFD then it will let you change back to miles if you dont then your stuck with KM.

Share this post


Link to post
Share on other sites

Hi,

thanks for that info, could you help with the relevant menu's to look in

thanks in advance                                                                                                                                       

Share this post


Link to post
Share on other sites

On 10/9/2016 at 2:06 PM, Willy said:

Camera connector now sourced so just need to work out where the camera cables are on the loom.

2016-09-10 12.59.55.jpg

 

@Willy Did you figure out which wire on the original loom that you needed to add the connector to? And did you just cut the wire and solder the connector to the wire or did you do something else

I am retrofitting sat nav at the moment at have the same issue that you had :)

Thank you in advance

Brgds

Simon

Share this post


Link to post
Share on other sites

Sorry mate but never finished it and sold the unit abroad. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now