Jump to content
Do Not Sell My Personal Information

Ford S max / Galaxy radiator cooling fan not working


Recommended Posts

Like a lot of people it seems, I had trouble with the radiator/cooling fan not operating on my S Max.  Presumably this also applies to the Galaxy mk3 and the Mondeo.


I have now fixed the problem and thought it would be helpful to share what I know as there is little information that I found when searching the internet, some of which is incorrect.

I am an electronics/software engineer by trade and so for my own curiosity as much as anything I wanted to find out how the fan operates.....

Attached to the cooling fan housing is a speed controller in a small metal box.  Some forum posts refer to this as a relay box, which is incorrect.  It is driven by a PWM signal - to those who don't know what that is, it is a continuous series of pulses that change width dependant on the speed required.

There are three wires going to the fan controller, a permanent 12V feed (Red), a ground (Black) and a pink wire.  The pink wire is the control (PWM) wire.  There are two wires that come out of the other end of the speed controller and connect to the fan.

The powertrain control module (PCM) in the wheel arch drives the PWM signal on the pink wire.

So how do you tell if the fan should be on?  The signal on the pink wire appears to be an open-collector drive - a bit technical but basically means that you probably won’t be able to measure a signal unless it is plugged in to the fan speed controller at the time.

This is also how the PCM detects a fan fault.  The speed controller has an internal pull-up resistor between the pink wire and 12V (Measures about 2700 ohms).  When the fan is connected, the PCM module can see the 12V on the pink wire, so when the fan is disconnected, the 12V disappears from the pink wire and the PCM can detect a fault.

If you have a voltmeter - when connected between ground and the pink wire you should see 12V (or whatever the battery voltage is) when the fan is off and a lower voltage when the fan is on.  The actual voltage will depend on how fast the fan should be going and the type of voltmeter but it will probably be around 4V at full speed.

I believe there are two ways to force the fan to come on.  The first is to disconnect the engine temperature sensor - however I did not try this as I was not sure where it was.  The second method (that I used) is to turn the aircon on full - when the aircon is on the cooling fan should come on full speed.  This will only happen though when the engine is running as the aircon pump has to be engaged.

If you just want to test the fan itself works, you can disconnect the 2 pin connector from the output of the fan controller and connect them to 12V and GND.  I did this by also removing the 3 pin connector and using the red and black connections on their to link across to the fan connector.

So what was wrong with my fan ? I had what appears to be a common problem of the pink control wire being broken/corroded in the wiring loom.

The following is a description of a right hand drive, I don't know if the engine layout is different for a LHD. 

The PCM module is located in the passenger (near) side wheel arch.  You need to remove the wheel and arch liner to get at it (Mine has the protective cover over the connectors with a shear bolt which I don't have tools to remove).  You don’t have to take the wheel/liner off but I found it gave me better access to the loom.

The wiring loom from the PCM goes through the arch and at about 6 inches in to the engine bay (pretty much under the bottom radiator hose) part of the loom goes up to the top.  This bit of the loom is cable tied to the inner wing.  This contains the pink control wire which then goes across to the fan controller.

My pink wire was broken/corroded at the point the loom separates in the bottom of the bay.  There are two reasons for this.  The first is that the cable firstly bends to the left and then is bent back on itself to go the wheel arch and taped up so that there is too tight a bend in the wire.  The second reason is that this join is below the washer fluid bottle and water dribbles down into the join which over time corrodes the wire.

What I learnt when fixing the problem: It is much easier to access from the bottom of the engine bay.   I started trying to un-tape the loom from the top (After removing the air filter box).  After removing the wheel arch liner, I discovered it was much easier to access from the bottom and removing the liner gives you more room to manoeuvre your arms.  You will have to remove a fair amount of tape and some conduit from the loom to work out which wire it is but there are only a couple of pink wires in that part of the loom and I think only one that has a tight bend.

I cut out the bent/corroded piece of wire and replaced it.  I have read on some forums that any fault codes need to be reset before the fan will work again.  I didn’t reset my code (P145C, Fan System Component A) and it worked anyway.

 The attached pictures show

1) A picture of the PWM signal on the pink wire viewed on an oscilloscope.  This is with the fan full on.

2) a picture of the wiring loom from above after removing tape/conduit - This taken with the air intake box removed.

3) The small section of wire that I removed and the break/corrosion in the middle

4) A view of the PCM module inside the wheel arch with the liner removed

5) A picture of the wiring loom from below with the pink wire cut out


Hopefully all of this info will be useful to someone……






  • Like 4
  • Thanks 1
Link to comment
Share on other sites

  • 8 months later...

Hi Paul, I’ve recently been having problems with my radiator too, just wondering if you can help?

I’ve took the radiator control unit off and I’ve measured the pink wire resistance, now  here’s the strange thing, there’s a click from a relay in the fuse box then the pink wire measures 4.3v and after a few seconds it drops to 0v, obviously the relay opens momentarily to allow some power but not enough or for long enough to power the module.

So, do I hunt the relay down ? Would it even be broken? Or is it some other electronic sensor / device  to working correctly?

I replaced the fan motor controller just in case but didn’t make a difference.



  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

Hello Paul and Flubbabelly,

I am having the same problem. I first noticed the aircon had stopped working and I quickly worked back to the radiator fan. Like Flubbabelly I get a 4.3 V reading on the multimetter between the pink and earth (Mine is constant). Before I run out and spend money on a very overpriced fan unit can anyone recommend other test points to narrow the fault down? Or even better a cheap fix?

Paul, amazing explanation and attention to detail. I was able to follow everything you suggested with ease and the picture were a great help.



Link to comment
Share on other sites

Hi Mike, sorry I’ve only just noticed the reply you posted.

I ended up pulling my thermostat out to test that and the engine temp sensor ‘located in the back of the thermo housing’, I flushed the whole system out and when I put the everything back together I left the leads to the engine temp sensor off, fired the car up and the fan came straight on, the car must be set so that if it can’t detect the engine sensor it automatically starts the fan, I’d try this first before replacing the fan module especially if you have voltage to it. As Paul suggested, the true volts to the module can’t be determined because it isn’t a continuous flow of electricity more of a pulse that the module reads / converts into the correct voltage and without taking it apart and braking in to it, you’ll not get a correct reading.

Try taking the engine sensor leads off , it’s a right faff, If you have an 06 / 07  2.0 tdci like I do, you'll have to remove the air box cover, filter and pipe to stand any chance of getting to it, you have to push the clip up and pull if I remember rightly, once you’ve done that you should only need to put the ignition on to see the fan move.

Hope this helps.


Link to comment
Share on other sites

  • 2 months later...


If the control wire is damaged would this completely stop the fan coming on, under any circumstances?

I have a 1.8tdci Mondeo that suffered hesitation after being stuck in traffic on a hot day. The only thing I could find wrong is the fan doesn't seem come on. I used forscan several times to verify this. However, it comes on when I disconnect the CHT sensor so the fan is definitely not faulty. I don't think it's the CHT sensor either, connected forscan when the engine was cold the the CHT was close to the IAT. 

Hence asking the question, I inspected the control wire and couldn't find and damage there. Could it just be I missed the damage? 

Running out of ideas.


Link to comment
Share on other sites

  • 9 months later...

I’ve bee told its the module behind fan but after had a new one fitted fan didn’t work so it wasn’t the module box... it was the pink cable from the plug .. the top one with 3 pins ... it was corroded so they cut and replace a new bit of cable 3-4 cm long and now everything is working as it should... didn’t know before that the galaxys has just one fan ... ac and for cooling the engine ...  

Link to comment
Share on other sites

Hi there,

today in the morning my Galaxy WA6 overheated at idle speed -> the reason was the same fu****g broken cable, see pictures. Thank you very much for this helpful thread and forum.







Link to comment
Share on other sites

I've just had (and fixed!) the same problem on my wife's '09 Galaxy 2.0 TDCi. Air conditioning just packed up one day. AC clutch wouldn't engage, so I assumed that all of the R134a had taken a trip to the Ozone layer. Took the car to Halfords for a re-gas and the guy said that only 50g of the required 850g was missing, so he filled it back up with the requisite quantity of refrigerant and oil. (They had previously repaired the AC on this car 18 months ago when one of the solid pipes to the rear/auxiliary AC evaporator sprang a massive leak, so I thought I'd take it back to the same place.) They offered to diagnose the problem that was causing the AC clutch to not engage but like the OP, I'm an electronics/software engineer so I thought I'd have a go at diagnosing the electrical problem myself. I have friends with nightmare stories of giving garages carte blanche to do electrical diagnostics on their car, and ending up thousands of pounds out of pocket after the garage replaced every sensor and module they could find until they cured the problem.

  1. First port of call: Check fuses and relays. The wiring diagrams in the Haynes manual don't even show the AC compressor and cooling fan circuits - useless! After much Googling, I managed to find the location of the AC relay and tested it off the car - solenoid and contacts both working:1235424989_GalaxyMk3Fusebox.thumb.jpg.dd21909cd01e94ce7abf93dc493d3a0f.jpg
  2. Time to go to phase two: get the OBDII scan tool out, and find out if one of the ECUs is actually telling the AC clutch to engage. I plugged in my el cheapo OBDII bluetooth dongle and loaded up my trusty copy of 'Forscan', which is installed on a 10+ year old Windows XP laptop with a duff battery. I added all the sensors and status flags available on the PCM (Power Control Module) which I could find that appeared to relate to AC or cooling system. It should be noted that up until this point, I had not seen the Check Engine light illuminate, nor did the scan tool find any fault codes in the PCM. Straight off the bat, I could see that the AC compressor clutch was commanded to engage and in fact it did engage - I saw it run for about 15s one time. A quick look at the Forscan log shows why. The clutch kicks in and the High-side pressure starts to build up. When it starts to rise, the PCM commands the engine cooling fan to start running. It appears that it keeps increasing the PWM drive percentage (up to a maximum of ~30%) until it starts to see the AC High-side pressure level off. In the first trace, you can see that this never happens and at just under 1000kPa, the PCM de-asserts the AC_REQ (AC Request) and ACC_REQ (AC Clutch Request) signals to save the system from blowing itself up. After that, the clutch won't re-engage until the pressure falls to about 500kPa - which in my case was taking about 10 minutes. So in this state of repair, the AC would run for 15s every 10 minutes! At least I knew the compressor could be engaged. 802776014_ACswitchonpressurebuildsswitchoff.thumb.PNG.b9f3463c6ee3aa7b04bca8736b00d265.PNG
  3. Check whether the fan is faulty. The fuse that supplies the 12V feed to the cooling fan's PWM module is F5 in the engine bay fuse box, and that was intact. I also measured 12V at the PWM connector. Then I tried bridging straight across from the connector feeding the PWM to the connector on the fan, with 2 short lengths of wire - Success! Big spark and the fan runs. So... the PCM is commanding the fan to run, but it won't. What could be causing that? I tried what Flubbabelly suggested and disconnected the coolant temperature sensor. Indeed it does cause the PCM to command a high fan rate of 95%. With the CHT sensor disconnected, the PCM reports the CHT as 90ºC, the outside air temp display on the dashboard shows "--.-", and a fault code is logged in the PCM.
  4. Next step (in terms of minimising the diagnosis time spent), I elected to replace the PWM module that's screwed to the back of the cooling fan. Managed to get a Chinese knock-off one from eBay for £22 brand new. Fitted that and tried again - no go. Same trace in Forscan as before - PCM commands ~25% fan drive, but fan not running. Curses!
  5. Time to start looking at the PWM wiring (that's how I Googled into this post). I pulled the wheel off and removed the wing liner as has been suggested, but neither of these two steps were necessary in hindsight; I did all the cutting, splicing and taping-up from above. It was hard to tell from the previous posts exactly where in the loom the pink wire had broken. I started cutting it open from the bottom joint and worked upwards. Turns out it was broken (through metal fatigue probably) at the same point where samse2101's wire was broken - exactly at the point where the loom tees off towards the fan/PWM connector. The muppets that built the wiring harness made that tiny little pink wire too tight and with the tension and 10 years of vibration, it finally snapped - but only inside the plastic insulation. I spotted the break due to the green-ish bulge in the wire at that point:  1590383926_hardbend.thumb.jpg.2eb2d2d2d87ae1e46bd992990e097ff5.jpg  I gave it a sharp tug and the wire pulled apart at that point, revealing cheesed-up green ends of copper wire. Water must have gotten in somehow. 65160469_brokenend.thumb.jpg.34b9afe92e60ddd28b56e0eee467b4c7.jpg Finally, I cut and stripped the ends of the snapped pink wire and spliced in about 8cm of new wire, gratuitously heat-shrinked. Finished off by wrapping it all up with PVC tape and cable-tying the harness back to the engine and chassis at the points where it was previously anchored.
  6. Before I tested the AC, I ran-up Forscan again - just to see what happens when the system is working properly. You can see from the plot that the AC clutch is commanded to kick in, then once the High-side pressure climbs to about 700kPa, the PCM starts up the engine cooling fan at a low PWM rate. As the pressure in the system fluctuates, more or less PWM is commanded, to keep the pressure within preset limits: 1361514079_GalaxyACisfixed.thumb.PNG.50d041e92fc11b3af5c159c7ba184b4a.PNG

Other parameters recorded in the trace are:

  • AAT - Ambient Air Temperature
  • CHT - Cylinder Head Temperature
  • FANHI - not sure what that one does; it was in the list of flags in Forscan. 

So why didn't the PCM log a fault code for this broken wire? I'm guessing that there was just enough current passing through that green gunge to allow the PCM to detect the presence of the PWM module. However, it wasn't enough to let it drive the module.

Thanks everybody for your valuable assistance! You've saved me a few hundred nicker, I'm quite sure.



Link to comment
Share on other sites

  • 4 weeks later...

I have same issue with my s max 2.0tdci 07. Bought it with faulty aircon, when at the garage checked the system had pressure that means system is fine but still topped up the gas. When switched on AC nothing happened, pump clutch did not get signal and fan never seen working. However clutch is engaging if i force it by removing relay and connecting it straight with short piece of wire. As suggested above i unplugged coolant temp sensor and started the engine and fan started straight away. I also checked resistance between pink and other two wires on control module connector but no resistance or voltage or ground on pink wire. Then i stripped wires from tape starting from the module and following all the way down to the spot i could get from the top but no damaged wires detected...however i noticed that the loom where pink wire goes to the bottom of the screen wash tank is"upgraded" with bicycle tube by previous  owner. Next im going to get my hands under the car behind the front nearside wheel to see if thats common pink wire fault. Otherwise i don't know what else can i check. Any suggestions would be appreciated. 

Link to comment
Share on other sites

Ui iantt thanks for good suggestion , spot on .I opened cover under the glove box and surprise! i found the issue. You were right, i found removed sensor connector. Plugged it back and now Fan and AC working just fine. Thanks again for suggestion.


Link to comment
Share on other sites

So I have a similar issue.

Picture the scene as my Wife is driving and the Galaxy suddenly looses power pulling off round a roundabout. My 'helpful' suggestion that perhaps she should attempt the manoeuvre in second gear and not 4th was met with much swearing as she limped into a car park and suggested I should see for my self. With my tail between my legs I acknowledged the error of my ways, popped the bonnet and promptly got drenched in a haze of steam and coolant peeing out everywhere, karma. After summing up the issue as one I'm not going to be able to fix in the dark in a Pizza Hut car park with a car full of hangry occupants I called recovery and got towed to the garage. Having had a Coolant issue on my Mondeo (identical car, both 2011 1.6 Ecoboost) I gathered the same hose that caused my Mondeo woes the previous month had taken a dump and there was no way it was fixable.

Turns out the ECU wiring on the Galaxy had been 'fixed' previously, as it is in a stupid place behind the front N/S wheel it had rotted in places. The guy I take the car to normally suggested 2 things, a £700+Vat new fan assembly from Ford or a few hours with a Auto Electrician to fix the previous bodge. I opted for the latter and a few days later it was back and working.


Now as soon as the temp gauge hits the half way point the fan kicks in. And boy does it hick in. I am told by the garage that this is correct and the Ford Tech that did the visual inspection of the vehicle when I took it in for a software recall didn't comment that the workshop was deafened by the noise from the fan.

Air Con works, not losing coolant, not overheating and the fan doesn't stay on when the engine is off (as it would if there was a real problem). I don't have the same issue with my Mondeo, the only difference between the 2 is that (from the Ford visual inspection) the coolant in the Galaxy froze at -9deg and the Mondeo -18deg, so more water in the Galaxy? I can't see this as having much of a bearing though.

Any thoughts?



Link to comment
Share on other sites

  • 1 month later...

I have this same fan controller on my freelander 2.  I have checked the resistance of the PWM control wire back to the ECU and it is fine.  However the fan never comes on as the car overheats in traffic.  It does come on as commanded by the AC - which is wierd as it is via the same ECU.  I wondered if anyone knows whether the pulses get longer for faster fanning or shorter for faster fanning.  I have an Osciliscope on order so I can look at it soon and would love to know what to expect.  I have also got a new chinese controller on order, but I don't think that's gonna fix it.  Really odd that it still works with the AC.  Sadly forscan doesn't seem to work with the Landrover ECU, so I can't look at the requested fan duty cycle directly



Link to comment
Share on other sites

  • 6 months later...

Hi my Mondeo 2.2 TDCI 2012 overheats when towing, can`t find the problem. Should the fans run at full speed when the car idle, with aircon on?

I`m suspecting the fan module because when overheating the fan does not run at full speed. But it runs full speed if i disconnect the temp-sensor. any ideas?



Link to comment
Share on other sites

  • 4 months later...

Hello everyone.

I too have fallen into pink wire abyss it seems and like the last 2 posts before me I also have an issue with my fan only spinning when i turn ON the AC. I think it only spins on lowest possible mode.

My S-Max AC is sparently venting out gas when ever i fill it back up to spec. It vented gad and oil 3 times this month when i was in city and it was hot, but car didn't overheat.


Yesterday i went on a long drive up a huge hill and my car overheated with needle on red but no coolant being lost of steaming up. I noticed the lack of power so i quickly went back down the hill and meanwhile noticed fan isn't spinning at all!

Fan won't spin no matter the engine temp, but it does spin if i turn on the AC (you cant hear the fan). If i turn off the AC fan stops.


I changed the fan control module just couple of min ago, and the issue is still persistent.


Does anyone have an idea on where to start looking for a fix? Any help would very appreciated.


Thank you.

Link to comment
Share on other sites

  • 4 weeks later...

Struggling with the radiator fan here as well.

AC is not working and the radiator fan never starts running.

When I force the duty cycle using Forscan I can run the fan. (Except for some reason at 100%, then it shuts off.)
This makes me think that the pink / purple wire is Ok.

but the strange part is: the duty cycle on forscan when i run the engine is always at 0%. 
Even when i reach operating temp, 90 degrees celcius. Any ideas why this can be 0 always?

Link to comment
Share on other sites

  • 7 months later...

I have a 2008 2L diesel smax. The air con was not working and my air con guy said there was no power to the compressor. On further inspection the radiator fan was not working and since both the engine and aircon rely on the same fan... we concluded my issue was main fan related. 

Ford did an initial inspection and said the fan or control unit was at fault.  And quoted a big sum to replace both with no guarantee that would solve the issue. 

I bought a fan control module off eBay for £13 and that didn't fix it. Got a 2nd from the supplier which did the same. 

So did a bunch of tests. I was getting between 1v and 4v on the mauve control wire but nothing through on the output. 

Did the 12v to the fan test and that showed the fan to be working. 

I put it back to ford to test again. Basically it was the corroded wire thing. So although I was getting 4v on the control wire,  the corrosion meant no amps. They replaced the wire and its fixed. 

So to check this....

1. Remove the feed to the fan control unit. There are 2 connectors for the full 12v and a 3rd control wire (mauve)

2. Test voltage with car running on the 3rd control wire. You should see a build up from 1v to 4v as the car warms (regardless of the aircon)

3. Check the amps. If they are low then its a corrosion thing. Not sure what they were as I didn't test myself

4. Replace mauve wire from fan control unit to the controller (somewhere in near side wheel arch)

Link to comment
Share on other sites

  • 1 month later...

A very useful and informative thread which sparked me into action when my neighbour said her car had overheated in traffic.
No boilover action just 120'C on the dials.

It went to a garage which tried to order £400 of parts for a 14 year old car so it came home and I got stuck in full of knowledge.


1 : The connector into the fan controller showed 12v across the two big terminals I couldn't work out how to get the fuses out to check but power is good thing.

2: unplug the fan and check for resistance, showed 0.9 Ohms I think, no change when wiggling cable between fan and plug

3: Check the purple wire end to end, here it went a bit rubbish.

I wanted to stick a meter on both ends of the purple cable and wiggle it about to see if it worked as an actual wire so I took out the arch liner and popped open the white box in the front of the wheel arch.
My plan was to pull off the multi-plug for an end-to-end test.......


There is a metal shield over the multi plug on the PWM ECU, it also has some sort of anti-tamper bolt at the far end of the unit in the above picture that prevents removal of the shield and covres the plug I wanted to access for a continuity test.

in summary I found no benefit to removing the wheel arch liner, crack on if you feel lucky but I was stumped by the sodding bolt.


So I pulled the harness apart carefully and checked all the wire I could access resigned to the fact the bit threaded through the chassis was not accessible.


Having pulled and twisted all of the pink wire I could get at, none of it looked or felt damaged or weakend much to my dissapointment.

As a last ditch at finding a cause I "Popped open" the fan controller.
Actually I used a hammer and a Stanley knife blade into the seam all around the controller to get the lid off with very little damage.
There are four capacitors in there, one had bubbled up and pushed the case label on this component out so this may be the fault after all.
No pictures, phone went flat.


Applied power to the fan with two spade connectors on fly leads (The fan leads are colour coded Red/Black), the fan roared nicely.

I have orderd a fan controller, from AutoDoc, so the car may be gone before the part arrives looking at the tracking data.


If I cannot fix this Galaxy it will get traded in for a Mini, the one Clarkson described as the "Massive Countryman"

A pity really, this car only has 63,000 on the clock and a slightly sticky interior

Link to comment
Share on other sites

Update: Galaxy fixed, it was the fan controller module.


Exhibit A



This fault did give me an opportunity to have a proper go with forscan and my new cable, very impressed with its features.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...