Sign in to follow this  
marshy2312

help needed

Recommended Posts

hey guys i have a mark 1 focus t plate now the problem is il be driving down the road and all of a sudden the speedo will go off and the car will lack on power but will still drive if i come to a set of traffic lights it will cut out it will then start back up off the key first turn but speedo remain off and still lacking it only seems to be realy happening if the weathers isnt very good or dull day. wat i have tried ive pulled nearly every plug i can find around the engine and put grease in these hoping this would stop i havent touched the fuse box just 2 big connecters under neath also my fuel gadge has now gone on the blink

Share this post


Link to post
Share on other sites
hey guys i have a mark 1 focus t plate now the problem is il be driving down the road and all of a sudden the speedo will go off and the car will lack on power but will still drive if i come to a set of traffic lights it will cut out it will then start back up off the key first turn but speedo remain off and still lacking it only seems to be realy happening if the weathers isnt very good or dull day. wat i have tried ive pulled nearly every plug i can find around the engine and put grease in these hoping this would stop i havent touched the fuse box just 2 big connecters under neath also my fuel gadge has now gone on the blink

yuneed to take it to ford it could be the instrument cluster is on its way out a new one fitted only costs 99quid after so many complaints on watchdog or it could be the speed sensor to the gearbox

Share this post


Link to post
Share on other sites

would this cause it to lack on power wen the speedo goes off its seems to me as if im driving with no battery the battery light does come on wen the speedo stops working but only wen i come to a stop also where do i find the gear box sensor ?

Share this post


Link to post
Share on other sites
would this cause it to lack on power wen the speedo goes off its seems to me as if im driving with no battery the battery light does come on wen the speedo stops working but only wen i come to a stop also where do i find the gear box sensor ?

the gearbox sensor or speed sensor can cause it to stall yes its not that easy to get to and id eget a garage to do it personally

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this