flesta

AUX in Fiesta 2010

Recommended Posts

I just bought a used 2010 Fiesta, but it didn't have an AUX connection. It did have an AUX button in the center console, though, so I thought I could just hook this up to the back of the stereo unit:

13981.jpg

Unfortunately it didn't work, as the display doesn't go into AUX mode when I press the AUX button. There is some kind of connection, as when I'm navigating some of the sub menus, and press the AUX button, it returns to the main radio screen. But it doesn't switch to AUX.

I also have no USB or bluetooth in the car as far as I can see. This must be a very low specced version. Any ideas what to try next, or if there is a secret feature to enable AUX?

Share this post


Link to post
Share on other sites
 

I know on mine you have to use Forscan to activate DAB. Perhaps it's the same for you, but only guessing here.

Share this post


Link to post
Share on other sites

It's worth giving it a try. I wasn't aware of Forscan. Going to order an ELM327 device now. Thanks!

Share this post


Link to post
Share on other sites

Using Forscan indeed worked. It said "Without Axiliary input" and I was able to change it to "With Auxiliary input". Save, restart ignition, and the AUX button works. Thanks @Luke4efc!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now