penfold14

Fuel temp sensor

Recommended Posts

Cmax 2.0tdci 2011.  Does anyone know where the fuel temp sensor is. The eml light has cone on, and codes flagged up

Fuel temp circuit a intermittant, and fuel temp circuit b intermittant. I cleared the codes hoping it was a glitch, but they came back. Car appears to be running fine.

 

Thanks

Share this post


Link to post
Share on other sites
 

Excellent, glad its not in the tank. Don't suppose you have the finis code for the part? Do you have any pictures

Share this post


Link to post
Share on other sites

i would contact your ford dealer and they will use your reg number to find the correct finis number

1509189900223.jpg

Share this post


Link to post
Share on other sites

i would locate the sensor, unplug it, and refit. clear codes and see if codes return

Share this post


Link to post
Share on other sites

Why is that mate.. If these are going to go, don't they just fail, unless you think it may be a dodgy wiring issue?? 

Share this post


Link to post
Share on other sites

Light came back on in a matter of mins unfortunately.

I have found the fuel pump, but which of these do you think is the right sensor.  From the photo previously posted, and looking at the orientation, I would presume the lower one of the 2!!

 

IMG_20171029_134844.jpg

Share this post


Link to post
Share on other sites

Well the garage I took it to reckoned the sensors I thought it was were fuel connections..... And said the sensor was under the hp pump. They would need to remove air filter housing, scuttle and boost control solenoid to replace. Does this sound right?????? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now