Recommended Posts

Having a nightmare! I have a Fiesta MK7, 2009 Zetec, I have the bluetooth module and the USB port but the bluetooth and aux cable WILL NOT work. We've looked at so many questions on here but nothing is touching it! We have tried:

  • replacing the fuses under the bonnet and in the passenger footwell (fuse 21)
  • turning the battery on and off
  • installing an update via USB (just said there were no files then would not progress to the next stage)
  • replacing the bluetooth unit (not cheap and nothing happened!)

To be a bit more specific - when i press the 'phone button' it says 'Mute' and i cannot change this no matter what I press. When I press 'aux' it says 'Line in' and again i cant change this no matter what i press. When I go through menu to select blue tooth is doesn't say anything apart from bottom right 'BT off' again - you guessed it - no matter what I press it doesn't change. No idea what to do with it now and I'm sure most of you know driving down the motorway with the radio cutting in and out is so frustrating i really need this working! Please HELP!

Share this post


Link to post
Share on other sites
 

Hi Did you ever resolve this issue? I have exactly the same problem and can't work out whats wrong with it...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now