• Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Get Your Club gear
      Get Your Club gear


Choc4holic

Focus 2009 - battery dies, radio not work, dash fails go out when off

Recommended Posts

My 2009 focus TDCI been brilliant till six months ago. battery dies when not used for four days. Garage could only find tiny drain and fixed that. Put in new battery too. Problem not fixed though. The radio/CD player was intermittently available or dead ie. no display. Now basically not available. Also the driving display stays on when car switched off. To be exact it does not go out fully - only the central part of the display goes off.  These faults been happening all this time. Has anyone experienced this? Have any suggestions to fix this?  Many Thanks. 

Share this post


Link to post
Share on other sites

The mileage display on the dash stays on for about 20 minutes after you switch off the engine and illuminates when you unlock the car, so that's normal unless it's staying on permanently.

The radio might have an electrical fault (earth short) causing the battery drain.  You could try removing the radio fuse to see if the problem still occurs.  

Share this post


Link to post
Share on other sites
7 hours ago, Choc4holic said:

Also the driving display stays on when car switched off

On the MK2  the display can stay on some time ( about 20 minutes but if a very long time then this is usually an ECU problem and will need to go to an ECU repairers a common fault  (lots advertised) But I don't think that it would cause your other problems though with the radio there are many after market radios that you can replace this with.

 

Share this post


Link to post
Share on other sites

Thank you TomsFocus and Gizza11. Will try the fuse on the radio/CD. The display is on permanently - top and bottom bit of it, the middle bit with changeable info does go off when I turn the engine off. The other bit is just glowing overnight! So will probably need to sort ECU. Car apparently says it has no radio or dash issues when diagnosed. The battery dies after four days but the garage has it hooked up to track any drain and can’t find enough over 24 hours to account for it not starting at all after 4 days. So waiting till after weekend and hope will be able to solve it. Thank you for your help much appreciated. 

Share this post


Link to post
Share on other sites

Have now been told that Ford says the car missed an instrument panel upgrade - assume to do with the car’s computer. Needs to go into ford dealer, have booked it in but they say initial diagnostics check will be £110 before I even know what the issue will be. Apparently they wouldn’t have checked at its service in March with the dealership they would just have checked that the battery was ok, which it was as I was using the car every day - and the problem was already there then. Feeling bit frustrated. Have to wait two and a half weeks for the appointment at the dealer garage too. Hey ho. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now