JackAndrew1995

MK8 Fiesta - issues with build quality

Recommended Posts

Hello,

I took delivery of a MK8 Fiesta Zetec  with the new 1.1L Ti-VCT engine in late September and i'm wondering if anyone else is experiencing issues with the build quality of their car?

Unfortunately, there is a list of complaints with my car and i'm not best pleased with it and would love to know if any one else has had the same or similar issues.

Issues reported to the dealer:
Interior Front lights don't always come on first unlock (fixed with a software update)
Sat-Nav looses GPS and ends up in the middle of a river (Ford are aware of the issue, but could take a couple of months for a fix)
Dashboard rattles when in motion.
Engine seems to be really rough to the point that the passenger side seat wobbles at idle.

Dashboard and Engine issue have been reported again however nothing was brought back about the dashboard when I picked it back up from the service dept.
My car has apparently had an update to control the rough idling engine which hasn't helped at all :(

Hows everyone else's MK8 Fiesta treating them? It's alot better than my previous MK7.5 Studio in everyday i'll tell you that much!

Jack

Share this post


Link to post
Share on other sites

Hi

My sat-nav on my Mk8 lost GPS signal once and reset after I turned ignition off. Once it indicated it had lost signal but carried on giving correct indications. Got mine early August and both my problems occurred in the first two months. OK since.. Not suffering any of your other two issues. Agree a lot better than the Mk 7.5.

Share this post


Link to post
Share on other sites

The problem I have been having is the automatic windscreen wipers. Some times they work sometimes they don't . Like losing the GPS  on the Satnav , which I have lost the signal too, I just stop and start up again and it's sorted. 

 

Share this post


Link to post
Share on other sites

Ordered mine in July for delivery in October, initially went for titanium spec with reverse sensors for £200 but added camera as it was only £50 more, dealer rang to say there had been a mix up ( by ford not them) and sensors were not fitted, he gave us a couple of options, we could reorder the car with correct spec for delivery in DEC, or take the car and they would fit the sensors, we chose to take the car, the only problem would be that the proximity sensor wouldn't show on the camera, when we went to collect the car the dealer gave us an extra two years on the warranty, fitted the rear sensors foc and we received a cheque for £200 from ford , can't say I've noticed much difference when reversing as I find the camera a lot better, had no issues as yet of any problems as reported by the op, I too think its a vast improvement over the mk7.5

 

Share this post


Link to post
Share on other sites
1 hour ago, potter18 said:

Ordered mine in July for delivery in October, initially went for titanium spec with reverse sensors for £200 but added camera as it was only £50 more, dealer rang to say there had been a mix up ( by ford not them) and sensors were not fitted, he gave us a couple of options, we could reorder the car with correct spec for delivery in DEC, or take the car and they would fit the sensors, we chose to take the car, the only problem would be that the proximity sensor wouldn't show on the camera, when we went to collect the car the dealer gave us an extra two years on the warranty, fitted the rear sensors foc and we received a cheque for £200 from ford , can't say I've noticed much difference when reversing as I find the camera a lot better, had no issues as yet of any problems as reported by the op, I too think its a vast improvement over the mk7.5

 

I think it's good to have sensors along with a camera. Helps give a audio judgment when your not looking at the camera and busy looking at not kurbing the wheels. I fitted a reversing camera and once I just about touched the car behind me because I was busy looking at the kurb. 

For the build quality Id say ford aren't perfect with all their cars they make. I heard one person ordered a mk7 back when they were new and the rear Speakers weren't working so had to take the car back to Ford. 

Share this post


Link to post
Share on other sites

I've been noticing rattles from interior. Had the dealership check on it and they told me they noticed nothing unusual. Will make them check again when it's due for service.

I am not sure about the engine being rough. I am noticing some kind of "rattle" or roughness when taking off in first gear and reversing, also during idle.

Share this post


Link to post
Share on other sites

I am having problems with my passenger window going slowly and seeming that there is something stuck. Mk8 ST Line. The side skirt it just popped on and you can see where it scratches. My drivers seat is fading. And I have a squeak in the passenger seat. Also spot on with the dashboard rattling very annoying. 

 

All are pretty cosmetic to me fair. Car is lovely otherwise just wish I went for the ST or the focus!

Share this post


Link to post
Share on other sites

Take it back to the dealership as it sounds like some warranty work needs to be done.

Share this post


Link to post
Share on other sites

I am having problems with my Ford Fiesta mk8 st Line. 

1: the engine occurs a really odd ticking noise when idling and it comes and goes. 

2: when I am steering and braking at low speeds there is a really odd creaking noise and at times it’s quite loud. 

3: my passenger seat rattles when stationary with the engine running. 

My car has only done 10,000 miles, just wondering if anyone can help me out n let me know if anyone else is having similar problems. 

Share this post


Link to post
Share on other sites

I haven’t had any of those 3 issues on my vehicle but in all honesty, they all sound like items your dealer would be perfectly able to fix. As your car will be under warranty, i’d try getting the dealer to take look and try and fix it. 

Saves you time and stress trying to work out what it could be. 

Share this post


Link to post
Share on other sites

It’s a nightmare it’s a brand new car I don’t understand! The creaking noise tho it started at around 1500 miles but it seems to have got worse. This is my second mk8 st line and I’m having the exact same issue.

Share this post


Link to post
Share on other sites

Take it back to dealership.

Have had none of those issues either.

Share this post


Link to post
Share on other sites

Hi, I’ve been searching for ages to see if anyone has had a similar issue but no luck. 

I have the MK8 Titanium and whenever it rains heavily and my windscreen wipers are on a faster setting the wiper will intermittently hit the side of the car on the drivers side. 

It’s only when it rains very heavily and when they have been going for a while. It’s so loud at when it does hit that I can hear it over my music

Ive taken it back to the dealer (three times now) and they don’t seem to believe me? I made a video of it happening but they’ve just said that’s the noise it’s supposed to make. When the car is stationary the wipers do make the usual noise which is fine, but obviously you don’t hear that when your car is driving over the usual sounds but this can clearly be heard hitting the side of my car. 

I feel like I’m losing the plot. 

Share this post


Link to post
Share on other sites
2 hours ago, nicolajennifer said:

Hi, I’ve been searching for ages to see if anyone has had a similar issue but no luck. 

I have the MK8 Titanium and whenever it rains heavily and my windscreen wipers are on a faster setting the wiper will intermittently hit the side of the car on the drivers side. 

It’s only when it rains very heavily and when they have been going for a while. It’s so loud at when it does hit that I can hear it over my music

Ive taken it back to the dealer (three times now) and they don’t seem to believe me? I made a video of it happening but they’ve just said that’s the noise it’s supposed to make. When the car is stationary the wipers do make the usual noise which is fine, but obviously you don’t hear that when your car is driving over the usual sounds but this can clearly be heard hitting the side of my car. 

I feel like I’m losing the plot. 

Hello, are you able to post the video into this forum? 

Sounds maybe like the wiper arm could do with some adjustment or tightening of the bolt, but really after three visits to a dealer, I'd have expected at the very least, they'd have had a go at that already. 

As far as I'm aware, the wipers shouldn't be making any abnormal noises when wiping at any speed. 

Share this post


Link to post
Share on other sites
10 hours ago, nicolajennifer said:

Hi, I’ve been searching for ages to see if anyone has had a similar issue but no luck. 

I have the MK8 Titanium and whenever it rains heavily and my windscreen wipers are on a faster setting the wiper will intermittently hit the side of the car on the drivers side. 

It’s only when it rains very heavily and when they have been going for a while. It’s so loud at when it does hit that I can hear it over my music">music! 

Ive taken it back to the dealer (three times now) and they don’t seem to believe me? I made a video of it happening but they’ve just said that’s the noise it’s supposed to make. When the car is stationary the wipers do make the usual noise which is fine, but obviously you don’t hear that when your car is driving over the usual sounds but this can clearly be heard hitting the side of my car. 

I feel like I’m losing the plot. 

Ditch the factory fitted Ford blades (cheap & nasty) one of the 1st things I do is a buy a set of Bosch Wiper Blades, a lot quieter, smoother and no judder. 

‘I’ll attach a link to the ones you need. 

https://rover.ebay.com/rover/0/0/0?mpre=https%3A%2F%2Fwww.ebay.co.uk%2Fulk%2Fitm%2F192919456162

I’ve a 2019 Fiesta Active X but I would imagine the above link will fit all Mk8 fiesta models. 

Share this post


Link to post
Share on other sites
On 6/12/2019 at 11:59 AM, DG97 said:

Hello, are you able to post the video into this forum? 

Sounds maybe like the wiper arm could do with some adjustment or tightening of the bolt, but really after three visits to a dealer, I'd have expected at the very least, they'd have had a go at that already. 

As far as I'm aware, the wipers shouldn't be making any abnormal noises when wiping at any speed. 

When I took it in the first time they said they had tightened them but it has not helped at all! Second time they said they did the same.

The last time I took it in the girl just turned the wipers on after they had had the car for about 5 hours and said 'Look it makes a noise, it's just the noise it makes' 

They had been for a drive in it and used the windscreen washer fluid to make the screen wet and said it was not making any noises other than what it should be doing and at this point I kind of lost my patience with them and just took my car and left.

I've linked a video of what I recorded on Tuesday when it was heavily raining. You can hear that it's not on every single wipe (which is what they're implying is normal) but there's even music on that it can be heard over so it can't be considered correct I don't think.

Never had a car do that!

Video

 

Share this post


Link to post
Share on other sites
On 6/12/2019 at 8:34 PM, John 1 said:

Ditch the factory fitted Ford blades (cheap & nasty) one of the 1st things I do is a buy a set of Bosch Wiper Blades, a lot quieter, smoother and no judder. 

‘I’ll attach a link to the ones you need. 

https://rover.ebay.com/rover/0/0/0?mpre=https%3A%2F%2Fwww.ebay.co.uk%2Fulk%2Fitm%2F192919456162

I’ve a 2019 Fiesta Active X but I would imagine the above link will fit all Mk8 fiesta models. 

Were they difficult to change? My only experience changing wipers (Clio about 10 years ago) did NOT end well!

I do notice the wipers don't do an amazing job of actually wiping the rain away at the best of times so it could be worth me trying these for that reason alone.

Share this post


Link to post
Share on other sites
6 hours ago, nicolajennifer said:

When I took it in the first time they said they had tightened them but it has not helped at all! Second time they said they did the same.

The last time I took it in the girl just turned the wipers on after they had had the car for about 5 hours and said 'Look it makes a noise, it's just the noise it makes' 

They had been for a drive in it and used the windscreen washer fluid to make the screen wet and said it was not making any noises other than what it should be doing and at this point I kind of lost my patience with them and just took my car and left.

I've linked a video of what I recorded on Tuesday when it was heavily raining. You can hear that it's not on every single wipe (which is what they're implying is normal) but there's even music on that it can be heard over so it can't be considered correct I don't think.

Never had a car do that!

Video

 

Definitely not normal. Your dealer seems to just be trying to fob you off which is quite poor really. I would suggest readjusting the arm a little bit so there is less of a chance of it catching. An alternative would be to take it to another dealer if your current one isn't taking things seriously and saying "it's normal". Depending on how confrontational you are feeling, I would somewhat politely ask them to show you another car that makes a noise like that when hitting the bodywork of the car and then ask them to clarify if it's definitely normal. 

On one side, I feel for the dealership a little too as it may be difficult to recreate this in a workshop in dry conditions or even after slightly spraying the windscreen with water. Either way, as you have the video, I'd say that's more than sufficient. 

If you take it back to your dealer and they say it's normal again, I'd advise an email to Ford themselves with a complaint and this video attached. I believe some have done this before and its surprising how your issue then gets looked after properly. 

Hope you get it all sorted!

Share this post


Link to post
Share on other sites

Mk8 Fiesta ST here. The plastics on the inside rattle a lot (doors + infotainment). Will get it fixed (they can add extra padding at the dealer) when it goes for service at 20k km. Automatic lighting is a bit slow to turn off but turns on very quickly. Adaptive high beams work fine (full-led). Automatic wipers are a bit of a gimmick. 

Share this post


Link to post
Share on other sites
10 hours ago, iug_aocontrario said:

Automatic wipers are a bit of a gimmick

Some people quite like them - all personal preference. Quite a few members, me included,  have disabled the automatic function through the settings menu so the automatic setting just becomes a normal variable intermittent wipe.

Share this post


Link to post
Share on other sites
On 6/22/2019 at 10:44 PM, iug_aocontrario said:

Mk8 Fiesta ST here. The plastics on the inside rattle a lot (doors + infotainment). Will get it fixed (they can add extra padding at the dealer) when it goes for service at 20k km. Automatic lighting is a bit slow to turn off but turns on very quickly. Adaptive high beams work fine (full-led). Automatic wipers are a bit of a gimmick. 

I don't understand how the wipers can vary so much! On my actual car the automatic wipers are great, they work perfectly at matching the rain but on a courtesy car of another MK8 (It was an ST) the wipers were garbage! They just either didn't turn on at all or they would be going insane when it was barely raining it was so strange. 

Surely it should all just be standard with the automatic wipers. Strange.

Share this post


Link to post
Share on other sites
On 7/12/2019 at 11:44 AM, nicolajennifer said:

I don't understand how the wipers can vary so much! On my actual car the automatic wipers are great, they work perfectly at matching the rain but on a courtesy car of another MK8 (It was an ST) the wipers were garbage! They just either didn't turn on at all or they would be going insane when it was barely raining it was so strange. 

Surely it should all just be standard with the automatic wipers. Strange.

For the auto wipers to work well, the screen in front of the sensors needs to be kept clean and free of smears etc - possibly the courtesy car wasn't. I've always had problems like you describe with auto wipers - at home my car is parked near several trees with nesting birds and there's always something sticky or unmentionable somewhere on the screen. So I've disabled auto wipers in favour of variable intermittent, which at least is consistent. You couldn't do this with previous cars I've had with auto wipers, so this is a good feature on the Mk 8 Fiesta imo.

 

Share this post


Link to post
Share on other sites
47 minutes ago, Eric Bloodaxe said:

For the auto wipers to work well, the screen in front of the sensors needs to be kept clean and free of smears etc - possibly the courtesy car wasn't. I've always had problems like you describe with auto wipers - at home my car is parked near several trees with nesting birds and there's always something sticky or unmentionable somewhere on the screen. So I've disabled auto wipers in favour of variable intermittent, which at least is consistent. You couldn't do this with previous cars I've had with auto wipers, so this is a good feature on the Mk 8 Fiesta imo.

 

I hate the concept of auto wipers and find the speed has rarely been spot on, most likely due to reasons that Eric mentions. Really like that we can switch auto wipers off and use the intermittent wipe ourselves, simple enough to then adjust the intermittent speed to what you want/conditions. 

Share this post


Link to post
Share on other sites

Year ago VW used to have a relay where you could set the time between the intermittent wipers to whatever you wanted up to a couple of minutes. Has anyone tried that yet? I don’t like the stepped timing between wipes on intermittent, never seems to work. Always too fast or too slow so I end up just doing it myself 9/10.

Share this post


Link to post
Share on other sites

Lots of issues with my 2018 1.1 fiesta - been back to the dealership every month since October.  Rattles from the dashboard still not solved and apparently the loud ones are in the roof and tailgate which they can't access as welded upon manufacture, also gear stick shudders in 1st gear when pulling away

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.