Sign in to follow this  
b6130bui

Power steering malfunction & hill start assist not available on 2014 Fiesta Mk7 facelift 1.0L Ecoboost Turbo

Recommended Posts

DA,

 

I am hoping for some advices for my car...2014 Fiesta Mk7 facelift 1.0L Ecoboost 125HP engine with 6sp Powershifts.

 

This is the car with push button engine start (newer model)

 

After 3 weeks not going out from garage (but keep the engine turn-on for 30min each week)...suddently displayed :

- Power steering malfunction

- Hill start assist not available

 

And the steering wheel is getting really heavy.

Others electricals are fine...no problem.

Engine sound etc, turbos are also fine.

 

On the last ride (3 weeks before the problem)....nothing wrong...nothing shown on the indicator....also no sign / no feels of dead power steering.

 

I called my local ford dealer & make the following :

 

1) Unplug battery & cleaned grounding points....plug again after 20 minutes.

2) Recheck connection plug on the PSCM module under steering.

3) Make OBD scan and it showed :

 

Indicated DTC :

U0420:00-68-ABS invalid data received from PSCM (EPS module isn't it?)

Failure type : 00 no other info for this DTC

Status : 68 indeterminate but monitor has not completed to determine

Diag protocol : 14229

 

But on individual PSCM scan it said PSCM - PASSED.

 

They told me ABS turned off the PSCM because ABS not receiving any data from PSCM (were they telling me wrong / the other way around?)

 

But they also said PSCM should be OK because it passed the PSCM tests.

 

They suspect no data because of connections....and told me to check all connection plugs/wires.

 

1 week after I brought the car to (another) Ford dealer & told them the problem, DTC code....then they checked & made scanning to the car.

 

And after scan (also checking connection)...they said it is definitely PSCM and price is USD2400 for the complete PSCM module+motor assembly...before tax (and not included labour).

 

I took back the car because I am not willing to pay USD2400+++ for PSCM assembly.

 

Now I am getting confused :

1) Scanning said : U0420:00-68-ABS invalid data received from PSCM.

 

2) 1st Ford dealer said : because of U0420 the ABS turned off the PSCM thus power steering not activated. But PSCM is OK...because it passed the individual PSCM test. They recommend check all connections/plugs problem that causing invalid data/no data from PSCM.

 

3) 2nd Ford dealer : followup the problem stated from 1st dealer and made another check of connection/plug/wire that might be related to this problem. (Also unplug the battery again).

And made another OBD scan....then they reported to me it is very certain PSCM module is the problem (and they want USD 2400+++ for installing new PSCM assembly).

 

Anyone has the same problem with their Mk7? Any advices?

 

Is it really PSCM module problem....or ABS problem?

 

Looking for any advice.

 

Attached is the 1st dealer scan result

 

Thanks in regards

Kent7fc60c75b41f18a832f95c3523b957ea.jpg

 

Sent from my Redmi Note 4 using Tapatalk

 

 

Share this post


Link to post
Share on other sites

I'm having the same issue. But instead of the PSCM, my local Ford center suggest to replace the ABS pump. Wonder if it's the same thing.

I live in Malaysia. And had the Fiesta for about 6years. And I had the TCM replaced recently. I was lucky, as the TCM was under warranty. Now, I'll have to cough up $2,500 for the ABS Pump.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this