Sign in to follow this  
Focus ST 1980

Dashcam earth point?

Recommended Posts

I have a 2006 Focus ST.

I was bought a NextBase dashcam for Christmas, however as it's an ST I don't really want an unsightly 12V power plug powering the dashcam.

I bought the NextBase hard wire kit which piggy backs off a fuse in the fuse box. I went to install it today but can't work out where to ground the kit, it's got to be close to the fuse box under the glove compartment as the hardwire kit positive and earth wires are not that long.

Does anyone know where the best place to ground is in the passenger footwell on a 2006 ST?

Thanks in advance

Share this post


Link to post
Share on other sites

I have grounded some of my stuff to the fuse box bracket, but obviously can be a little bit of a pain potentially for anyone changing the pollen filter!

Share this post


Link to post
Share on other sites
16 minutes ago, Micro said:

I have grounded some of my stuff to the fuse box bracket, but obviously can be a little bit of a pain potentially for anyone changing the pollen filter!

Changing the pollen filter is a massive pain anyway.  I've changed heater matrixes in other cars with less annoyance.

So did you use one of the two securing bolts of the bracket? 

I did think to try that but its painted black and the bolts washer the other side is plastic, where on the bracket?

Thanks

Share this post


Link to post
Share on other sites

 I've just done this earlier today.  If you peel away the door trim and then remove the dash end panel, that will expose a useful earth bolt. You might have to extend the wire as you say it's a bit short.

Share this post


Link to post
Share on other sites

Thanks,  I started peeling away the rubber strip running along the door frame and sill then yanked up the plastic panel next to the ST door sill logo and found two earth points.

I chose the back windscreen wiper fuse for the camera. 

Thanks

Share this post


Link to post
Share on other sites

On 13/01/2018 at 6:27 PM, Focus ST 1980 said:

Changing the pollen filter is a massive pain anyway.  I've changed heater matrixes in other cars with less annoyance.

So did you use one of the two securing bolts of the bracket? 

I did think to try that but its painted black and the bolts washer the other side is plastic, where on the bracket?

Thanks

I believe it's sandwiched between the front of the bolt and the bracket (so only contact between the back of the bolt head).

Share this post


Link to post
Share on other sites

Hey guys, so I too am hardwiring dash cam to fuse box and can't find a suitable earth point. I removed the door seal and can see some bolts however I can't find an easy way to remove the plastic housing. I've got a 64plate focus navigator. Any help would be greatly appreciated. 

IMG_20180415_141340.jpg

IMG_20180415_141347.jpg

Share this post


Link to post
Share on other sites
Just now, davecantshoot said:

Only possible point I can see is this. Would it be suitable

IMG_20180414_135252.jpg

Should be. If the camera powers up and shows it's charging then it will be ok.

Share this post


Link to post
Share on other sites

Thanks, before I try that is there an quick and easy way of dropping the glove compartment. I could probably get to something there. 

Share this post


Link to post
Share on other sites

The side panel with the airbag sticker just pulls off.  Mine is there with the blue crimp.

It might not be such a good contact with the black painted part in your photo.

IMG_20180130_160802705.thumb.jpg.dd511c3638a7b946a3263683c197427d.jpg

Share this post


Link to post
Share on other sites

 
can someone tell me which fuse can I use to piggyback for hard wiring dashcam from fuse box?
also what fuse amp is ideal?
yunii
 
Sent from my SM-G960F using Tapatalk
 
 
 
 



Sent from my SM-G960F using Tapatalk

Share this post


Link to post
Share on other sites
1 hour ago, yunii said:

 Can someone tell me which fuse can I use to piggyback for hard wiring dashcam from fuse box?
also what fuse amp is ideal?
yunii
 

Fuse F100 on the mk2.5 focus comes on with the ignition, the amperage should be determined by the existing plug I used a 10 amp red fuse.

That's where mine is plugged in Guide: https://www.fordownersclub.com/forums/topic/65147-guide-fitting-dual-camera-dvr-system-focus-mk2-mk25/

I've also earthed on a bolt above the glove box where there was already another item earthed it may have been the bluetooth module earth point.

Share this post


Link to post
Share on other sites

on the focus I wired direct to back of 12v power outlet below radio.
yunii

Sent from my SM-G960F using Tapatalk

Share this post


Link to post
Share on other sites

btw the dashcam is nextbase with parking mode so switches off when not in use.

Sent from my SM-G960F using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this