jonnyharris33660

Budding Enthusiast
  • Content Count

    4
  • Joined

  • Last visited

About jonnyharris33660

  • Rank
    Newbie

Profile Information

  • First Name
    jonny
  • Ford Model
    mk3 focus 1.0l ecoboost
  • Ford Year
    2013
  • UK/Ireland Location
    Shropshire

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Looking for a sports exhaust in the uk for my 1.0 ecoboost focus. And a dive or experience in the ares appreciated. Thanks. Jonny Sent from my SM-G950F using Tapatalk
  2. Undecided on which way to paint the front of my car, like em both but would love your feedback. Thanks. Sent from my SM-G950F using Tapatalk
  3. Hi all. I have a 2013 mk3 focus 1.0l ecoboost. I've had an engine malfunction light come on on the dash board yesterday and the car lost a lot of power. Whilst I was still moving I dipped the clutch switched her off and on again and all was fine and power restored. Since then it's done it 5 or 6 times over 60 miles. Got it home and put the ODB on it and it shows bank 1 sensor 2. Do I need a new sensor? Do I need a new cat? Could there be a leak in the exhaust? Could the recirculation valve be leaking? Things to mention... had a remap 12months ago nothing too drastic , I asked for more of a pep up rather than a maximum power increase. In the last few weeks I've noticed an increased flutter noise from the turbo/recirc. Any advice is greatly appreciated. Jonny Sent from my SM-G950F using Tapatalk