Macstef001

Budding Enthusiast
  • Content Count

    2
  • Joined

  • Last visited

About Macstef001

  • Rank
    Newbie

Profile Information

  • First Name
    Maciek
  • Ford Model
    Stefanski
  • Ford Year
    2012
  • UK/Ireland Location
    Surrey
  1. Hello, my Smax keep randomly going into limp mode with Engine Malfunction warning. The fault that keeps registering is Fuel Rail Pressure (Intermittent/Erratic). The problem is the fault keeps resetting itself after the engine is switched off for a few hours so by the time its in a garage for repair (3 times now) they can't detect the fault and fix it. The best guestimate is that its the fuel pressure sensor on the rail. However I understand its not possible to replace just the sensor on an Smax and the whole rail would have to be replac ed (£500 with labour). Its an expensive gamble. Has anyone experienced this problem and is it correct to assume its a sensor fault? Thank you.
  2. Hello, my Smax keep randomly going into limp mode with Engine Malfunction warning. The fault that keeps registering is Fuel Rail Pressure (Intermittent/Erratic). The problem is the fault keeps resetting itself after the engine is switched off for a few hours so by the time its in a garage for repair (3 times now) they can't detect the fault and fix it. The best guestimate is that its the fuel pressure sensor on the rail. However I understand its not possible to replace just the sensor on an Smax and the whole rail would have to be replac ed (£500 with labour). Its an expensive gamble. Has anyone experienced this problem and is it correct to assume its a sensor fault? Thank you. Maciek