liorm84

Budding Enthusiast
  • Content Count

    8
  • Joined

  • Last visited

About liorm84

  • Rank
    Newbie

Profile Information

  • First Name
    Lior
  • Ford Model
    S-Max
  • Ford Year
    2010
  • UK/Ireland Location
    Other/NonUK
  1. How can I disamblee the shutters? Can you add a guide or something? Thanks Sent from my ONEPLUS A6013 using Tapatalk
  2. When you write rubber, you mean worn bushings and so? Do you have a list with all "rubbers" at the front. Eventually, I will replace all of them. Sent from my ONEPLUS A6013 using Tapatalk
  3. You didn't attach a picture but I think that I heard about this from my mechanic. Definitely will try this first. Thanks mate Sent from my ONEPLUS A6013 using Tapatalk
  4. Ok, I little bit tough to explain - when I steering to the left, at some point ( about 1/8 of steer) it feels loose and not steer the wheels (loose zone) checked at parking of course. few people said that its the steering rack and eventually I will need to replace it. What do you think ? Also, from you experience, which sensors / relays / electric stuff tend to die soon ? my car is S max 2010 automatic 6 speed aisin 2.3 duratec
  5. So, after few weeks that I didn't have time and the noise became worse I eventually put my Max at the garage. They replaced the o ring on the steering pipe + steering fluid and also replaced some polley tensior with new belt. Finally, no more whining. I'm happy. Sent from my ONEPLUS A6013 using Tapatalk
  6. I don't know, but the whining is definitely related to the steering. Even on parking, if I steering, the noise become louder. Sent from my ONEPLUS A6013 using Tapatalk
  7. So in your opinion, this is not likely to be the steering pump? The whining starts not right away but after a minute and only when accelerate (and on top when accelerating with turning the steering). This whining goes away after 10+ minutes and not exist when the car is hot. One of the garages suggest to replace steering hoses as in their opinion and practice this is the problem (whining until the steering fluid warms up). Sent from my ONEPLUS A6013 using Tapatalk
  8. Just bought a 2010 model. Yes, it is duratec 2.3 petrol with automatic gearbox. I have a strange noise at mornings. After about a minute of driving, there is whining noise that become louder if I accelerate or turning the steering wheel. The whining going off after about 15 minutes of driving. There is enough steering fluid. I know that pervious owner just changed the steering fluid reservoir and the oil about a month ago. The steering itself is smooth. What do you think? Sent from my ONEPLUS A6013 using Tapatalk