Kja52y

Budding Enthusiast
  • Content Count

    2
  • Joined

  • Last visited

About Kja52y

  • Rank
    Newbie

Profile Information

  • First Name
    Kieran
  • Ford Model
    13 Ford Focus eco boost 1.0
  • Ford Year
    2013
  • UK/Ireland Location
    Essex
  1. Hi all hoping someone can help. I own a 13 plate 1.0 focus eco-boost and having power issues when in 5 and 6 gear. It cannot hold 70 going up hills any more which before the car had issue holding a speed when going up the same hills. The car is also unable to accelerate when going up hills either. I have recently had the coolant pipe to the turbo replaced as this had just disintegrated, after looking at an old post on here someone had a similar issue and it turned out to be a split air pipe to the turbo but I am still getting the turbo noise (whoosh) when I come off the gas.  Anyone have any suggestions I will be most appreciated 
  2. Hi all hoping someone can help. I own a 13 plate focus and having power issues when in 5 and 6 gear. It cannot hold 70 going up hills any more and the start stop hasn’t worked in months. I have recently had the coolant pipe to the turbo replaced as this had just disintegrated, after looking at an old post on here someone had a similar issue and it turned out to be a split air pipe to the turbo but I am still getting the noise when I come off the gas. Anyone have any suggestions I will be most appreciated
  3. I have this same issue but I am still getting the turbo noise when coming off the gas. Could this still be a cracked air pipe to turbo