mrdstamp

Budding Enthusiast
  • Content Count

    4
  • Joined

  • Last visited

About mrdstamp

  • Rank
    Newbie

Profile Information

  • First Name
    D
  • Ford Model
    Ford Focus Zetec 1.6 Petrol 09
  • Ford Year
    2019
  • UK/Ireland Location
    Buckinghamshire

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Thanks for this. I'm very grateful for any advice anyone can give me. I'm going to stick my car in at the end of the month when I get paid. I do wonder how much these things are going to cost, but I still believe the car's worth a bit of TLC. Hopefully I can report back soon. Cheers. Sent from my EML-L09 using Tapatalk
  2. Hi there, They did. The mechanic said they took the throttle body out and found no issue with it. They cleaned it. They checked the sensor attached to it. Then after stocking some redex in the fuel and resetting the ECU they state that there were no issues. I'm struggling to understand why I still have this issue. It stalls almost daily. When either coming to a junction etc so I quickly have to restart the engine. It also stalls when setting off and in both cold and warm starts. It's sluggish when Gears are changed. I love my focus as it's just used like a "thunderbird 2" but the missus can't rely on it and so won't drive it. Sent from my EML-L09 using Tapatalk
  3. Hi there, I'm new on here. Firstly I am not a qualified mechanic, but not afraid to get stuck in. [emoji3526] I have been having issues with my Ford Focus 2009 1.6 zetec (petrol) for over a year now and I would be truly grateful if anyone actually knows the Solution. Its so bad that I'm now not comfortable driving it with my young family. The symptoms are the following... Hunting on idlle when the engine is switched on which leads to stalling) Jerky shuddering when accelerating from stationary. Poor torque when in third gear. Sudden acceleration when I travelled at 60 when I came onto a motorway (last night of which I noted the time on the car's clock) When waiting at lights/roundabouts car stalls. So far the following has been done... Spark plugs changed Air filter replaced Oil changed 2 garages have run diagnostics and found no faults. Air manifold block taken out and checked by the garage. There's no Maf sensor in the vehicle because of its model. The Tmap sensor was checked by the garage The inboard computer (forgive me I don't know the term) was reset because the manidold block was taken out. I have absolutely no idea as to how this has happened. The car is shy of 100 thousand miles on the clock (10 000/ year). Limited funds but I really need this fixed for family travel. Thankyou kindly in advance. Dave Sent from my EML-L09 using Tapatalk Sent from my EML-L09 using Tapatalk
  4. Hi there, I'm new on here. Firstly I am not a qualified mechanic, but not afraid to get stuck in. [emoji3526] I have been having issues with my Ford Focus 2009 1.6 zetec (petrol) for over a year now and I would be truly grateful if anyone actually knows the Solution. Its so bad that I'm now not comfortable driving it with my young family. The symptoms are the following... Hunting on idlle when the engine is switched on which leads to stalling) Jerky shuddering when accelerating from stationary. Poor torque when in third gear. Sudden acceleration when I travelled at 60 when I came onto a motorway (last night of which I noted the time on the car's clock) When waiting at lights/roundabouts car stalls. So far the following has been done... Spark plugs changed Air filter replaced Oil changed 2 garages have run diagnostics and found no faults. Air manifold block taken out and checked by the garage. There's no Maf sensor in the vehicle because of its model. The Tmap sensor was checked by the garage The inboard computer (forgive me I don't know the term) was reset because the manidold block was taken out. I have absolutely no idea as to how this has happened. The car is shy of 100 thousand miles on the clock (10 000/ year). Limited funds but I really need this fixed for family travel. Thankyou kindly in advance. Dave Sent from my EML-L09 using Tapatalk