Sacul

Budding Enthusiast
  • Content Count

    6
  • Joined

  • Last visited

About Sacul

  • Rank
    Newbie

Profile Information

  • First Name
    Carl
  • Ford Model
    Fiesta
  • Ford Year
    2003
  • UK/Ireland Location
    Devon

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I bought the car at 14k miles about 6 months ago. 3 times a week it does a 70 mile round trip. I'm unsure of its first 14k though
  2. We did initially think the same but would they start to fault at 20k miles? I found alot of problems in the 1.8 and a faulty batch of injectors which caused a problem but not so many issues in the 1.6.
  3. Hi, I have a 2011 1.6 Diesel C MAX Titanium. It has done just over 20k miles. I broke down a while back and had a diagnostics of "high to low on cylinder 2" took it to a garage where they changed injector 2. After that I broke down again with diagnostics "high to low on cylinder 3". I had a different mechanic take a look and found that the earth was bad and the wires to the injectors needed sorting out. After that the car drove better than ever but every time I go up a hill at about 70-80 I get a little misfire/hesitation then it pulls like normal. I took it back to the mechanic who checked all the wires again and did live data while going up a hill, it did what I said but there is no fault on the live data. Seemingly the car is "perfect". Injector 3 has also been changed incase that was the problem but no luck. It's got a new fuel filter aswel and fuel pressure is perfect. Has anyone come across this problem or have any ideas what it might be. Thanks guys!
  4. I'll have to get the manual out and find out what the relays do.
  5. Thanks, that's good to know. Maybe I should put the car in for the mot first before fixing the light.
  6. Hi everyone. I have a 2003 Fiesta 1.4 LX auto. I've had the car around 4 years with no problems. When I got the car it beeped when put into reverse, not sure if this is standard or someone had it fitted as I've never heard a fiesta do this before. The beeper has stopped working and after taking the car to a garage to be fixed they told be the reverse light isn't working and it's not the bulb as they tried to change it for me. I've checked the fuse and it's also not that. What else could it be and where/how do I start to fix this problem. I have my MOT in 1 month so need to get this fixed asap. Thanks in advance!