TomB1991

New Member
  • Content Count

    1
  • Joined

  • Last visited

About TomB1991

  • Rank
    Newbie

Profile Information

  • First Name
    Thomas
  • Ford Model
    Focus Sport
  • Ford Year
    2007
  • UK/Ireland Location
    Lancashire

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi guys, New to the forums despite owning fords throughout my driving history. I recently bought a MK2 Focus, 1.8 TDCi Diesel for a rediculouly good price to say it was remapped to stage 1. However a couple of days in as I would put my foot down on the acceleration the vibration in the pedal and steering wheel was immense. And also found when pulling out at junctions I had no power what so ever, I did some research and found that engine mounts were a common problem in these cars so I asked a garage next to my work to take a look. Anyways cut a long story short they got it in the air looked at the two in the engine bay and said there fine, it was the torque mount underneath the car that had shattered on the rubber. Got that replaced, noticed a major difference in the vibration but it was still there. The power had also slightly come back and it didn't seem like it was choking. So I delved a bit deeper and found egr valves in these can be pretty clogged up, so I took a trip to Halfords and bought Wynn's egr cleaner. Did the clean out took it for a rest drive and noticed even more of a difference yet again. Barely any vibration in the steering wheel, however when accelerating the noise was still there and the vibration in the gear stick. I just don't know what else to pin this to and what I can do to fix it so it runs smoothly again. Any thoughts or advice would be greatly appreciated. To.