Pid16v

FOC Supporters
  • Content Count

    74
  • Joined

  • Last visited

About Pid16v

  • Rank
    Settling In Well
  • Birthday 01/27/1956

Profile Information

  • First Name
    Alan
  • Ford Model
    2.5T Mondeo Titanium X Estate
  • Ford Year
    2008
  • UK/Ireland Location
    Nottinghamshire

Recent Profile Visitors

367 profile views
  1. Mine is a titx 2008 with the NX satnav. There is no camera input. Sent from my I3113 using Tapatalk
  2. Assuming this is now sold but if not can you show some interior photos and under bonnet. Sent from my I3113 using Tapatalk
  3. Well I guess Jamie's not around here much these days so I'll throw this at whoever the expert is these days, [emoji4]. Looks like I need a pair of new tyres at the front, then I'll get those rear arm bushes replaced then wheel alignment. First though, tyres. Can any of you guys recommend a midrange tyre for my 2008 2.5T titx Mondy estate? Oh, 18" standard. TIA. [emoji4] Sent from my I3113 using Tapatalk Sent from my I3113 using Tapatalk
  4. Sounds like engine mounts to me. I had a similar issue though it was on my 2.0ltr zetec, it was the rear mount (roll restrictor). Eventually the rubber let go and the vibration changed to a thud at every gear change. Sent from my I3113 using Tapatalk
  5. Dismantle job I'm afraid but fairly straight forward if you take your time. You'll need the removal pegs and I recommend taking photos of the serial number and info labels before you replace it. There's a "how to" thread on this forum somewhere I'm sure. Sent from my I3113 using Tapatalk
  6. Finally swapped the buckle and sorted, no more bonging. [emoji106] Sent from my I3113 using Tapatalk
  7. I think it works really well and factory fit? Sent from my I3113 using Tapatalk
  8. More on this. I've been somewhat distracted recently but I was reminded a couple of days ago when I had to use the car. I've ordered a replacement drivers side buckle which I will get fitted hopefully by weekend. I've read that the seatbelt alarm is connected to the airbag so are there any precautions I should take apart from battery disconnect. Sent from my I3113 using Tapatalk
  9. After upgrading my bt/vc module for the usb one I wanted to add an easily accessible USB port. After some head scratching I decided on using the triangular blank opposite the start button. Works a treat and Imo looks OK. Sent from my I3113 using Tapatalk
  10. Sorry for delayed reply. Simple fix, I made a bad earth connection but rechecked and made good. [emoji108] Sent from my I3113 using Tapatalk
  11. Yes, complete loom swap from exterior handle to A pillar [emoji106] Sent from my I3113 using Tapatalk
  12. It's the time of year. Try changing your damp/wet floor mats for a dry set. Sent from my I3113 using Tapatalk
  13. According to my asbuilt data, mine originally had blue tinted w/screen [emoji848] Sent from my I3113 using Tapatalk
  14. ... Just me then..... [emoji513] Sent from my I3113 using Tapatalk
  15. Thanks, all sorted. [emoji798] Sent from my I3113 using Tapatalk