Jordandavis

Budding Enthusiast
  • Content Count

    11
  • Joined

  • Last visited

About Jordandavis

  • Rank
    Member

Profile Information

  • First Name
    Jordan
  • Ford Model
    Focus 1.8
  • Ford Year
    2009
  • UK/Ireland Location
    Hampshire

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Okay thank you for that I’ll give that a try now I’ll post an update keep you informed when it’s does starting working again and what it was
  2. That’s right and only been checked visually my friend who’s good with cars only had time to visually check it but he said he’s going to do a proper look at it but he doesn’t think it’s that he’s plans on doing it Monday or Tuesday for me it’s strange how it drove fine to get petrol then when to do another test drive then nothing I didn’t think a starting motor could go that quick as it’s started up fine when we had then all of a sudden nothing
  3. Yeah we have got a spare key that doesn’t work either and we put a full tank in when we got it then went to drive it when we got home then bam nothing, don’t know if this helps but went we try start it it makes a clicking sound my father in law said that a good sign and if you look on YouTube this problem happens quite a lot but no one fix is the same we’ve been going throuugh them nothing as of yet, I don’t know too much about cars myself but how much would that cost to fix/ could I do it myself?
  4. Thank you all for your help will look into that it’s makes and attempt to turn over the immobiliser light does flash also when trying to start up its now saying engine malfunction we’ve checked the fuse changed them over two checked the earths my mechanic friend check the starting motor he said that looks fine I’ve even checked the cluster took it out it’s one big unit all the cables look fine checked the passenger fuse box two that’s all good did the fault code check but people are saying that they won’t help Not sure what else I could do that
  5. If I take my Ford Focus 1.8 09 plate that’s not running into Ford do you think they could fix the problem or at least find the fault we think it’s the cluster drove fine for 20 mins after we brought it the guy did say it needed a new battery so when it broke down we thought it was flat brought a new one still won’t start up I’ve looked over it can’t seem to find nothing got my mate who’s a mechanic can’t find nothing wrong with it not to start
  6. I have the same problem with my car only brought it 2 days ago drove it fine then went to drive again broken down changed the battery thinking it was that looked at the starting motor not that checked the fuse box that’s all fine a lot of people are saying it’s the cluster for some reason
  7. Yeah they did mate also check the starting motor that’s fine and the fuse box is all good too
  8. Hello just brought a Ford Focus 1.8 09 plate drove for 5 mins now won’t start we thought it was a flat battery brought a new one no luck won’t start says engine malfunction now too code are d900 e510 and d147 I know this isn’t the right chat but please someone help wasted money so upset
  9. Hello just brought a Ford Focus 1.8 09 plate drove for 5 mins now won’t start we thought it was a flat battery brought a new one no luck won’t start says engine malfunction now too code are d900 e510 and d147
  10. Hello just brought a Ford Focus 1.8 09 plate drove for 5 mins now won’t start we thought it was a flat battery brought a new one no luck won’t start says engine malfunction now too code are d900 e510 and d147
  11. Hello just brought a Ford Focus 1.8 09 plate drove for 5 mins now won’t start we thought it was a flat battery brought a new one no luck won’t start says engine malfunction now too code are d900 e510 and d147