Jump to content
Do Not Sell My Personal Information


AlwaysTrouble68

Budding Enthusiast
  • Posts

    11
  • Joined

  • Last visited

Profile Information

  • First Name
    Tony
  • Ford Model
    Focus1.6tdci
  • Ford Year
    2010
  • UK/Ireland Location
    Devon

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

AlwaysTrouble68's Achievements

  1. I've just checked the MAF sensor readings with FORscan live data and it's reading 10.8 at idle. Seems a bit high to me? Confused now 😕.
  2. Sorry for delay. You were spot on. My MAF is running at 6 on idle. So im guessing it's something else. ***** annoying. Doesn't matter what gear your in, it's always around 1500rpm particularly when light on the throttle ie just feathering. Thank you for your help. Tony
  3. Since I've had the car about a year. Looked in FORscan and nothing showing. Any idea what a good maf should read at idle ? Thank you for your reply
  4. Sorry if I have duplicated this question. Focus 1.6 tdci 2010. Has anyone managed to sort out the 1500rpm hesitation problems yet as I cannot seem to find fault with anything.
  5. Hi all. Does anyone know if the stuttering/hesitation issue @ approximately 1500rpm has ever been solved 🤔. 2010 1.6 tdci focus. Thanks
  6. Has this issue been resolved yet. If so does anyone know how 🤔.
  7. Welcome to Ford Owners Club - Ford Forums. Please feel free to browse around and get to know the others. If you have any questions please don't hesitate to ask.

  8. Hi all. Turbo leaks common? What's the solution guys 182k miles and still pulls really well but a bit worried about the leak. ???
×
×
  • Create New...

Forums


News


Membership