Jump to content
Do Not Sell My Personal Information


Matthew Cain

Budding Enthusiast
  • Posts

    3
  • Joined

  • Last visited

About Matthew Cain

  • Birthday 06/01/2001

Profile Information

  • First Name
    Matthew
  • Gender*
    Male
  • Ford Model
    Focus
  • Ford Year
    2003
  • UK/Ireland Location
    Greater Manchester
  • Interests
    Classic Cars
    General Automotive
    Motorsport & Racing
    Car Restoration
    Car Modification
    Food & Drink
    Computers & Electronics

Previous Fields

  • Location
    Manchester

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Matthew Cain's Achievements

  1. Already checked the Oil and its very clean, especially since it done 10k miles since last service a year ago
  2. Would have thought it'd be running a bit more lumpy and a loss of power if it was a compression issue. Might look at getting a compression test done just in case. Thanks
  3. Welcome to Ford Owners Club - Ford Forums. Please feel free to browse around and get to know the others. If you have any questions please don't hesitate to ask.

  4. Got an issue with engine vibrations inside the car, you can really feel it at 2k revs through steering wheel. Higher the revs the more consistent it gets. Engine itself is running as normal, no EML, no decrease in MPG, no smoke, no abnormal noises, no power loss etc. This issue happened all of a sudden, felt I came to a stop at a red light on my way to work and could feel a slight judder in clutch on hillstarts only, initially I thought it was just a clutch judder but further investigation cancelled that out. Have replaced all motor and gearbox mounts It's definitely inertia from the engine running, but when I press clutch in it doesn't go away or get worse so to me that cancelled out any problems with clutch or flywheel. Front Subframe is in good condition, all bushes are OK, all gears work as normal, no missing nuts or bolts anywhere, brand new mounts. Checked oil and its nice and clean, no signs of any metal particles. Any ideas? Thanks
×
×
  • Create New...

Forums


News


Membership