• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


amigadude

Budding Enthusiast
  • Content count

    29
  • Joined

  • Last visited

Everything posted by amigadude

  1. thought it was gonna be the bearing at the top of the suspension but nope... that would be constant in both directions and yours seems to be only when steering right ie past straight forward rather than just when turning the steering wheel right.... So wear/damage on a component that only comes into play past that point.... I'd axle stand/jack the front end and remove the wheels and look for damage, failing that get someone to turn the wheel while you listen close enough to find the source of the click...
  2. 1.4TDCI 04 Fusion I had a whistle @ 3000rpm so I removed the air intake all the way to the turbo, inspected all the pipe work for cracks then refitted... good news the whistle is gone... bad news turbo now feels like it kicks in @ ~2500rpm instead of 1700rpm like it did before stripping & refitting... could it be damage to the air flow meter? seems like the only thing I could of accidentally knocked/dirtied...
  3. Turbo kicking in @ 2500rpm instead of 1700rpm

    Turns out the MAF was faulty, broke the gauge trying to get rid of/dim the 12 megawatt blue LED so I can't check when the boost kicks it but... Set off to drop the wife at work and almost got back-ended due to the lack of acceleration, always feels worse on cold days but it really felt like I was towing a double decker bus that day... so when I dropped her off I popped the hood and disconnected the MAF... and proceeded to leave half the front tyres on the road outside my wife's workplace... I guess I'd got used to giving it a good kick to try and get her rolling... Quick visit to scrapyard and £25 for MAF and the pipe between the MAF and the turbo (parts Ford wanted about £400 for) and she's back to accelerating like a 1.4TDCI rather than an asthmatic snail towing a house brick... Had to get the parts off a 1.4 citroen C3 as they'd all been robbed off the Fords and peugeots with the same engine. Had to remove the battery for a while to reset the engine warning light from running without a MAF.
  4. Raider32's Mobius Camera

    He's in a rush to join the chain bar congestion... will this road work ever end?? :(
  5. Turbo kicking in @ 2500rpm instead of 1700rpm

    I T'd off of the waste gate actuator line. What power the engine is giving is at about 2500RPM same as before I fitted the boost gauge.
  6. I removed the irritating whine from the B40/A118C mic by equalising ~5900Hz as low as possible.
  7. October Compilation - took a while then I had to redo due to copyright hit on some crap song on the radio
  8. not a compilation but... yeah! I luv Bradford... replaced link with fixed audio version
  9. Turbo kicking in @ 2500rpm instead of 1700rpm

    still not kicking in early enough I think... anywayz here's what the boost is up to...
  10. :( keeps throwing an EGR fault saying the reading is out of range, the garage who fitted the clutch have reset a couple of times they seemed to think it was getting triggered by multiple stalls while the mechanic & I were getting used to the really low biting point, but I haven't stalled it once since the last reset. Drove around for 10mins light stayed off, parked at my folks house, had a coffee and a chat... and the light was on when I restarted the car :( Banged/broke a sensor or knocked the carbon deposits loose fitting the clutch is my wild and uneducated guess... opinions/guesses?
  11. Engine fault light after new clutch fitted

    yeah! fixed it!! I was nosing around the engine compartment (routing the pipe for my boost gauge, dianostics only, gonna be behind the dash most of it's life) and near this doodat I found an electrical connector... anyways plugged... connected my new OBD2 wifi adapter and cleared the error... fixed! well so far no light....
  12. Engine fault light after new clutch fitted

    ...and they switched the lines around and reset the error...and it came back,,, So I cleaned the EGR myself (It's the vacuum actuator type) and got them to reset the error... fingers crossed... ...and nope light is back on... FFS
  13. Engine fault light after new clutch fitted

    ...and the light is back... just gonna get them to clean the egr for me... weather is too crap now for DIY mechanics without a garage...
  14. Engine fault light after new clutch fitted

    I think I might of found the problem... seems the mechanic forgot to re-attach 2 air/vacuum lines... they should go to this thing between the battery and the back of the near side headlight.... got the garage to work out which one goes to where and reset the fault through obd.
  15. I had 2 people run into me exactly a month apart. 13th of July I was rear ended while stationary waiting for the lights to change at a crossing. 13th of August while I was getting computer parts from CCL on a nearby industrial estate, the taxi in front of me stopped suddenly then reversed into me... I thought he was going to try an insurance scam on me so I pointed at my phone on the dash and said I had a dashcam app running (I'd forgotten to start the bluetooth so it wasn't...). Luckily I got CCTV footage from one of the businesses on the estate. Test footage from the G1W-H (the -H version doesn't have chrome around the lens so it's a bit more stealthy) the stock music on the night scene is because my father-in-law is in the passenger seat, it's better that way trust me...
  16. Idiot runs red light and some bits and pieces

    I used to work near those lights, in SS Audio, Sony Centre & Gerrards. After market head unit installed... my to-do list is shrinking quickly...
  17. Turbo kicking in @ 2500rpm instead of 1700rpm

    I re-seated the vacuum line on the wastegate seems to be back to normal now...
  18. Turbo kicking in @ 2500rpm instead of 1700rpm

    I cleaned the MAF with electrical contact cleaner as I couldn't find MAF cleaner anywhere... seems a little bit better...
  19. ...another fine idea brought to you by the morons who drive taxis in Bradford. (NSFW quite a bit of swearing... SFW if you mute :) ) on the subject of parking... :)
  20. Raider32's Mobius Camera

    I need to start reviewing my footage (or get a cam that has a button so you can mark idiot moves...) got a couple of red light runners and a few BMW/audi tossers cutting ppl up today.... so quiet day driving in Bradford
  21. Raider32's Mobius Camera

    I guess you live near me... not surprised to see the chain bar roundabout feature in one the videos, I spot some poor lost soul on there every other time I'm on it... only gonna get better after they finally finish adding the extra lane.... not!
  22. Ford Fusion Owners?

    Got a 1.4TDCI 04 plate in Oyster Silver (Gold). I think I still had the 1.25 mk4 fiesta when I joined up. Solid vehicle only ever failed MOT on consumables like exhaust, tyres & bulbs. Put some focus alloys on after I dinged a steely on a kerb cos it was cheaper than buying a wheel and new tyre. 50quid including 2 barely legal & 2 good decent (more expensive than the Goodyear efficient grips I have on now) brand tyres.
  23. Spotted this in the passenger footwell of my 04 Fusion 2 anyone know what it's for? aux on a better factory stereo?
  24. Mystery Connector Behind Glovebox

    Good idea.... I'll look see if I can find confirmation either way...