• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Timbo

  • Rank
    Settling In Well

Contact Methods

  • First Name

Profile Information

  • Ford Model
    Mondeo Titanium
  • Ford Year
  • UK/Ireland Location
  1. Thanks, will let you know! Tim
  2. Hi, Thanks for the reply. I tried it yesterday when it was 15 degrees. my first thought was lack of gas, but I thought that there would be a code shown for low pressure. Among the receipts that came with the car was one for £700 to supply and fit a new compressor in 2016! The car saw little use since then, so may just need a re gas. Tim
  3. Hi, Thanks for the reply. It's the dual zone climate control. I just get ambient to hot air. All the fan speeds and air direction flaps work though. I thought that it may just be low on gas, but wouldn't that show up as a low pressure fault? Thanks Tim
  4. Hi all, I've recently purchased a 2009 Mondeo Titanium. The climate control does't work. I ran the self-diagnostic feature, but no fault codes came up. I'd appreciate any advice on where to look first! Thanks Tim
  5. Hi, thanks for the replies! Tim
  6. Hi all, I'm thinking about blocking off my EGR valve on my 2004 Mk3 Mondeo duratec. The throttle response has always been "wooly" and I'm hoping to improve it. There's lots of info on doing it on diesels, but hardly any on petrol engines. Has anyone done it, and what was the effect? Thanks! Tim
  7. Looking To Upgrade My Headlights

    I just replaced my bulbs with Philips Xtreme bulbs (Less than £20 on Ebay when I bought them) If your headlamps are in good condition, it's a cheap and easy fix. Osram Nightbreaker are also good. They're cheaper too, but maybe not quite as good as the Philips bulbs. Tim
  8. Poor Throttle Response

    I replaced the MAP sensor and the low speed hesitation now seems to have gone. £16.50 and 30 minutes work! Thanks to all who replied! (And thanks to Ebay for being so cheap!) :D Cheers Tim
  9. If the thermostat is stuck open, you won't get hot air from the heater. Other possibilities are a blocked heater or an air-lock. Have you disconnected part of the cooling system recently? For the cost of a thermostat, I would change it now, before the weather gets much colder. Tim
  10. Poor Throttle Response

    That's ok, I find it all confusing too! My knowlege is more points, carbs and condensors, haha. :D
  11. Poor Throttle Response

    Hi, thanks for the reply. You are correct, no MAF sensor on my car. I mentioned the MAP sensor, (manifold absolute pressure, I think) which takes its place. It goes in the inlet manifold. Cheers Tim
  12. Poor Throttle Response

    Hi, thanks for the reply! Would that show up on a code reader? I've also been told that a faulty map sensor could be to blame. Thanks Tim
  13. Hi all I have a mk3 1.8 petrol Mondeo which is in excellent condition. My problem is that there's a really noticeable "flat spot" below around 2500 rpm. It's like the throttle cable's made of elastic. It starts and runs really well apart from this, so I'm a little mystified! It's had a new coil, plugs and leads and I've cleaned the throttle body and MAP sensor. There aren't any fault codes either, so I don't know where to look next. Any help would be great! Thanks Tim :)
  14. Hi all. Following on from a previous enquiry, I had my thermostat changed today, and discovered that there was no electrical connector on the old one. What purpose does it serve, as I've read different views. I had mine changed in an attempt to improve the in car heating. I was also told that the fan comes on at 89 degrees! I guess the temp sensor is next. Does this measure metal temp, or coolant temp? I've just spoken to my Mechanic again and he said that my car doesn't have any wiring for the electric part of the thermostat either! I'm really confused now, as I thought that all Mondeos like mine had this feature. Any ideas? Thanks! Tim