Andrew_S-Wales

Budding Enthusiast
  • Content count

    10
  • Joined

  • Last visited

About Andrew_S-Wales

  • Rank
    Member

Profile Information

  • First Name
    Andrew
  • Ford Model
    Fiesta Titanium Ecoboost
  • Ford Year
    2013
  • UK/Ireland Location
    RhonddaCynonTaff

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Andrew_S-Wales

    2013 1.0l Ecoboost engine rust. Problem?

    Like other posters here I've also noticed some surface rust on a section of the degas hose. Again just surface rust so far but the clips on the hose look worse. Am I right in thinking there's a later part that is all rubber that could replace it?
  2. Andrew_S-Wales

    2013 1.0l Ecoboost engine rust. Problem?

    I didn't use a primer, just rubbed down the pipes as best I could to get rid of the surface rust.
  3. Andrew_S-Wales

    2013 1.0l Ecoboost engine rust. Problem?

    Well its been a month since I treated the rust on the pipes in my engine so still early days but all looks good so far. This is the paint I used: http://www.halfords.com/motoring/paints-body-repair/specialist-decorative-paints/halfords-vht-paint-silver-grey
  4. Andrew_S-Wales

    2013 1.0l Ecoboost engine rust. Problem?

    Brushed, used VHT paint from Halfords.
  5. Andrew_S-Wales

    2013 1.0l Ecoboost engine rust. Problem?

    After a number of telephone conversations with Ford and being directed to dealers up to 30 miles away I thought I'd try to sort it myself:
  6. Andrew_S-Wales

    2013 1.0l Ecoboost engine rust. Problem?

    Cheers, will do.
  7. Andrew_S-Wales

    2013 1.0l Ecoboost engine rust. Problem?

    I've had a reply from Ford today who are going to discuss the matter with the dealer who looked at my car last week and they've promised to get back to me by Monday at the latest with an answer. Given that the rust on the pipes is similar to yours I'd be happy to have the same resolution.
  8. Andrew_S-Wales

    2013 1.0l Ecoboost engine rust. Problem?

    I've sent an email to Ford and am waiting to be allocated a 'Case Manager' who will deal with my issue (i.e. probably tell me to get lost!). I'll update the thread when they get in touch.
  9. Andrew_S-Wales

    2013 1.0l Ecoboost engine rust. Problem?

    Having read this thread I checked my engine late last week and have rust on the surface on both pipes (doesn't look to have gone deep at the moment. I took the car to my local Ford dealer for them to take a look and they said they were unaware of any issues and had never seen anything like it on an Ecoboost before. Their initial advice was to "keep an eye on it" but when I made my concern more clear the recommended rubbing the surfaces clean of rust and to apply some VHT paint to prevent further corrosion. I'll be sending an email to Ford UK to get their view on the problem, and I'll include these pics together with the link to the Danish info posted earlier. Given what appears to be a low number of cases I won't hold my breath for a positive response. The car has done 45k and has had 4 services since new.