Chucky341

Budding Enthusiast
  • Content Count

    26
  • Joined

  • Last visited

About Chucky341

  • Rank
    Member

Profile Information

  • First Name
    Johnpaul
  • Ford Model
    Mondeo
  • Ford Year
    2010
  • UK/Ireland Location
    West Midlands

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Chucky341

    St line

    Hello I just wanted to ask is the st line same as the st or is the st line the model in the middle of the basic - sporty one
  2. Ok let me explain it this way Option 1 I put £60 in the car to fill up the tank that last four to five days Option 2 if I put in £20 that £20 last me 2-3 days So £60 last for 9 days in option 2 ( Best case scenario ) so I am paying out £60 ya that true but the £60 lasted 9 days in option 2 so in option 1 u would have to pay more money to make it last the week so it as save u money
  3. Ya I know it pain in the ***** keep filling up but if it better for me & save me money then I am not complaining
  4. I have got a iPhone xs plus got 2018 kuga st & it read the text msg out ( first it tells you got a msg then u have to click on hear it then it read it out ) hope this help
  5. I got a 68 plate ford kuga eco-boost St line 1.5 petrol my mpg is about 28 - 30 if I am lucky on motorways about 34 so not great but on a another note if I put £20 in petrol every 3 days I get more petrol for my money then if I fill the tank
  6. Well I just bought universal seat covers from Halfords £16 i got a few sets from eBay but the back sets none of them fitted
  7. I got a 68 plate ford kuga eco-boost St line 1.5 petrol my mpg is about 28 - 30 if I am lucky on motorways about 34 so not great but on a another note if I put £20 in petrol every 3 days I get more petrol for my money then if I fill the tank
  8. I got a 1.8 td when the light did come on the code did point to a egr valvue that what the aa guy said any way plus I point some egr cleaner In the air take this morning so hopefully that will sort it out but the only codes on the car is a cruise control code but I know about that fault
  9. Hello I have have a Engine fault light come on my dashboard on Friday so I got the aa put to see what was wrong they said it was this code Patrol found the following fault code/s:System : Engine control 1 - 52Q / Diesel CR/EDC SID 206P1335 - Exhaust-gas recirculation valve. Error Message : Open circuit or disruption.P0489 - EGR position sensor B. Error Message : Control on lower stop.removed wiring connection so any way he got the light to go out so he said if the light come on again I need to get it sorted well yesterday I parked I. Morrison to do some shopping when I come out I started my car engine it started but about 5 second later it just cut out so try again this time I put my foot on the gas pedal to rev it up but Notting happen then engine cut out again that happen 3-4 times then Eventually it work with the gas pedal since yesterday that has happen 3 times so I call aa out again he said he can’t fine any faults codes so he can solve the problem but he said the egr valve can cause starting problems so do u recommend me getting the egr fixed I was quoted £440 that with fitted
  10. Hello I have got an1.8 to 2010 ford mondeo mk4 over the last month I have notice that my car stalls more on hill starts first I thought it was just me being stupid & I lifting my foot of the clutch to quick but it not I notice when I get the bitting point I have to give more gas then normal to move off otherwise the car stalls if I am on a hill I have had a new clutch flywheel last August so dont know what it could be any ideas would help plus i don’t know if it my imagination but some time if seen as if the clutch pedal don’t come al the way back to its normal position after i change gear so if I got any questions nor answer for me please let me know thx in Adv
  11. Hello I have got an1.8 to 2010 ford mondeo mk4 over the last month I have notice that my car stalls more on hill starts first I thought it was just me being stupid & I lifting my foot of the clutch to quick but it not I notice when I get the bitting point I have to give more gas then normal to move off otherwise the car stalls if I am on a hill I have had a new clutch flywheel last August so dont know what it could be any ideas would help plus i don’t know if it my imagination but some time if seen as if the clutch pedal don’t come al the way back to its normal position after i change gear so if I got any questions nor answer for me please let me know thx in Adv
  12. Well Someone I know who done the code reading for me he charge me £30 it came back as p120f high pressure regulator ( excessive variation) he told me to book it in with car wood to get it check again as then is three different things it could be so I got that book in for tomorrow i had a look on eBay for that code reader it about £10 which is good but if it don't point to one Pacific part It don't really help
  13. Hello I got a ford mondeo 2010 1.8 about 1 month ago as i work nights I let work as I normally do in the morning I was driving down the duel carriageway doin about 70 my Engine malfunction light come on so I slow down the. It went off so I went home ever since then it ain't come back on till today Driving to work just join the Duel carriageway doin about 50 it come on again I am goin to get it check tomorrow but it still runs fine it twice only come on whe. The car bin sitting they with out moving for a few hours any ideas
  14. Ok thx for the info I got it book in next week so I will wait and see what they say
  15. Hello this is my first mondeo Diesel car I had a focus before this but never had cruise control before but when I select cruise control it goes to standby which is normal & I go to set it at a speed ( when I hit the set button ) all the cruise control goes off ( standby as well as if I ain't selected it ) then I have to hit the cancel button reset button Decrease button just in case them button stick ( but I have never used them buttons ) then i select cruise control again & set speed this time it actives ( or if it don't I repeat ) is this normal with cruise control thx in advance