• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About JG0

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
  • Ford Year
  • UK/Ireland Location
  1. Fixed! Prior to your reply I'd already ordered a holder for the rear bulbs for £6 from eBay: It arrived today so I fitted it and it worked! I was getting ready to try and trace the wiring, so I was glad it didn't come to that, haha. Thanks very much for your help, appreciated.
  2. I just switched the fuses around, according to this diagram: And these instructions (though my fuses were 7.5 amp): http://www.autogenius.info/ford-fiesta-mk4-fuse-box-diagram/ F6 10 LH sidelights F7 10 RH sidelight And there's no change. The passenger side rear lights are still working and the drivers side rear lights aren't.
  3. Hi all. I have a MK IV Ford Fiesta, 2001. My drivers side tail light isn't working. The fog and brake lights work. At first I assumed it was the bulbs, but I've tried each of the bulbs in the fog light slot and all of the bulbs work when put there, so it isn't that. Any help would be much appreciated. Thanks a lot.
  4. I've got a Y reg Ford Fiesta. My fuel cap was very stiff and my key very nearly got stuck, to the point that I believe I twisted the barrel, which meant that the fuel cap wouldn't go back into the hole anymore. When playing around with it, I've accidentally taken the whole thing apart. I believe I've put it together and aligned it correctly: However, it doesn't click down and just bounces back up due to the spring: Can anyone help? Is there a trick to getting it to stick back in place? Thanks very much.
  5. It's a 1.2. With mine it revs to 3000-4000 every time it's out of gear, such as when I'm coasting or when I'm stopped. When I turn the car on and it's sat on the drive it revs. After reading up a little more I think it could be something to do with the throttle cable?
  6. I have a Y Reg Ford Fiesta 2001 Zetec-S. Currently whenever it's out of gear it revs up to 3000, sometimes 4000. I've looked it up and it says that it's often a problem with the idle control valve, which needs to be cleaned, however, I can't find my idle control valve. I'm not experienced with cars, so excuse the probable idiocy of this question. I've looked it up and it says it's below the inlet manifold, which seems like it should be in the bottom of the picture, right and centre. On pictures of other Fiesta engines I've looked at, the inlet manifold is open with rubber pipes. Is the cover over where my idle control valve should be? If so, I assume I have to remove the cover and then I'll see the idle control valve? Thanks very much for any help, I've attached a picture of the engine below.