Rikesh

Budding Enthusiast
  • Content Count

    2
  • Joined

  • Last visited

About Rikesh

  • Rank
    Newbie

Profile Information

  • First Name
    Rikesh
  • Ford Model
    Fiesta Titanium
  • Ford Year
    2008
  • UK/Ireland Location
    London

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Rikesh

    Fiesta Titanium 2009 not blowing hot air

    Thank you for the replies. I went over a bump yesterday and it started working all of a sudden. Flap closed fine and started heating again. But again today didn't work. So the flap opens and closes but doesn't work all the time so might be as stated above. Thanks for the replies, will post again here if I find a fix.
  2. Hi everyone, This seems to be an issue posted couple of years ago but didn't find a solution. Apologies for my restricted car knowledge but keen to learn. Basically, I used to press the MAX button on my heating control unit and hot air used to blow within 10 seconds. Now, no matter what temp the car is set to, even at 30 degrees the car still blows cold air even after the car has been driving for hours. I've been told by Halfords that it's the "flap" which sounds right as when I used to turn the heating on there was a clear recognisable sound like a flap closing after 2 seconds and then the car would blow hot air in seconds. Now there is no such noise when I turn the heating on. He said along the lines the flap should close and blow hot air and open for cold air. At the moment its not closing? I've been told by one mechanic that I should just change the entire heating unit or something along those lines. If it is this "flap", which parts would I require to order? Thanks for looking! Rik