DorianCmax

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About DorianCmax

  • Rank
    Newbie

Profile Information

  • First Name
    Dorian
  • Ford Model
    07 Focus CMax 1.6 TDCi Ghia 5d CVT Auto
  • Ford Year
    2007
  • UK/Ireland Location
    London
  1. DorianCmax

    W Reg Focus Losing power

    Suggest as a starting point you get a multi-meter and check the battery voltage at rest, while running and at rest again a while after. This will help tell if maybe its the alternator not charging the battery, or the battery not holding the charge. There are a few you-tube videos on how to do these checks. A year or so ago I had a dodgy battery and it wasnt simply about starting, it started fine, but lack of proper power while running made the ecu and transmission misbehave and it cut out too. It had given me all kinds of alarming expensive sounding codes, but it was just the battery in the end.
  2. Hi 07 Ford Focus C-max 1.6 TDCi Ghia 5d CVT Auto (Euro 4). There are many forum posts and threads on the TDCI power loss on acceleration, but I can’t find one with my own version... As per many others, if I accelerate hardish out of a roundabout or junction then power loss happens followed by stall / cut out. This is with my auto gearbox in Drive. So maybe EGR, maybe DPF, maybe fuel pump, maybe air/fuel lines, maybe ECU as per others posts. Yes I get the code P2002 DPF efficiency below threshold. I have the P2584 fuel additive ELYOS level one, and I get U0073 control module comm bus A off, which I think is secondary. But people have addressed all these and made no difference. If I clear them and retry, the fault happens (every time now) but the codes dont come back straight after, or even as pending, until some normal driving later. Here’s the thing... if I switch my gearbox into the semi auto side (M, and +/-), I can accelerate to my hearts content, keep in low gears rev to 4000 and hold it there - fine no issues. So it can’t be mechanical, fuel line, EGR? Maybe electronics associated with the auto? Anyone tried this experiment or can explain it? I put some wynns dpf cleaner in and have been driving at over 2000 to try to kick in regen, but no change yet. Car is rusty, not worth spending on maybes of EGR, fuel pump, even the DPF additive and ecu reset I’m tight on! thanks Dorian