• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Darf82

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
    Focus 1.6 D zetec
  • Ford Year
  • UK/Ireland Location
    West Midlands
  1. Please help electrical fault

    Thanks again will have a look tomorrow. Number plate lights seem to be fine. I will add when I press boot switch the centre brake light comes on too. I will check wires tomorrow.
  2. Please help electrical fault

    Ok thanks. I'll have a look. On the odd occasion I press the rear demisters switch it flashes the stereo lights on for a split second
  3. Hi guys thanks for your time. I'm new to the forum so hi 👋 My wife's car is a 2009 1.6 D zetec Right the problem I have is when I put my rear demisters on it doesn't work but it comes up on my dash saying rear luggage compartment open. Also when I look outside when the switch is on the centre brake light comes on and rear wiper doesn't work. Switch the rear demisters switch off and rear wiper starts working and brake light goes off but still rear demisters doesn't work. Also when I hit my brake pedal it comes up on dash luggage compartment open. I've opened all the back up and spray all switches with silicone spray. (Wiper/boot switch/rear lights) The boot switch still works with button and keyfob. I had a feeling it may be foot brake switch but the brake lights all work fine when the rear demisters switch is off. Please can anyone help