FordFocus2005

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About FordFocus2005

  • Rank
    Newbie

Profile Information

  • First Name
    Sam
  • Ford Model
    Ford Focus Titanium Mk2 2005
  • Ford Year
    2005
  • UK/Ireland Location
    London
  1. FordFocus2005

    Head Unit Fried?

    Thanks Luke, where would i test the voltage to make sure too much isn't getting through? On the battery?
  2. FordFocus2005

    Head Unit Fried?

    Thanks very much Benedict, I've ordered a second hand one but I'll do some checks before i plug it in
  3. FordFocus2005

    Head Unit Fried?

    My car has had some electrical issues and made a bad burning smell the other day. I've taken the head unit out today and the smell is definitely coming from in the head unit. Is it possible for a head unit to spontaneously fry its own components or is there a bigger issue that has caused this? My car is 2005 Mk2 Ford Focus with the sony 6000CD head unit.
  4. Hi, I was driving home the other night and my radio stopped working, interior light for the hazard button wouldn't work and the warning lights for airbags and drivers seat belt warning lights came on the dash. There was also a plastic burning smell, like there had been surge in the wires which had caused the plastic coating to melt. I drove the car yesterday on a short journey and all of the electrical faults were gone apart from the radio which still wasn't working although there is now a clicking noise coming from the fuse box although I have checked all the fuses and none of them have blown. Today I have taken a few interior panels and the head unit out to see if I can find any burnt wires but without any success. Has this happened to anyone else or does anyone have any advice? My goal is to find the issue so I can get it fixed professionally. Thanks
  5. Hi, I was driving home the other night and my radio stopped working, interior light for the hazard button wouldn't work and the warning lights for airbags and drivers seat belt warning lights came on the dash. There was also a plastic burning smell, like there had been surge in the wires which had caused the plastic coating to melt. I drove the car yesterday on a short journey and all of the electrical faults were gone apart from the radio which still wasn't working although there is now a clicking noise coming from the fuse box although I have checked all the fuses and none of them have blown. Today I have taken a few interior panels and the head unit out to see if I can find any burnt wires but without any success. Has this happened to anyone else or does anyone have any advice? My goal is to find the issue so I can get it fixed professionally. Thanks S