Search the Community

Showing results for tags 'Titanium'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to Ford Owners Club
    • Review your Ford
    • Discount Scheme
    • New Member Introductions
    • Was it you!? FOC Members Spotted!
    • General Ford Related Discussions
    • General Chat
    • Ford Guides
    • Show off your motor!
    • Car Insurance Discussions
  • Ford Models
    • Ford Fiesta Club
    • Ford Focus Club
    • Ford Mondeo / Vignale Club
    • Ford Mustang Club
    • Ford KA / StreetKA Club
    • Ford Kuga Club
    • Ford Edge Club
    • Ford B-Max Club
    • Ford C-Max Club
    • Ford S-Max Club
    • Ford Galaxy Club
    • Ford EcoSport Club
    • Ford Fusion Club
    • Ford Puma Club
    • Ford Escort Club
    • Ford Sierra Club
    • Classic Ford
    • Ford Transit Club
    • Ford Ranger Club
  • Buy & Sell
    • Club Cars For Sale
    • Ford Parts For Sale
    • Classifieds
    • General Items (Non Ford Related)
    • Wanted
    • eBay Finds
    • Buy & Sell Archive
  • Traders
    • Visit Owners Club Insurance Page
    • Opie Oils
    • Advertise Here
  • Ford Modifications and Projects
    • mountune Discussions
    • Photoshopped Ford Photos
    • Ford Project and Build Threads
    • Ford Modification Discussions
  • General Forums
    • Ford Owners Club Meets & Regional Discussion
    • Maintenance / Servicing / MOT Discussions
    • Dealer Problems & Consumer Advice
    • Technical Knowledge
    • Wheels & Tyres
    • Detailing your Ford
    • Audio & Electronics
    • General Site Requests
    • Computing, Gaming and Geeky
    • Dash Cam Videos
    • Ford Motorsport
  • Back Office
  • Ford How-To Guides

Categories

  • Ford Reviews
  • General Ford Guides - Modern Fords
  • Ford Fiesta Guides
  • Ford Buyers Guides
  • Ford Focus Guides
  • Ford Fusion Guides
  • Ford C-Max Guides
  • Ford S-Max Guides
  • Ford Ka Guides
  • Ford Mondeo Guides
  • Ford Kuga Guides
  • Ford Galaxy Guides
  • Ford Puma Guides
  • Ford Escort Guides

Product Groups

  • Advertisements
  • Premium Membership

Calendars

  • Community Calendar

Categories

  • Articles

Categories

  • Premium Member Discounts

Categories

  • Articles

Categories

  • Official Ford Videos

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


First Name


Ford Model


Contributor


Location

Found 133 results

  1. Hi, My partner has a 63-plate Fiesta Titanium Ecoboost (face-lifted version with larger grill) Up until about 1pm today, it's been largely issue free, but all of a sudden the car will not lock with the remote fobs unless standing right next to the car. It's not been a gradual reduction in range to indicate a expiring fob battery and the issue has occurred with both fobs simultaneously, which is telling me it's a hardware issue on the car. Are there any known things to try before I book it into the dealer for the inevitable expensive diagnostic & parts replacement routine?
  2. Focus 2015 Titanium X Heated Steering Wheel not working Anyone have any suggestions? My Heated Steering Wheel is not working. I press the button which illuminates briefly then goes off. Wheel doesn't heat up. Any ideas? GK
  3. Chunx4t

    Ford Edge First Impressions

    Well I picked up my new motor, and have not been dissapointed, although I have only done a few hundred miles each one has made me smile, really impressed with the auto box it feels seamless even in Sport, I've even had a play with the paddles, but they are now pretty much redundant, and so far no left foot braking, but I do tend to go for the gear stick whilst approaching junctions. This is my first automatic and to be honest I wish I had gone for one sooner. I'm also impressed with the engine and it feels very capable, and in my opinion more powerful than I had expected, in line with the gearbox it also feels smooth, my good lady has put it through it's paces and has commented that it is no slouch. So far there have been no niggles, no squeaks, creaks or rattles or any other issues and everything appears to work as it should. The seats are comfortable, although my wife says the mondeo was comfier, I'm not convinced, that asides she likes the car also. My mother in law is not as able as she used to be and she gets in and out much easier than the Mondeo, instead of basically falling in to and having to be pulled out of the Mondeo the seat is at a height where she can sit on it and swing her legs in and out, adjustable suspension would have been a nice option. I've read in other posts about problems with the tailgate, and I have had one phantom closure, I can only assume that I activated the sensor with my foot whilst putting the dogs in the back, as I am now conscious of this It has not happened again. Still early days and only 800 miles on the clock so I will not go too overboard on the first impression praise, but so far so good.
  4. Ive had minimal issues with my car for the last two years until now I keep getting the ENGINE MALFUNCTION and REDUCED ACCELERATION and the ESP light go on... restarting the car clears this issue for a bit. but this can be a bit problematic on motorways. Any clue as to what might be the problem. On another not but which could be connected or coincidental I do have a distinct juddering on braking in the range from 32-38 mph but above or below its not felt. I have put this down to a very slight knock/tap i had in the winter weather sliding into a kerb at 2mph afterwhich i realighed my tracking and thought nothing of it.... its only recently ive noticed the juddering a lot more... could it be more than warped discs? I have Forscan but Im no master tech and not entirely sure what i am doing on it. Any suggestions? Ford Focus Titanium 09 1.6Ltrs
  5. I've recently purchased a Ford Fiesta Titanium X with Low profile tyres fitted to it. The wheel is a 205/40R17 Tyre profile. I have had it for less than a month and the wheels have been damaged significantly (sidewall) people have been telling me that if I change the tyre from Low profile to Normal profile it will affect Speedo etc but I can't see any other way to stop the car from damaging the wheels and this is on two of four low profile tyres. Is there anything I can do? I live on an estate which is still being built and there are Low manhole covers which could be causing damage but never had problem on old car? Any advice would be greatly appreciated.
  6. I have been on ford owners club for a while now but have never got around to sharing my MK2 Focus Titanium 2.0. Had the car for around a year now and am in the process of modifying it. Mods so far are: ST Front Bumper With Zunsport Lower & badgeless upper Grille Zetec S Rear Skirt St / ZS Spoiler Piper Stainless Steel Duplex Exhaust 4" Slash Cut Tips LED rear Tail Lights LED DRL Projector Headlights Recaro Leather Interior ST / RS Carbon interior Ambient LED Footwell lighting Calibre Suzuka 18" Alloys Heko Wind Deflectors Kill All Wipers De-Wiper Kit Various little bits sprayed & Vinyl Wrapped K&N Air Filter With Custom Air Box ------------------------------------------------------------------------------------------------------------- Side Skirts are currently in the spray shop, so will be going on this weekend. Also have a set of 35mm Apex lowering Springs which i have had for around 6 months & still haven't got round to fitting them lol! Anyway, please see below pictures & enjoy.
  7. Hey guys, I've retrofitted a set of the full leather seats into my 2013 Titanium but ideally I'd like to connect up heated seat function. I'm fairly sure this should be possible because: - The seat connectors on the main loom have all the correct plugs - The heated seat fuses are present in the fuse box - It was an optional extra for this model I've got a set of the correct switches but the only problem is I can't find the unused connector under the dash, I was led to believe it might be taped up under the dash somewhere but I'll be damned if I can find anything like that - does anyone know where I should be looking or would anyone be willing to follow theirs back from the switch to find out where it goes? Thanks in advance
  8. So I'm new here, I'm sorry if I offend people with how little I know about cars etc... anyway, tomorrow I collect my Fiesta Titanium with 125bhp 2014 plate. I am looking to spice the car up a little bit but unsure on what to do with it (suggestions greatly appreciated) and how to do some things - hence the forum post. I am not looking to make this car into an ST with 280bhp or anything like that, I just want to make the car look a little bit more visually pleasing and maybe add a stage 1 map. (The car is a 5door due to me needing the space for work as I carry around a lot of gear). Anyway. The things I have considered doing so far: -Halo ring lights from autobeam, any good? Worth the money? Easy to install or hard? -Upgrade the alloys to maybe some ST alloys or third party ones -Rear windows are already tinted however I would like to tint the front ones as well -Sunstrip on the windscreen -Wind deflectors -Paint the calipers, maybe upgrade the brakes after I have had the alloys fitted -Stage 1 map, was thinking of going to AET Motorsport? Any reviews? Advice? -Induction kit? (Don't really know much about it but it looks very good and am slowly researching a bit more -Upgraded bulbs - Looking to fit some osram H7 and H1 bulbs -TRC Front splitter - will this fit my car or will I need added parts to be able to fit it? Anything else you would reccomend that I haven't thought of? As I say these are just ideas for now. Not looking for anything ridiculously mad for performance wise just more visually! Thanks.
  9. I have a 2009 ford fiesta titanium. I was involved in an accident and the car was returned from the panel beaters with Bluetooth, USB and AUX not working. CD and radio work perfectly besides all of the other features. If any of you have experienced this problem before or know how to fix this it would be a great help! Wondering if it's not the bluetooth module that is broken?
  10. patrick1233900

    Weird RPM while flooring

    Hi. I have a 2007 Mondeo 2.0 Tdci with manual 6-speed. I'm having an issue with the RPM. It's not causing any troubles, but i have been speculating about it for a while now. If i'm driving casually and e.g wants to overtake, it takes a while for the turbo to take effect (pretty normal i guess). When it finally kicks in, my RPM rises to about 3500 and kinda stays there. This mostly happens in 3rd gear, but can happen occasionally in 4th as well. The power is there, but i'm concerned the clutch may be slipping. Previews owner told me the car was chipped, and i'm concerned it has been chipped too high for the clutch to handle it. It kinda acts like if the car had a CVT (which it obviously doesn't). Can anyone tell me the reason for this. I included a video i recorded of it happening: https://drive.google.com/file/d/1RDTCqDFavUVH5bSyzsQAiWNfrECziFsh/view?usp=sharing Thank you in advance. 🙂
  11. Hi guys. I am having a problem with my 14 plate fiesta mk 7.5, I have keyless entry and today i went to use the button on the handle on the passenger side which has stopped working. My driver side is still functional. So I am slightly baffled. Could anyone please share some advice on what to look for. I havr checked the fused for keyless entry they are both fine. thanks in advance
  12. my aux lead was connected to my phone then the other end fell into my cigarette lighter which caused loads of sparks and blew my phone, now my cigarette lighter, aux and usb aint working could it just be the fuses or a more serious problem? if it is the fuses anyone know where they are located? its a 1.4 titanium 2010 fiesta
  13. Hi everyone. I have a 2009 Ford Mondeo Titanium. A few days ago I was driving on a dual carriageway at around 60mph. I was accelerating to 70 and all of a sudden the pull from the engine changed. When I was putting my foot down on the accelerator further the car seemed to make noise but not produce much more power. My car has not had the same pull since this day. When I am driving around town at speeds of around 30mph the pull is good and it sounds like the turbo is boosting, however that changes when driving at higher speeds when the engine revs go above about 2500. The power loss is between 2500 and 3000 revs. There is no smoke coming from the car. What do you guys think this issue could be? Could this be as simple as a fuel filter? Thanks in advance, Carl
  14. can anyone give me some advise, my 1.4 fiesta 08 plate has randomly stopped blowing out any hot air i just seem to be gettin ice cold air, i have ran the car and checked all pipes and they are all hot and coolant levels are fine but it is just refusing to blow hot air and in these cold morning i would much rather have warm air than ice cold blasting through my heaters. could any give me advise or even let me know what the problem is if they have had this on their fiesta.
  15. Hi. I just put a fiesta titanium bluetooth sterio in my basic style model. Everytime I try to use the phone, it says audio mute, also I cant enter a lot of the options menues. Do I need a Bluetooth module or ford activation code of some sort. Thank you..
  16. Looking for some advice here... currently have my standard 16" Titanium alloys that are now showing a little bit of scuffing given they're just over three years old. looking to freshen them up by powder coating in either satin or gloss black, and also looking to lower the car by around 30mm, so question is do I get the existing wheels powder coated...or dig deep and shell out for larger rims in black? I can get the existing wheels done by a friend for just over £100 so this is also a factor. I keep hearing black cars shouldn't really have black wheels but I "think" I like that look but certainly open to opinion, once they're done, they're done! Lol Any photographs others may wish to share to get an idea of how the car might look would be great...look forward to hearing from you all soon
  17. Hello all, Basically I loved my 2010 FORD FOCUS DIESEL HATCHBACK 1.6 TDCI STYLE 5DR [110] [DPF] MANUAL and had it up to 119500 miles. It regularly got up to 54-56 mpg when commuting 5mins on country roads, 20mins motorway driving. It was sitting at 53.6mpg when I sold her privately last night :( After a year of looking and waiting for the right car/deal I decided the time was right to upgrade and bought a private 2012 FORD FOCUS DIESEL HATCHBACK 1.6 TDCI 115 TITANIUM 5DR MANUAL (ECOnetic) version. It has 69000 miles, full service history and last weeks MOT shows 0 advisories. I am only getting 48mpg :( I am gutted about this. When asking fellow focus mk3 1.6 diesel users they are also getting 48/49mpg. I regularly use the cruise control at 70/74mph on motorway driving and think I drive efficently. The last service was 6months ago by a small garage in lancaster where i bought it. Is there a good chance the MPG on my new titanium focus will improve if I put the car through an arnold clark full service? I also miss the 2010 style's steering options of comfort, standard and speed :( I am wondering if I can do anything to improve the MPG? without doing silly stuff like driving down hills with no accelarator etc. Let me know if you need more information. Thanks very much Shaun
  18. Hi there, A few months ago I bought a Ford Fiesta 1L Ecoboost (125bhp), Titanium, 63 reg. I have been having no trouble with connecting my phone and others via bluetooth to Sync media, however when playing music via bluetooth my car does not display track names/artists, but it does when playing music via the USB wired connection. A friend of mine has a lower spec fiesta (zetec), but a newer model (14 reg) and can get their bluetooth mode to display track names... I have been warned that these systems wok better with android phones rather than iPhones (which is what I have) and it is an android phone that my friend uses. Has anyone found similar issues? Or knows whether a 63 reg car is simply not new enough to support the track name information when in bluetooth mode, despite being high spec? Both my Sync and iPhone software are on the most recent updates... Any ideas? Thanks! drward1
  19. SmithyScoot

    Incoming Newbie

    Hi everyone. I'm picking up my 2014 Ford Fiesta this weekend. Its a Titanium X so full of gadgets :). Have any of you modified yours in anyway? I was also told when I paid for this that it has Sat Nav capabilities I just need an SD card with the software on, is that true? I've also attached a couple of photos :-).
  20. Hi guys, I live on the Costa del Sol and have just bought a 2010 Ford Focus Titanium. It is fitted with a Sony CD (Generation 2) audio unit, and pressing the CD/AUX button brings up USB as a menu option. I have also found in the unit behind the handbrake (under the armrest) a 12V power socket, an Aux jack socket, and a USB connector. When I connect a USB stick with mp3 songs on it the stick illuminates, indicating that it is powered, but then selecting USB from the CD/Aux menu it says USB not fitted! Am I doing something wrong, or is this USB connector just for charging?
  21. Hi everyone, This seems to be an issue posted couple of years ago but didn't find a solution. Apologies for my restricted car knowledge but keen to learn. Basically, I used to press the MAX button on my heating control unit and hot air used to blow within 10 seconds. Now, no matter what temp the car is set to, even at 30 degrees the car still blows cold air even after the car has been driving for hours. I've been told by Halfords that it's the "flap" which sounds right as when I used to turn the heating on there was a clear recognisable sound like a flap closing after 2 seconds and then the car would blow hot air in seconds. Now there is no such noise when I turn the heating on. He said along the lines the flap should close and blow hot air and open for cold air. At the moment its not closing? I've been told by one mechanic that I should just change the entire heating unit or something along those lines. If it is this "flap", which parts would I require to order? Thanks for looking! Rik
  22. So yesterday i had a 17 plate Audi S3 rear end me in the focus :( How i out-breaked him i don't, know but credit to Ford brakes ensuring i did not hit the child chasing his football into the road! My question is now, is an RS rear bumper a straight fit to my titanium or will the rear arches be wider and cause the bumpers to not sit flush? I also presume that the boot lids (mine has a nice dent now) are all the same throughout the mk2 facelift focus range? Meaning i can in theory get a replacement boot from any mk2 focus thats being broken for parts?
  23. tank121

    Cant get into Focus

    Following on from my earlier thread about the mobile phone battery icon and mobile signal not showing on the left hand screen. I successfully updated the software last night using a usb stick and the icons were present and locked the car using the fob. Came out to go to work this morning and my car would not open using the fob or the manual key underneath the top cover any ideas? Does the manual key not work if the battery is completely dead etc? 2nd fob is the same.
  24. Does a car of this year and model show mobile phone signal strength on the left hand screen? Cant seem to find it and my Wife's horrible orange display does! Driving me mad!
  25. Hi All, I’m a newbie from Norfolk. Just picked up my new Mk 8 Fiesta today and so far, really enjoying it!