• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.

Search the Community

Showing results for tags 'clutch st170 focus problem'.

More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Welcome to Ford Owners Club
    • Review your Ford
    • Discount Scheme
    • New Member Introductions
    • Was it you!? FOC Members Spotted!
    • General Ford Related Discussions
    • General Chat
    • Ford Guides
    • Show off your motor!
    • Car Insurance Discussions
  • Ford Models
    • Ford Fiesta Club
    • Ford Focus Club
    • Ford Mondeo / Vignale Club
    • Ford Mustang Club
    • Ford KA / StreetKA Club
    • Ford Kuga Club
    • Ford Edge Club
    • Ford B-Max Club
    • Ford C-Max Club
    • Ford S-Max Club
    • Ford Galaxy Club
    • Ford EcoSport Club
    • Ford Fusion Club
    • Ford Puma Club
    • Ford Escort Club
    • Ford Sierra Club
    • Classic Ford
    • Ford Transit Club
    • Ford Ranger Club
  • Buy & Sell
    • Club Cars For Sale
    • Ford Parts For Sale
    • Classifieds
    • General Items (Non Ford Related)
    • Wanted
    • eBay Finds
    • Buy & Sell Archive
  • Traders
    • Visit Owners Club Insurance Page
    • Opie Oils
    • Advertise Here
  • Ford Modifications and Projects
    • mountune Discussions
    • Photoshopped Ford Photos
    • Ford Project and Build Threads
    • Ford Modification Discussions
  • General Forums
    • Ford Owners Club Meets & Regional Discussion
    • Maintenance / Servicing / MOT Discussions
    • Dealer Problems & Consumer Advice
    • Technical Knowledge
    • Wheels & Tyres
    • Detailing your Ford
    • Audio & Electronics
    • General Site Requests
    • Computing, Gaming and Geeky
    • Dash Cam Videos
    • Ford Motorsport
  • Back Office
  • Ford How-To Guides


  • Ford Reviews
  • General Ford Guides - Modern Fords
  • Ford Fiesta Guides
  • Ford Buyers Guides
  • Ford Focus Guides
  • Ford Fusion Guides
  • Ford C-Max Guides
  • Ford S-Max Guides
  • Ford Ka Guides
  • Ford Mondeo Guides
  • Ford Kuga Guides
  • Ford Galaxy Guides
  • Ford Puma Guides
  • Ford Escort Guides


  • Community Calendar


  • Articles


  • Articles


  • Official Ford Videos

Found 1 result

  1. St170 2004 Clutch Issue

    Hi there, I have a question about an issue I have experienced recently. I have a 2004 Ford Focus st170 and was recently on fast single carriageway road. I wanted to overtake a lorry so I dropped down into 2nd gear at around 4000 rpm in preparation. I then put my foot down until the rev counter neared the redline (can't remember if it hit or not) then changed into 3rd. Suddenly my clutch seemed to disengage and wouldn't engage in any gear despite what I was doing with the pedal or gear stick. I was left rolling toward the side of the road while still being able to rev my engine from idle. I stopped on the side of the road and noticed that my clutch pedal wouldn't go all the way down as if something was physically stopping it at the bottom. It still wouldn't engage in any gear (my engine was idling and revving happily independent of the clutch). A few minutes later, I tried engaging my clutch again. It sort of worked this time but only very slightly (The clutch pedal still wouldn't go all the way down). I turned my engine off then a few minutes later tried it again. Everything was now completely back to normal! Can anyone please explain this. I find it very confusing. Why would my clutch feel physically damaged and not work but them seem completely fine a few minutes later? I need to know if this is something that might return or something I need to get fixed before it really does some damage. Help would be greatly appreciated. Thank you, Tom