Search the Community

Showing results for tags 'windscreen'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to Ford Owners Club
    • Review your Ford
    • Discount Scheme
    • The New Ford Owners Club Collection
    • New Member Introductions
    • Was it you!? FOC Members Spotted!
    • General Ford Related Discussions
    • General Chat
    • Ford Guides
    • Show off your motor!
    • Car Insurance Discussions
  • Ford Models
    • Ford Fiesta Club
    • Ford Focus Club
    • Ford Mondeo / Vignale Club
    • Ford Mustang Club
    • Ford KA / StreetKA Club
    • Ford Kuga Club
    • Ford Edge Club
    • Ford B-Max Club
    • Ford C-Max Club
    • Ford S-Max Club
    • Ford Galaxy Club
    • Ford EcoSport Club
    • Ford Fusion Club
    • Ford Puma Club
    • Ford Escort Club
    • Ford Sierra Club
    • Classic Ford
    • Ford Transit Club
    • Ford Ranger Club
  • Buy & Sell
    • Club Cars For Sale
    • Ford Parts For Sale
    • Classifieds
    • General Items (Non Ford Related)
    • Wanted
    • eBay Finds
    • Buy & Sell Archive
  • Traders
    • Visit Owners Club Insurance Page
    • Opie Oils
    • Advertise Here
  • Ford Modifications and Projects
    • mountune Discussions
    • Photoshopped Ford Photos
    • Ford Project and Build Threads
    • Ford Modification Discussions
  • General Forums
    • Ford Owners Club Meets & Regional Discussion
    • Maintenance / Servicing / MOT Discussions
    • Dealer Problems & Consumer Advice
    • Technical Knowledge
    • Wheels & Tyres
    • Detailing your Ford
    • Audio & Electronics
    • General Site Requests
    • Computing, Gaming and Geeky
    • Dash Cam Videos
    • Ford Motorsport
  • Back Office
  • Ford How-To Guides

Categories

  • Ford Reviews
  • General Ford Guides - Modern Fords
  • Ford Fiesta Guides
  • Ford Buyers Guides
  • Ford Focus Guides
  • Ford Fusion Guides
  • Ford C-Max Guides
  • Ford S-Max Guides
  • Ford Ka Guides
  • Ford Mondeo Guides
  • Ford Kuga Guides
  • Ford Galaxy Guides
  • Ford Puma Guides
  • Ford Escort Guides

Product Groups

  • Advertisements
  • Premium Membership

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


First Name


Ford Model


Contributor


Location

Found 44 results

  1. Rich A

    Heated front Screen

    Hi I have a 2007 Zetect Climate Fiesta, with a heated front screen. It Doesn't work, I have checked the screen and I can see the filament (so no aftermarket normal screen). The switch light comes on when pressing the switch, I have checked the fuses (2) and they are fine, and as the rear works fine so I think they share a relay, so I assume that is fine also. I tried looking for the actual connector to the screen by removing the front valance and metal cover above the wiper box, but could not see any wiring or connector. So my question is where is the connector on my model in the engine bay or the interior?? Any help gratefully received. Thanks
  2. Strange fault: Heated Windscreen does not work which I suspect is related SOMEHOW - please bear this in mind. I changed the relay for the heated windscreen last Friday and within an hour, I had the strangest electrical fault I have ever seen happen to me All my dashboard gauges were ready 15% or so HIGHER than the actually were and even had a reading with the engine OFF and car parked - and yes, ALL gauges were affected. After several restarts, the issue seemed to have solved itself but the car acted like the ECU had been reset and error codes erased but it still had the engine management warning light ON I then found that I had ZERO acceleration - even less than the car has with the P2455 error I currently have (This is being investigated and looks to be an ECU issue). Here's the kicker, I removed the replacement relay the following day and the car responded normally for the day - except for the 500yds I travelled when I tried putting it back in again (loss of power again). So I finished the day without the relay in and put it back in this morning to attempt to defrost my windscreen and the car is responding perfectly now (excluding the P2455 error that has been there since I owned the car - limp mode enabled). I suspect an earth leakage somewhere is the initial cause of the error. Any theories as to where to look at all? Could it be something to do with the relay itself that is causing ALL of my issues (including the 5v feedback up the DPF sensor wire that is triggering P2455 error) or is it more likely to be a loose connection somewhere causing glitches that are actually unrelated?
  3. I have just had a new windscreen fitted to my Ford Fiesta Mk3 F/1989 Ghia Low Series spec and it happens to be heated. I would like to add the switch to the blanked-off hole in the dash and use it! Of the four gaps I have, the rear heated windscreen and rear fog lights occupy two; same for the front are not present and blanked-off. I have checked and the relay socket with a mass of wiring to/from it is present though the relay itself is missing. The two 30 amp fuse holders (simply slotted beside the fuse box) and fuses are missing but would be easy to add as would the wiring to/from it. I do not know if the dash switch wiring is present. Has anyone added a functioning heated front window post-factory to any Mk3? My questions are: 1. Is the wiring/ plug for the dash switch present but tucked away somewhere behind the dash? 2. I cannot see wiring to the windscreen or either side of the two missing fuse carriers. Are they present but tucked away? I watched the screen being fitted and the +ve and -ve terminals are accessible. 3. Where can I buy the Ford heated windscreen dash switch (push button with light), the two fuse holders and the relay? 4. Any other tips? Thank you
  4. National Windscreens replaced my screen and supposedly recalibrated the cameras. Car came back in a state (see pics). Broken glass left throughout cab and across leather seats, broken plastic clips found (presumably from the camera surround as it’s not been put back together properly), gap in N/S corner of screen where seals don’t line up, and a white polystyrene bobble on the inside of the glass - in line-of-sight of one of the cameras. Told insurers, passed back to National Windscreens where a regional manager tried saying the gap in screen was supposed to be there to allow water through - until I mentioned I had before and after photos... It has to go back for a second replacement to “give them chance to rectify it” but I really have no confidence in them. Total lack of care. 1) Can anyone tell what the plastic clips might be from? (I’ll try and get better pics). 2) If it comes back a mess a second time what are my options? Could I take it to ford to have it done properly and then try and claim the money back? Or request a different company such as Autoglass?
  5. jimjamyaha

    Auto on heated windscreen

    Hi, just noticed that heated windscreen auto came on even though it's 14c outside. Petrol 2l 2006. Assume that a temperature sensor is on the blink. Both engine thermostat (for coolant) and the external / outside air temp are working well. Are there any other ones to check for incorrect readings? Thanks.
  6. Hello Guys! I'm new here, and posting my question as I have not found any solution yet... I have a 2009 Ford Focus MK2.5, and have the following issue: when I use the windscreen washer, there is a quite big leak from the washer jets on the bonnet - besides it is quite ugly, I don't think it is good for the paint either. I tried to use the washer only at higher speeds, but same happens. I also tried to point the jets a bit higher, but nothing changed. Do you have any idea what to do in such case? Thanks in advance!
  7. Lippedout

    Replace Washer Motor

    Where do I find the washer motor and how do I replace. Washers not working no sound I have checked the fuse.
  8. mattwlkr

    Windscreen issues

    Hello, I have poor visibility through my windscreen. I've tried cleaning and polishing but its still pretty poor. I was hoping the polish would fill the little pits. There are quite a few tiny scratches/chips/pits on the windscreen that causes quiet a bit of glare. A lot of headlights seem over bright these days which doesn't help; unless its just me. Any ideas how to reduce the glare? - Matt
  9. Dead_Fred

    Windscreen Heater Problem

    Hi, I’ve got a 2012 Focus Titanium and it’s developed a couple of electrical issues and I’m wondering if anyone can help before I go to the expense of getting someone to look at it. To begin with, whenever the windscreen heater or fans aren’t turned off (either via the Max button or just the windscreen fan button) the hill start assist would kick it and turn off straight away. so I turned off Hill Start Assist and everything was fine for about 2 weeks and all of a sudden the same issue is happening but with the tire pressure. Has anyone got any idea why? Thanks
  10. Anyone know the cost of a heated windscreen for a fiesta? Just bought a Cat C and only noticed there is no heated windscreen, when there should be! Thanks in advance.
  11. Hi I had a look at removing a focus mk2 windscreen today. Could do with a little advise before I continue though. I have got the wire to cut through the adhesive. Do you need to take the trim on the edge of the screen out first.i tried to do this, but it kept breaking off. Not sure if it should come out with the screen, or to take it out first. I' assuming a new screen doesn' come with the trim on it. Just wondered if anyone had any experience in this area. I would be great full of anyone' input.
  12. Hi I had a look at removing a focus mk2 windscreen today. Could do with a little advise before I continue though. I have got the wire to cut through the adhesive. Do you need to take the trim on the edge of the screen out first.i tried to do this, but it kept breaking off. Not sure if it should come out with the screen, or to take it out first. I' assuming a new screen doesn' come with the trim on it. Just wondered if anyone had any experience in this area. I would be great full of anyone' input.
  13. Hi all I have noticed on my fiesta 2012 that the scuttle (i believe is the right name - not sure) has come away from the windscreen glass slightly and filled with grunge which i have cleaned out. I was wondering whether this is normal or is it meant to be sealed tight against the glass for water to run over? I have just looked under the bonnet now its raining and seen some water dripping underneath. Any ideas whether this needs replacing, resealing or if its fine as it is? Thanks Rich
  14. Hi guys, After trying to find out as much info that I could to fit a heated screen into my son's Fiesta, we have now hit a brick wall. So, I'm wondering whether anybody has successfully fitted one and if so can they point me in the right direction. So this is where we're up to so far: We have had the heated screen fitted into a 2004 (54plate) Mk6 Fiesta Flame 1.4 Petrol. Unfortunately we were not lucky enough to find any wiring behind the pillar covers. So, we set about sourcing the various bits that we needed. I fitted a double switch (front and rear) in place of the existing rear heated screen switch. The connector was wired for both switches, which I took to be a good sign. Next, after purchasing cable that was man enough to handle the current for the screen, I ran a feed to both sides of the screen and connected each of them to a 32A fuse. From the fuses I then connected those to pin 5 of a Ford 70A relay (which I have mounted into the fuse box) I connected both of the earth tags on the screen to the pillar earth points. The next job was to get power to the relay which I did by running a cable from the FH 60A terminal in the engine bay fusebox and connected that to pin 3 of the relay. Pin 1 of the relay is the supply from Fuse 38 (Ignition) which I spliced into near the fusebox (that took some tracing!!), and this is also connected to one side of the switch (pin5) Now, this is where the brick wall is. The other side of the switch (pin 8) and pin 2 from the relay go to the GEM. I have looked at the GEM and there are no wires in the connecting loom from the switch (although the switch connection has the wire), nor (obviously) is there on from the relay. I understand that the GEM would control the timing that the screen was on etc. So, I have a question, would I be able to piggy back onto the heated rear screen GEM connections and understand that the screen would/may only work if the heated rear window is switched on? Or is there another way round wiring it all in but bypassing the GEM, but still being able to use the original switch? We really want to try to get this to work as my other son has just bought, yes you've guessed it, a Fiesta Flame without a heated screen! Apologies for a long winded post, and hope that it makes sense to someone. Cheers Paul
  15. Ford_lover38

    Windscreen to fail MOT?

    Hey All, I was driving along the seafront today and all of a sudden a squashed tin can flew into my windscreen as I was doing around 25MPH. Its left a scratch on my windscreen would this cause a MOT failure? When i run my finger over it I cant feel a dent or a crack so I assume its just a scratch. I've attached a pic to make it abit more clear. Thanks
  16. Hello fellow Ford Fiesta owners, I've had my car for maybe 5 months or so now and never had an issue with the wipers. I bought new Bosch ones maybe 2-3 weeks ago and they have been brilliant, better than the OEM ones that were on my car when i bought it. However recently my driver side wiper seems to bounce across my windscreen in the rain, it doesn't even bounce when the window is bone dry which puzzles me. I do have a layer of Angelwax H2GO on it but ive had that on it for a while and its never been a problem. Has anyone else come across this issue? I've seen suggestions of bending the arm of the wiper but ive never touched them so i cant see how they are even bent at all, i only lift them up for cleaning the car and even then i do it gently. Surely the new wiper cant need replacing already? The rubber still feels soft. I would point the finger at the hydrophobic layer i have on it but i had it on the windscreen when i bought the new wiper and they worked perfectly fine for weeks. Sorry for the long post of just plain old wipers but it really bugs me when it makes such a noise and bounces on the windscreen when it rains and i live in wales so it rains a lot i just want to get this sorted, i might just buy new wipers AGAIN to see if that fixes the issue?
  17. Hi on my mk3 focus I have two little black boxes on the windscreen, which have wires running into the roof lining. It's a zetec so doesn't have auto lights / wipers - but I haven't seen these on similar models. Are they anything to do with the radio lights coming on when dark and off during the day? Only I thought the dome by the windscreen (between the vents) was what controlled this. Can't see anything on Ford Etis.
  18. Dondolino

    screen washer

    Hi need help!!! ford focus 2013 ( mk3) screen washers jet not squirting water all 3 jets stopped squirting at the same time all of the sudden. the pump is defiantly trying to pump water out I can ear the noise, I have disconnect the tube under the bonnet to check if front jets are blocked but no water is coming out, also I have syphoned the scrennwash bowl few times with clean water few bits of crap come out but jets still not delivering water!!!! Any help will be much appreciated.
  19. I am having a few issues with my heated windscreen on my mk2 Estate, only the passenger half appears to be working! Is this an easy fix or will I be looking at something expensive!
  20. Get in the car this morning and there was a huge amount of condensation not just fogged up but actual drops of water. I had to wipe this off with a cloth and squeezed out a load of water, after the heated screen and warm air vents did nothing to help. We had loads of heavy rain last week and maybe some got into the car, but anyone else have this problem with their Focus? Now I have streaks all over the window where I have wiped it, especially when driving towards the sun which is low in the sky - any suggestions of getting it back to the way it was?
  21. charlierwalker

    Heated Windscreen Issues

    Hello Guys I have a 2011 Ford Focus Titanium MK3 and I am having repeated problems with my Quick Clear Windscreen. I bought the car in September 2014, and shortly after collecting it, I discovered a fault so I got the garage to fix it under warranty and they replaced the screen. 11 months later, a similar fault developed so I contacted the company who fitted it, and they then came and replaced the windscreen again for me. It has now been 9 or 10 months and my heated windscreen has started doing this. I am starting to wonder, there is either 1 of 2 things happening here. 1. They are using cheap quality windscreens. 2. I have an electrical problem that is re-occuring. From the pictures, what do you guys think?
  22. Hi I have a 09 plate Mk 3 Focus Titanium and I need to replace the dashboard, windscreen, plastic landing panel and bumper support at the front, I've looked online at parts from a Mk 2 Focus and they look the same as the Mk3, I just wondered if anyone knows for certain if parts from a Mk2 will fit my Mk3 please? Thanks
  23. Hello all, Recently I have noticed the decay on windscreen wiper pads leaving a smudged line after wiping the screen. I've looked online and cannot find the replacement pads anywhere - only full blade replacements. Does anyone have the part number or any links as to where I can buy replacements. Cheers!
  24. Last July while on holiday we had our windscreen replaced by autoglass who we can't fault. Tuesday we had a hot sunny day for a change and Tuesday night we had a cold night. Anyhow when I went out to the car this morning I was met with this..... No idea when it happened but can only assume that since the MOT (two weeks ago) a stone has hit the screen and I haven't heard it and the hot/cold has made it go "bang during the night!"
  25. Hi All, I would be grateful if you could advise me on this. I was cleaning my wipers the other day and noticed the plastic trim at the bottom of the windscreen is loose. I worried lots of rain water will be getting in there , potentially causing damage rust. Do you think I can just superglue it back in place or fit some rubber trim? any advise welcome. Thank you please