Sign in to follow this  
kis2006

Ka wont start

Recommended Posts

Hello, I wonder if anyone can help with this issue.

(2007 Ka Luxury Duratec 1.3 8v, 25k miles, garaged, battery replaced 8 months ago)

Came to the car the other day and as soon as it fired it stopped (instantly, no splutter)
Then it refused to fire again, although it always turns over fine.
I did, however, notice that I couldn't hear the fuel pump prime.
So I swapped the fuel pump relay around and checked the fuse (both seem ok); Following this; I could hear the fuel pump again but it only started briefly, then no fuel pump again.
Next I plugged in a code reader but found no DTC codes at all, so I tried another code reader but again no codes. I know the code reader was working because I could see the live data like throttle position and temps.
Then I decided to unplug the battery overnight and in the morning it fired and ran perfectly for 10 minutes or so, but after turning it off then trying to restart - no fuel pump prime - no start.
So I unplugged the battery again for a few hours and again it started perfectly, so I went for 10 mile drive and the car ran perfectly. Turned off and yep - no fuel pump prime again- no start.
After trying to start it a couple of times, it then worked perfectly and I have tried a couple of times again and it has worked first time. There are still no codes to read other than p1001 which I believe is OBD cycle not complete. Sadly I can't use the car because I can't risk it not starting again.

Any experiences or suggestions will be gladly received.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this