Jump to content
Do Not Sell My Personal Information


Trying to identify part..


Jwatson
 Share

Recommended Posts

Hi guys

ive got a focus 2006 zetec tdci

im getting a whooshing hissing noise from the front while turbo kicks in. Have identified where it's coming from (split in a hose) but I don't know what the part is called to replace it. Have attached a few photos hopefully someone can help me out

Thanks!

IMG_6845.JPG

IMG_6848.JPG

IMG_6850.JPG

Link to comment
Share on other sites

Hi,

Thanks, proved quite difficult to find but believe it is the attached.

Mine had slots for the jubilee clips to slot into where as this one doesn't (nor does it seem to include them)

Does anyone know what size or where i can get the clips to secure this to the pipes?

Thanks

s-l500.jpg

Link to comment
Share on other sites

52 minutes ago, Jwatson said:

Hi,

Thanks, proved quite difficult to find but believe it is the attached.

Mine had slots for the jubilee clips to slot into where as this one doesn't (nor does it seem to include them)

Does anyone know what size or where i can get the clips to secure this to the pipes?

Thanks

s-l500.jpg

I would of thought jubiliee clips would still hold this on? even without the slots

Link to comment
Share on other sites

Yes you are probably right. I have looked high and low for an identical part and can't find it anywhere. Was just wondering if it's a good idea to reuse the clips from the faulty one or buy new ones? 

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership