mickter

fan running on

Recommended Posts

Hi all.

I have a 2016 c-max 1.5tdci.

after 1/2 hour driving home I turned engine off,fan kept running (louder than normal)and ran for more than a couple of minutes,

checked temp and it was ok.

started engine again and turned off , fan stayed on for a minute or two again but normal noise level.

Not had this happen before,any ideas.

Cheers Mick.

Share this post


Link to post
Share on other sites
 

Sounds like it's trying to do a DPF regen.

Go for a spirited drive, get it up to speed and keep the gears lower than you normally would to help once it's warmed up.

I think there is something in the manual about it.

Share this post


Link to post
Share on other sites

It was doing a regen when you switched of the fan runs on to cool things down as the exhaust and other bits get very hot, without the fan the heat soak would be high and possibly cause damage.

Share this post


Link to post
Share on other sites

Took car out yesterday and followed book instructions .

seems all ok.

Thanks for your help. Mick.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.