JayG96

Mk6 Fiesta 1.6 tdci stage 3 issues

Recommended Posts

hi unsure if im posting this in the right place but here goes, ive recently done a lot of modding to my 1.6 tdci fiesta including egr blank, decat, sportex exhaust system, 110 focus injectors, brand new 110 focus turbo, oil catch can from nb styling with a ram air con filter, the problem started when it went to be mapped they tried mapping it but could only reach 94bhp (88 standard) @ 2700 revs after that it wouldnt boost. it turned out that the actuator was not calibrated correctly so i calibrated it and the car seemed to behave a bit better but found out that the veins on the vnt turbo wasnt calibrated either so i bought yet another 110 focus turbo and again seems to have improved. the car pulls great until around 3000 revs and which point it doesn't want to boost anymore any suggestion or am i missing something?

64269874_2361143314149962_1046493748315291648_n.jpg

Share this post


Link to post
Share on other sites
 

I'd suggest the vanes still aren't right tbh.  It's difficult to set them up properly.  How are you actuating them btw?  Using the Focus boost solenoid?

What exactly is happening at 3k - does it maintain ~30psi or is the boost dropping off at that point?  Any fault codes on Forscan?

Share this post


Link to post
Share on other sites

im using the normal actuator that is "meant to be" set up on this new turbo havent tested it cuz dont have anyway to do it im using the fiesta boost solenoid although the mappers tried other solenoids as they thought that was the problem but didnt change anything, and the boost is dropping off at 3k up until that point pulls really well

Share this post


Link to post
Share on other sites

What mapping company did you use? 94hp is just a small increase from standard. 

On 6/13/2019 at 7:34 PM, JayG96 said:

im using the normal actuator that is "meant to be" set up on this new turbo havent tested it cuz dont have anyway to do it im using the fiesta boost solenoid although the mappers tried other solenoids as they thought that was the problem but didnt change anything, and the boost is dropping off at 3k up until that point pulls really well

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.