JudgeMental

Tyre Sensors Malfunction

Recommended Posts

Hi All

Can anyone help with an issue on my Grand C Max 1.6 TDCI Titanium 2014

I had the following message pop up, ('tyre sensors not detected') but if I reset the tyre pressure in Driver Assist it happily accepts this and the message disappears for 20 miles or so before the reappearing. The car has just passed its MOT with flying colours so this wasn't picked up during the test apparently - any idea if this is due to missing or faulty pressure sensors on one of the wheels? How would I go about finding the culprit and replacing?

I did find a guide on doing a complete reset on a Focus that involves pressing the hazard light button 5 times then deflating and reflating each tyre in turn, but this doesn't seem to apply to the C Max

Any advice gratefully received!

 

Tyre Sensor.jpg

Share this post


Link to post
Share on other sites

I think you may have the older type sensors that rely on the ABS sensors measuring the difference in wheel rotation, when working properly does it show individual wheel faults or just a low preassure warning if the latter its the older system and it could be an ABS sensor, I of course could be tottaly wrong.

Share this post


Link to post
Share on other sites

Hi, thanks for your reply!

There are no other faults showing up, it just displays that message then the yellow tyre warning light flashes for a while before staying on solid. I reset the tyre pressures (see below), the system says 'tyre pressures stored' then seems happy till it repeats the 'tyre sensors not detected message' roughly 20miles/minutes later...

Is there a way of narrowing it down to a particular sensor if it is to do with the ABS?

Thanks in advance

20190805_133053.jpg

Share this post


Link to post
Share on other sites

Forscan will read which ABS sensor is at fault though i would have thought you traction control light may be on..

i take it you have actuall physically checked the tyre pressurs as you may have a slow puncture.

Share this post


Link to post
Share on other sites

Thanks again for your reply

I checked the tyre pressures - they were all fine if a little high, I adjusted them to the correct level but no effect on the problem.

The car is in for a service today so I'll ask them to have a look at the fault codes and see what they come up with. For future use, can you recommend a decent OBD2 interface I can use with Forscan? I have used a cheap Chinese one found on Ebay which was reasonably useful, but working out a fault is difficult enough without having to decode the translation first!

Share this post


Link to post
Share on other sites
23 minutes ago, JudgeMental said:

, can you recommend a decent OBD2 interface I can use with Forscan? I have used a cheap Chinese one found on Ebay which was reasonably useful, but working out a fault is difficult enough without having to decode the translation first!

Yes the The ones from tunnelrat are generally thought to be the best.  https://tunnelrat-electronics.fwscart.com/USB_Modified_ELM327/p4541936_17045457.aspx

I use one completely reliable, the drivers for it are on a separate page.

Share this post


Link to post
Share on other sites

Thanks again - I've ordered the wifi version, they were a lot cheaper than I expected!

I had the car serviced yesterday, they gave me a list of the fault codes before they cleared them all - B124D-02 Tyre pressure sensor is the one I'm interested in. They also found damage to the inside of the rear alloy wheel which makes me wonder if the wheels have been rotated (maybe after hitting a pot hole with the front wheel - inside damage to a rear wheel seems unlikely!) - maybe the TPMS needs retraining after wheel rotation?

I found the following on a webdoc, this possibly relates to the F-150 but may still be relevant - 

image.thumb.png.e84dd1def6b500e234d58f18d9999a3a.png

image.thumb.png.d1a4f28e81d71bff319b5ec1f13cdad9.png

image.thumb.png.4d0028937541437c8d5a3796a43d4944.png

image.thumb.png.49b585e644a047941540b9995fbd5d3d.png

When the Tunnel Rat arrives I'll see what I can find out.

Apologies if I'm oversharing - I'm just assuming others may find this info helpful if they have similar faults!

Share this post


Link to post
Share on other sites
1 hour ago, JudgeMental said:

Thanks again - I've ordered the wifi version, they were a lot cheaper than I expected

When the Tunnel Rat arrives I'll see what I can find out.

Apologies if I'm oversharing - I'm just assuming others may find this info helpful if they have similar faults!

Just remember that the wifi is local low powered,  not you home wifi. IMHO you are better with the USB version.

dont worry about oversharing as you say it might help someone 

Share this post


Link to post
Share on other sites
21 hours ago, pragmatix said:

Just remember that the wifi is local low powered,  not you home wifi. IMHO you are better with the USB version.

dont worry about oversharing as you say it might help someone 

I thought I'd start with one connected to my phone - once I get the hang of it and I'm ready to do more damage I'll try connecting to a laptop!

The Wi-fi version arrived yesterday from Tunnelrat (1 day after ordering it!), I've managed to get it connected and working but I'll need to work out what I'm doing before I can get stuck in to the tyre sensor issue - I'll let you know if I make any progress on it!

Thanks again for the help

Share this post


Link to post
Share on other sites

I have the wifi version and the USB version from Tunnelrat. I originally had the usb one for connecting to laptop, but find the wifi one handier to keep in the glovebox and use with my iPhone.

The downside of using it with phone is that whilst Forscan is free for a windows laptop, it is about 6 quid to put the app on your phone (apple or android). But that is a small price to pay I feel for the usefulness of it.  Never had a problem with the wifi signal.

Share this post


Link to post
Share on other sites

buy a cheap tpms reader/ learn tool off ebay.£6.50. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.