Recommended Posts

Morning all,

I've got a 57 plate 1.8 tdci and it's just done something a bit random. Driving along, suddenly the back lights and LCD screen on the instrument cluster all go out and the temp guage falls to zero, but the rev counter and speedo still work. A couple of minutes later, it comes back to life with the airbag fault light staying on until the car has been restarted. 

Am i right in thinking the cluster is potentially goosed?

Share this post


Link to post
Share on other sites
Morning all,
I've got a 57 plate 1.8 tdci and it's just done something a bit random. Driving along, suddenly the back lights and LCD screen on the instrument cluster all go out and the temp guage falls to zero, but the rev counter and speedo still work. A couple of minutes later, it comes back to life with the airbag fault light staying on until the car has been restarted. 
Am i right in thinking the cluster is potentially goosed?
Hi mate
Are you have read codes?
Witch cluster you have? Withred LCD or big colours LCD?

Wysłane z mojego SM-G973F przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Nah, not yet mate. I'm working in Cumbria and the car is over in the North East.

It's the one with the red LCD.

Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.